LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 09-22-2004, 04:03 PM   #1
mabuse
LQ Newbie
 
Registered: Jul 2004
Location: germany
Distribution: SuSE 9.1
Posts: 4

Rep: Reputation: 0
problems playing video files with mplayer


Hello,

after reading many posts about playing different video and audio file types under linux i have installed mplayer since it is said to play almost anything. Unfortunately in my case this is only true for audio files. Everytime i try to play a video file the program crashes with the following error message:

Error opening/initializing the selected video_out (-vo) device.

here's the full output after starting mplayer :

marc@linux:~> gmplayer
MPlayer 1.0pre4-3.3.3 (C) 2000-2004 MPlayer Team

CPU: Advanced Micro Devices Athlon MP/XP Thoroughbred 1795 MHz (Family: 6, Stepping: 0)
Detected cache-line size is 64 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 0
Compiled with runtime CPU detection - WARNING - this is not optimal!
To get best performance, recompile MPlayer with --disable-runtime-cpudetection.
Reading config file /etc/MPlayer/mplayer.conf
Reading config file /home/marc/.mplayer/config
[cfg] read config file: /home/marc/.mplayer/gui.conf
Reading config file /home/marc/.mplayer/gui.conf
vo: X11 running at 1280x1024 with depth 24 and 32 bpp (":0.0" => local display)
Reading /home/marc/.mplayer/codecs.conf: Can't open '/home/marc/.mplayer/codecs.conf': Datei oder Verzeichnis nicht gefunden
Reading /etc/MPlayer/codecs.conf: 66 audio & 176 video codecs
font: can't open file: /home/marc/.mplayer/font/font.desc
Font /usr/share/MPlayer/font/font.desc loaded successfully! (206 chars)
Linux RTC init error in ioctl (rtc_irqp_set 1024): Keine Berechtigung
Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your system startup scripts.
Using usleep() timing
Can't open input config file /home/marc/.mplayer/input.conf: Datei oder Verzeichnis nicht gefunden
Input config file /etc/MPlayer/input.conf parsed: 53 binds
Opening joystick device /dev/input/js0
Can't open joystick device /dev/input/js0 : Kein passendes Gerät gefunden
Can't init input joystick
Setting up LIRC support...
mplayer: could not connect to socket
mplayer: Keine Berechtigung
Failed to open LIRC support.
You will not be able to use your remote control.
SKIN dir 1: '/home/marc/.mplayer/Skin'
SKIN dir 2: '/usr/share/MPlayer/Skin'

Playing /windows/Daten/Eigene Videos/Windows Movie Maker-Beispieldatei.wmv.
ASF file format detected.
VIDEO: [WMV1] 320x240 24bpp
Clip info:
name:
author: Microsoft
copyright: 1/1/2001
comments:
==========================================================================
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
AUDIO: 32000 Hz, 2 ch, 16 bit (0x10), ratio: 4000->128000 (32,0 kbit)
Selected audio codec: [ffwmav2] afm:ffmpeg (DivX audio v2 (ffmpeg))
==========================================================================
Error opening/initializing the selected video_out (-vo) device.


Exiting... (Exit)
marc@linux:~>

I am using SuSE9.1 and i am a newbie to linux so i would really be very grateful for any help
with this because it is really getting on my nerves that i still have to use windows to view video
files.
- i installed the win32 codec pack to try to make kaffeine play the files but this was also negative....... argh.

mabuse
 
Old 09-23-2004, 01:45 AM   #2
Hitokiri_X
Member
 
Registered: Mar 2002
Distribution: Slackware Current
Posts: 99

Rep: Reputation: 15
You're having a problem with the -vo setting.Try changing it to another setting,mplayer -vo help.
 
Old 09-23-2004, 07:43 AM   #3
PenguinPwrdBox
Member
 
Registered: Oct 2003
Location: /illinois/chicago
Distribution: Slackware/Gentoo/FC/RHEL
Posts: 568

Rep: Reputation: 30
I would also try to play an mpeg, as opposed to a .wmv......
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
mplayer not playing .wmv files??? matthewa Linux - Software 11 06-14-2005 06:04 PM
Mplayer and Xine create only green outputs on playing video files sn_piranha Linux - Software 5 10-10-2004 09:36 PM
only audio but no video when playing .mpeg files with MPlayer-0.90 koodoo Linux - Newbie 3 10-01-2004 04:43 AM
MPlayer is not playing video File linuxeagle Linux - General 0 03-31-2004 10:14 AM
mplayer not playing video pankajmathur Linux - Software 1 05-12-2003 02:56 PM


All times are GMT -5. The time now is 02:46 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration