LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 08-29-2006, 01:00 AM   #1
depam
Member
 
Registered: Sep 2005
Posts: 824

Rep: Reputation: 30
phpldapadmin error


I'm kinda new to LDAP.. I've installed slapd and phpldapadmin for easy encoding of data. After inputting one data, i get the following error:

Could not add the object to the LDAP server.

LDAP said: Strong(er) authentication required
Error number: 0x08 (LDAP_STRONG_AUTH_REQUIRED)
Description: This LDAP server requires strong (encrypted) authentication, not clear text.

Anyone knows what to do?
 
Old 08-29-2006, 01:06 AM   #2
drkstr
Senior Member
 
Registered: Feb 2006
Location: Seattle, WA: USA
Distribution: Slackware 11.0
Posts: 1,191

Rep: Reputation: 45
Are you using SSL (Secure Socket Layer)?

...drkstr
 
Old 08-29-2006, 02:49 AM   #3
depam
Member
 
Registered: Sep 2005
Posts: 824

Original Poster
Rep: Reputation: 30
Honestly,

I don't know. Here's my slapd.conf:

# Allow LDAPv2 binds
allow bind_v2

# This is the main slapd configuration file. See slapd.conf(5) for more
# info on the configuration options.

#######################################################################
# Global Directives:

# Features to permit
#allow bind_v2

# Schema and objectClass definitions
include /etc/ldap/schema/core.schema
include /etc/ldap/schema/cosine.schema
include /etc/ldap/schema/nis.schema
include /etc/ldap/schema/inetorgperson.schema

# Schema check allows for forcing entries to
# match schemas for their objectClasses's
schemacheck on

# Where the pid file is put. The init.d script
# will not stop the server if you change this.
pidfile /var/run/slapd/slapd.pid

# List of arguments that were passed to the server
argsfile /var/run/slapd.args

# Read slapd.conf(5) for possible values
loglevel 0

# Where the dynamically loaded modules are stored
modulepath /usr/lib/ldap
moduleload back_bdb

#######################################################################
# SSL:
# Uncomment the following lines to enable SSL and use the default
# snakeoil certificates.
#TLSCertificateFile /etc/ssl/certs/ssl-cert-snakeoil.pem
#TLSCertificateKeyFile /etc/ssl/private/ssl-cert-snakeoil.key

#######################################################################
# Specific Backend Directives for bdb:
# Backend specific directives apply to this backend until another
# 'backend' directive occurs
backend bdb
checkpoint 512 30

#######################################################################
# Specific Backend Directives for 'other':
# Backend specific directives apply to this backend until another
# 'backend' directive occurs
#backend <other>

#######################################################################
# Specific Directives for database #1, of type bdb:
# Database specific directives apply to this databasse until another
# 'database' directive occurs
database bdb

# The base of your directory in database #1
suffix "dc=armscor,dc=com,dc=ph"

# Where the database file are physically stored for database #1
directory "/var/lib/ldap"

# Indexing options for database #1
index objectClass eq

# Save the time that the entry gets modified, for database #1
lastmod on

# Where to store the replica logs for database #1
# replogfile /var/lib/ldap/replog

# The userPassword by default can be changed
# by the entry owning it if they are authenticated.
# Others should not be able to see it, except the
# admin entry below
# These access lines apply to database #1 only
access to attrs=userPassword
by dn="cn=admin,dc=armscor,dc=com,dc=ph" write
by anonymous auth
by self write
by * none

# Ensure read access to the base for things like
# supportedSASLMechanisms. Without this you may
# have problems with SASL not knowing what
# mechanisms are available and the like.
# Note that this is covered by the 'access to *'
# ACL below too but if you change that as people
# are wont to do you'll still need this if you
# want SASL (and possible other things) to work
# happily.
access to dn.base="" by * read

# The admin dn has full write access, everyone else
# can read everything.
access to *
by dn="cn=admin,dc=armscor,dc=com,dc=ph" write
by * read

# For Netscape Roaming support, each user gets a roaming
# profile for which they have write access to
#access to dn=".*,ou=Roaming,o=morsnet"
# by dn="cn=admin,dc=armscor,dc=com,dc=ph" write
# by dnattr=owner write

#######################################################################
# Specific Directives for database #2, of type 'other' (can be bdb too):
# Database specific directives apply to this databasse until another
# 'database' directive occurs
#database <other>

# The base of your directory for database #2
#suffix "dc=debian,dc=org"

When I issued the command ldapadd, It prompts for:

SASL/DIGEST-MD5 authentication started
Please enter your password:

When I enter a password, it says:

ldap_sasl_interactive_bind_s: Internal (implementation specific) error (80)
additional info: SASL(-13): user not found: no secret in database

My guess is I need to open bdb and gain permission to it.
 
Old 08-29-2006, 10:42 AM   #4
drkstr
Senior Member
 
Registered: Feb 2006
Location: Seattle, WA: USA
Distribution: Slackware 11.0
Posts: 1,191

Rep: Reputation: 45
Well from the original error you posted, it looks like it won't add anything to the database sine you are not using encrption.

Code:
#######################################################################
# SSL:
# Uncomment the following lines to enable SSL and use the default
# snakeoil certificates.
#TLSCertificateFile /etc/ssl/certs/ssl-cert-snakeoil.pem
#TLSCertificateKeyFile /etc/ssl/private/ssl-cert-snakeoil.key
This section is probably what you're looking for.

regards,
...drkstr
 
Old 08-29-2006, 07:22 PM   #5
depam
Member
 
Registered: Sep 2005
Posts: 824

Original Poster
Rep: Reputation: 30
I tried to uncomment it but when I issued the command ldapadd, It prompts for:

SASL/DIGEST-MD5 authentication started
Please enter your password:

When I enter a password, it says:

ldap_sasl_interactive_bind_s: Internal (implementation specific) error (80)
additional info: SASL(-13): user not found: no secret in database
 
Old 08-31-2006, 01:27 PM   #6
rem1986
LQ Newbie
 
Registered: Apr 2004
Location: Cuba
Distribution: Debian Sarge 3.1
Posts: 23

Rep: Reputation: 15
ldap ...

use ldapadd with the option -x for simple authentication instead of SASL
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't create LDAP entries with phpldapadmin dlublink Linux - Networking 6 12-12-2007 03:41 AM
phpldapadmin doesn't process tree.php pasmen Linux - Software 1 08-14-2006 04:53 PM
Phpldapadmin problem leiw Linux - General 2 07-25-2006 02:18 AM
Unable to get the ldaptree in phpLDAPadmin Uday123 General 0 11-15-2005 05:42 AM
upgrade breaks phpldapadmin gdsword Debian 2 11-04-2005 03:41 AM


All times are GMT -5. The time now is 05:40 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration