LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 11-25-2006, 02:24 AM   #1
asert
LQ Newbie
 
Registered: Nov 2006
Posts: 3

Rep: Reputation: 0
no video when mplayer play rmvb


now mplayer play rmvb only have sounds but no video,but it's OK before I delete some libraries that list by command: deborphan --guess-all;

the newest codecs I have installed to /usr/lib/codecs,and totem can play rmvb using the codecs OK(but I dont like totem);

I guess maybe I delete one or more libaries that important for mplayer load dll;but I dont know anything else;

followed output show some error messages when I using mplayer to play rmvb:
could anyone help to let mplayer work well again?
Code:
debian:~# mplayer "/home/Downloads/Anime/[SumiSora][Kanon][07][GB][RV10][600K].rmvb" -v
MPlayer 1.0rc1-4.1.2-DFSG-free (C) 2000-2006 MPlayer Team
CPU: Intel(R) Pentium(R) 4 CPU 1.80GHz (Family: 15, Model: 1, Stepping: 3)
CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled with runtime CPU detection.
get_path('codecs.conf') -> '/root/.mplayer/codecs.conf'
Reading /root/.mplayer/codecs.conf: Can't open '/root/.mplayer/codecs.conf': No such file or directory
Reading /etc/mplayer/codecs.conf: Can't open '/etc/mplayer/codecs.conf': No such file or directory
Using built-in default codecs.conf.
CommandLine: '/home/Downloads/Anime/[SumiSora][Kanon][07][GB][RV10][600K].rmvb' '-v'
init_freetype
Using MMX (with tiny bit MMX2) Optimized OnScreenDisplay
Using nanosleep() timing
get_path('input.conf') -> '/root/.mplayer/input.conf'
Can't open input config file /root/.mplayer/input.conf: No such file or directory
Can't open input config file /etc/mplayer/input.conf: No such file or directory
Falling back on default (hardcoded) input config
Setting up LIRC support...
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.
get_path('[SumiSora][Kanon][07][GB][RV10][600K].rmvb.conf') -> '/root/.mplayer/[SumiSora][Kanon][07][GB][RV10][600K].rmvb.conf'

Playing /home/Downloads/Anime/[SumiSora][Kanon][07][GB][RV10][600K].rmvb.
get_path('sub/') -> '/root/.mplayer/sub/'
[file] File size is 111359798 bytes
STREAM: [file] /home/Downloads/Anime/SumiSora][Kanon][07][GB][RV10][600K].rmvb
STREAM: Description: File
STREAM: Author: Albeu
STREAM: Comment: based on the code from ??? (probably Arpi)
Checking for YUV4MPEG2
ASF_check: not ASF guid!
Checking for NuppelVideo
Checking for REAL
REAL file format detected.
real: Header size: 18
real: Header object version: 1
real: File version: 0
Chunk: PROP (504f5250) (size: 0x32, offset: 0x12)
First index chunk offset: 0x6a077dc
First data chunk offset: 0x3f6
Flags (9): [save allowed]
Chunk: CONT (544e4f43) (size: 0x40, offset: 0x44)
Chunk: MDPR (5250444d) (size: 0xa2, offset: 0x84)
Found new stream (id: 0)
Stream description: Audio Stream
Stream mimetype: audio/x-pn-realaudio
==> Found audio stream: 0
Found audio stream!
version: 5
header size: 68
coded_frame_size: 557
sub_packet_h: 1
frame_size: 557
sub_packet_size: 557
samplerate: 44100, channels: 2
audio fourcc: MP4A (4134504d)
======= WAVE Format =======
Format Tag: 20557 (0x504D)
Channels: 2
Samplerate: 44100
avg byte/sec: 12000
Block align: 557
bits/sample: 16
cbSize: 0
==========================================================================
### skipping 0 bytes of codec info
Chunk: MDPR (5250444d) (size: 0x70, offset: 0x126)
Found new stream (id: 1)
Stream description: Video Stream
Stream mimetype: video/x-pn-realvideo
==> Found video stream: 1
video fourcc: RV40 (30345652)
H.263 ID: 40006000
unknown id: 40006000
### skipping 0 bytes of codec info
Chunk: MDPR (5250444d) (size: 0x256, offset: 0x196)
Found new stream (id: 2)
Stream mimetype: logical-fileinfo
Got a logical-fileinfo chunk
### skipping 536 bytes of codec info
Chunk: DATA (41544144) (size: 0x6a073f0, offset: 0x3ec)
Packets in file: 124802
Reading index table from index chunk (111179740)
size: 174334 bytes
entries: 12451
stream_id: 0
next_header_pos: 111354074
Reading index table from index chunk (111354074)
size: 5704 bytes
entries: 406
stream_id: 1
next_header_pos: 111359778
Reading index table from index chunk (111359778)
size: 20 bytes
entries: 0
stream_id: 2
next_header_pos: 0
Auto-selected RM audio ID = 0
Auto-selected RM video ID = 1
VIDEO:  RV40 [40006000,01081020]  704x396  (aspect 0.00)  30.00 fps
AUDIO:  MP4A [4134504D]
VIDEO:  [RV40]  704x396  24bpp  30.000 fps    0.0 kbps ( 0.0 kbyte/s)
[V] filefmt:11  fourcc:0x30345652  size:704x396  fps:30.00  ftime:=0.0333
Clip info:
 author: sumisora
 comment:
get_path('sub/') -> '/root/.mplayer/sub/'
open: No such file or directory
[MGA] Couldn't open: /dev/mga_vid
open: No such file or directory
[MGA] Couldn't open: /dev/mga_vid
[VO_TDFXFB] Can't open /dev/fb0: No such device.
[VO_3DFX] Unable to open /dev/3dfx.
X11 opening display: :0.0
vo: X11 color mask:  FFFFFF  (R:FF0000 G:FF00 B:FF)
vo: X11 running at 1152x864 with depth 24 and 32 bpp (":0.0" => local display)
[x11] Detected wm supports NetWM.
[x11] Detected wm supports FULLSCREEN state.
[x11] Detected wm supports ABOVE state.
[x11] Detected wm supports BELOW state.
[x11] Current fstype setting honours FULLSCREEN ABOVE BELOW X atoms
[xv common] Drawing colorkey manually.
[xv common] Using colorkey from Xv (0x0101fe).
[xv common] Maximum source image dimensions: 2046x2046
==========================================================================
Opening video decoder: [realvid] RealVideo decoder
realvideo codec id: 0x40006000  sub-id: 0x01081020
opening shared obj '/drvc.so'
Error: /drvc.so: cannot open shared object file: No such file or directory
opening win32 dll 'drvc.so'
Win32 LoadLibrary failed to load: drvc.so, /drvc.so, /usr/lib/win32/drvc.so, /usr/local/lib/win32/drvc.so
win32 real codec handle=(nil)
Error loading dll
ERROR: Could not open required DirectShow codec drvc.so.
Read the RealVideo section of the DOCS!
VDecoder init failed :(
Opening video decoder: [realvid] RealVideo decoder
realvideo codec id: 0x40006000  sub-id: 0x01081020
opening shared obj '/drv4.so.6.0'
Error: /drv4.so.6.0: cannot open shared object file: No such file or directory
opening win32 dll 'drv4.so.6.0'
Win32 LoadLibrary failed to load: drv4.so.6.0, /drv4.so.6.0, /usr/lib/win32/drv4.so.6.0, /usr/local/lib/win32/drv4.so.6.0
win32 real codec handle=(nil)
Error loading dll
ERROR: Could not open required DirectShow codec drv4.so.6.0.
Read the RealVideo section of the DOCS!
VDecoder init failed :(
Opening video decoder: [realvid] RealVideo decoder
realvideo codec id: 0x40006000  sub-id: 0x01081020
opening win32 dll 'drv43260.dll'
Win32 LoadLibrary failed to load: drv43260.dll, /drv43260.dll, /usr/lib/win32/drv43260.dll, /usr/local/lib/win32/drv43260.dll
win32 real codec handle=(nil)
Error loading dll
ERROR: Could not open required DirectShow codec drv43260.dll.
Read the RealVideo section of the DOCS!
VDecoder init failed :(
Opening video decoder: [realvid] RealVideo decoder
realvideo codec id: 0x40006000  sub-id: 0x01081020
opening shared obj '/drvc.bundle/Contents/MacOS/drvc'
Error: /drvc.bundle/Contents/MacOS/drvc: cannot open shared object file: No such file or directory
opening win32 dll 'drvc.bundle/Contents/MacOS/drvc'
Win32 LoadLibrary failed to load: drvc.bundle/Contents/MacOS/drvc, /drvc.bundle/Contents/MacOS/drvc, /usr/lib/win32/drvc.bundle/Contents/MacOS/drvc, /usr/local/lib/win32/drvc.bundle/Contents/MacOS/drvc
win32 real codec handle=(nil)
Error loading dll
ERROR: Could not open required DirectShow codec drvc.bundle/Contents/MacOS/drvc.
Read the RealVideo section of the DOCS!
VDecoder init failed :(
Cannot find codec matching selected -vo and video format 0x30345652.
Read DOCS/HTML/en/codecs.html!
==========================================================================
==========================================================================
Opening audio decoder: [faad] AAC (MPEG2/4 Advanced Audio Coding)
dec_audio: Allocating 4608 bytes for input buffer.
dec_audio: Allocating 49152 + 65536 = 114688 bytes for output buffer.
FAAD: Decoder init done (0Bytes)!
FAAD: Negotiated samplerate: 44100Hz  channels: 2
FAAD: compressed input bitrate missing, assuming 128kbit/s!
AUDIO: 44100 Hz, 2 ch, s16le, 128.0 kbit/9.07% (ratio: 16000->176400)
Selected audio codec: [faad] afm: faad (FAAD AAC (MPEG-2/MPEG-4 Audio) decoder)
==========================================================================
Building audio filter chain for 44100Hz/2ch/s16le -> 0Hz/0ch/??...
[libaf] Adding filter dummy
[dummy] Was reinitialized: 44100Hz/2ch/s16le
[dummy] Was reinitialized: 44100Hz/2ch/s16le
ao2: 44100 Hz  2 chans  s16le
audio_setup: using '/dev/dsp' dsp device
audio_setup: using '/dev/mixer' mixer device
audio_setup: using 'pcm' mixer device
audio_setup: sample format: s16le (requested: s16le)
audio_setup: using 2 channels (requested: 2)
audio_setup: using 44100 Hz samplerate (requested: 44100)
audio_setup: frags:  32/32  (4096 bytes/frag)  free: 131072
AO: [oss] 44100Hz 2ch s16le (2 bytes per sample)
AO: Description: OSS/ioctl audio output
AO: Author: A'rpi
Building audio filter chain for 44100Hz/2ch/s16le -> 44100Hz/2ch/s16le...
[dummy] Was reinitialized: 44100Hz/2ch/s16le
[dummy] Was reinitialized: 44100Hz/2ch/s16le
Video: no video
Freeing 0 unused video chunks.
Starting playback...
A:   0.8 (00.7) of 1450.0 (24:10.0)  3.2%

MPlayer interrupted by signal 2 in module: play_audio
Uninit audio filters...
[libaf] Removing filter dummy
Uninit audio: faad
FAAD: Closing decoder!
vo: uninit ...
debian:~#

Last edited by asert; 11-25-2006 at 06:50 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
mplayer codec rv40 plays rmvb video, but no sound... sirpelidor Linux - Software 5 12-04-2008 06:12 PM
How to play rmvb files with Mplayer ufosnorkis Linux - Software 6 10-19-2006 10:48 PM
How can I play rmvb,rm with Kaffeine and other players? homesp Mandriva 3 05-06-2005 09:45 AM
Can xine play .rmvb? NoThing Linux - Newbie 1 10-25-2004 05:35 PM
can use mplayer to play video, but not gmplayer.... sirpelidor Linux - Software 3 11-23-2003 06:02 AM


All times are GMT -5. The time now is 09:08 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration