LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 07-15-2005, 10:17 AM   #1
Markup
LQ Newbie
 
Registered: Feb 2005
Distribution: RHEL4, SLED10, Ubuntu, Solaris
Posts: 26

Rep: Reputation: 15
no gnome sound events, mtrr overlaps, acpi sleep resume


Hi, sorry for the long title (at least its more descriptive than "3 problems, please help" )

Anyway...

Firstly I can't hear any gnome sound events, on the gnome sound applet from desktop preferences the gnome sound server is enabled and use sounds for events is checked. Also I have checked that the audio files exist. When I click to play a sound event I don't hear anything at all and have maxed the master volumes and checked they are not muted. Aside from this the rest of my sound system is working (CD/DVD, MIDI, MP3 etc) and the the sound event .wav's play fine using xmms or any other media player.

OK second, when I check 'dmesg | tail' I'm getting mtrr overlaps:
Code:
[drm] Initialized drm 1.0.0 20040925
ACPI: PCI Interrupt 0000:00:02.0[A] -> Link [LNKA] -> GSI 9 (level, low) -> IRQ 9
mtrr: 0xe8000000,0x8000000 overlaps existing 0xe8000000,0x400000
[drm] Initialized i915 1.1.0 20040405 on minor 0: Intel Corporation 82852/855GM Integrated Graphics Device
mtrr: 0xe8000000,0x8000000 overlaps existing 0xe8000000,0x400000
[drm] Initialized i915 1.1.0 20040405 on minor 1: Intel Corporation 82852/855GM Integrated Graphics Device (#2)
mtrr: base(0xe8020000) is not aligned on a size(0x300000) boundary
mtrr: 0xe8000000,0x8000000 overlaps existing 0xe8000000,0x400000
ISO 9660 Extensions: Microsoft Joliet Level 1
ISOFS: changing to secondary root
So I done some googling and found out that if use 'lspci -v' (snipped output follows)
Code:
0000:00:02.0 VGA compatible controller: Intel Corp. 82852/855GM Integrated Graphics Device (rev 02) (prog-if 00 [VGA])
        Subsystem: Sony Corporation: Unknown device 8192
        Flags: bus master, fast devsel, latency 0, IRQ 9
        Memory at e8000000 (32-bit, prefetchable) [size=128M]
        Memory at e0000000 (32-bit, non-prefetchable) [size=512K]
        I/O ports at 1800 [size=8]
        Capabilities: <available only to root>

0000:00:02.1 Display controller: Intel Corp. 82852/855GM Integrated Graphics Device (rev 02)
        Subsystem: Sony Corporation: Unknown device 8192
        Flags: fast devsel
        Memory at f0000000 (32-bit, prefetchable) [size=128M]
        Memory at e0080000 (32-bit, non-prefetchable) [size=512K]
        Capabilities: <available only to root>
I should add a 'vram:128' parameter to my kernel's menu.lst entry and that should fix the overlap. Rebooted and still dmesg reports the mtrr overlap

Thirdly, I'm having problems resuming from acpi sleep. I'm using the following shell script:
Code:
#!/bin/bash

#sync the disks.
sync && sync && sync

#Change the screen to VT1 (text mode)
/usr/bin/chvt 1

#perform the actual "go-to-sleep" function.
echo "mem" > /sys/power/state

#Pause a second or two to let us sleep.
sleep 2
Which seems to work great (LCD turns off and standby LED goes on), but I'm stumped as how to wake up the machine and get back my X session. When I press any keyboard key it wakes from sleep mode (can hear the HDD spin up etc), but the LCD doesn't turn back on so I don't know whats going on. I've tried pressing CTRL + ALT + F1 that should get me back to my bash shell but that does nothing.

If anyone could help me with any of these annoyances it would be great
 
Old 07-15-2005, 05:54 PM   #2
flippantfig
Member
 
Registered: Aug 2003
Posts: 44

Rep: Reputation: 15
I have just solved the sound problems I had in slackware after a recent kernel upgrade. I also had no sound in Dropline Gnome EVER, even though xmms etc worked.

I compiled the latest alsa drivers, libs, utilities and OSS compatible libraries, and it all fell into place. this pdf helped a lot too. Hope that helps in some way!


Last edited by flippantfig; 07-15-2005 at 05:55 PM.
 
Old 07-27-2005, 05:19 AM   #3
Markup
LQ Newbie
 
Registered: Feb 2005
Distribution: RHEL4, SLED10, Ubuntu, Solaris
Posts: 26

Original Poster
Rep: Reputation: 15
*Forgot about this thread*

Thanks for the suggestion, but my ALSA setup is 'sound' excuse the pun. This is a problem with Gnome and not ALSA. It turns out that Gnome doesn't install everything it needs to play gnome-sound events.

With the help of the following webpages I was able to get Gnome sound events working:

http://www.linuxjournal.com/article/6809
http://www.ubuntuguide.org/

Quote:
1) Install esound, esound-clients, gnome-audio, gstreamer-plugins and libesd-alsa0
2) #killall esd
3) #gedit /etc/esound/esd.conf

Find this section:
Code:
auto_spawn=0
spawn_options=-terminate -nobeeps -as 5
Replace with the following lines:
Code:
auto_spawn=1
spawn_options=-terminate -nobeeps -as 2 -d default
Save the edited file

4) gedit /etc/asound.conf

Insert the following lines into the new file:
Code:
pcm.card0 {
type hw
card 0
}

pcm.!default {
type plug
slave.pcm "dmixer"
}

pcm.dmixer {
type dmix
ipc_key 1025
slave {
pcm "hw:0,0"
period_time 0
period_size 2048
buffer_size 32768
rate 48000
}
bindings {
0 0
1 1
}
}
Save the edited file

5) #ln -fs /usr/lib/libesd.so.0 /usr/lib/libesd.so.1

6) Open up Gnome sound preference from the panel:
- Enable sound server startup: Checked
- Sounds for events: Checked

7) Reboot computer
As for the other problems :\

Well the mtrr overlaps don't seem to be affecting the system performance or stability in anyway. I've read that its the vesafb that is the problem. I tried adding nomtrr to my menu.lst but that did nothing. The only other fix I can see is recompiling my kernel to use the intelfb (I chose vesafb as recommended for bootsplash, which I'm using). Anyway I don't play any FPSs so getting the most out of my gfx card isn't that much of an issue.

The ability to sleep/suspend would be useful, but startup/shutdown doesn't take all that long on my machine which compensates for this (at present) lost functionality.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't play Gnome Sound events cyberjun Linux - Software 3 10-17-2005 05:43 AM
gnome sound events linmix Linux - Software 0 02-22-2005 03:59 PM
Gnome Sound Events dsojat10 Suse/Novell 0 12-06-2004 01:55 AM
Gnome sound events problem... TippyToes Linux - Software 1 12-05-2004 01:06 AM
No sound events in GNOME 2.6 Romendo Slackware 4 08-25-2004 12:59 AM


All times are GMT -5. The time now is 10:13 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration