LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 07-24-2005, 05:06 PM   #1
cdhgee
Member
 
Registered: Oct 2003
Location: St Paul, MN
Distribution: Fedora 8, Fedora 9
Posts: 513

Rep: Reputation: 30
MythTV volume always reset to 70% when starting


I've just got MythTV working and encountered something strange. Whenever I start the TV part of Myth, it resets the computer's master volume to 70%, which is too quiet for me to be able to hear - I have to then use aumixer to put the master volume up to 100%, and even then it's a little on the quiet side. This is all with MythTV's volume (as controlled by F10 & F11) set to 100%.

So,

1.) Why is MythTV setting the output to 70% when it's started? Is it possible to change this behaviour?

2.) Is it possible to boost the volume of MythTV beyond it's internal limit of 100%?


Cheers
David
 
Old 07-25-2005, 12:26 PM   #2
tuxdev
Senior Member
 
Registered: Jul 2005
Distribution: Slackware
Posts: 2,012

Rep: Reputation: 111Reputation: 111
1. There is probably something in the preferences to do this, although the easiest thing to do get speakers with amps included.
2. Of couse its impossible to have a volume over 100%. The definition of 100% is maximum
 
Old 07-25-2005, 01:46 PM   #3
cdhgee
Member
 
Registered: Oct 2003
Location: St Paul, MN
Distribution: Fedora 8, Fedora 9
Posts: 513

Original Poster
Rep: Reputation: 30
1. I've got speakers with an amp, but it's still a pain when Myth makes the volume quieter at starting and then I have to go and reset it. I've looked all through mythtvsetup but there's nothing obvious, and there are no other settings for myth that I'm aware of.

2. Thought so, just wanted to make sure .
 
Old 05-02-2006, 05:15 PM   #4
mrchaos
Member
 
Registered: Mar 2005
Location: USA
Distribution: Slackware current, Fedora Core 5, SuSE 10.1 OSS
Posts: 298

Rep: Reputation: 30
is there a direct answer to this problem? I have yet to find anything in the preferences or config files to fix this "problem," and I agree that it's a total pain in the ass.
 
Old 06-05-2006, 03:48 AM   #5
cdhgee
Member
 
Registered: Oct 2003
Location: St Paul, MN
Distribution: Fedora 8, Fedora 9
Posts: 513

Original Poster
Rep: Reputation: 30
mrchaos,

Yeah, I did eventually find the solution - and it's blindingly obvious. There's an option in the config somewhere, I think it was in the mythfrontend setup, where you can configure the initial volume for the master and the pcm channels when MythTV starts. Default value is 70% at install time. Unfortunately, there doesn't seem to be a way to stop myth from changing the volume, which is what I would like, as it usually means that if I've got any other sound coming out it starts blasting out very loudly.

HTH

Regards
David
 
Old 06-07-2006, 01:49 PM   #6
mrchaos
Member
 
Registered: Mar 2005
Location: USA
Distribution: Slackware current, Fedora Core 5, SuSE 10.1 OSS
Posts: 298

Rep: Reputation: 30
haha, Yes, I found the same configuration option shortly after posting the response. Thanks for your help though!
 
Old 08-02-2006, 05:20 AM   #7
apanloco
LQ Newbie
 
Registered: Jun 2006
Posts: 9

Rep: Reputation: 0
I can't find it, I must be blind. Can someone guide me? Using Mythtv 0.19.

BR/D
 
Old 08-02-2006, 05:25 AM   #8
cdhgee
Member
 
Registered: Oct 2003
Location: St Paul, MN
Distribution: Fedora 8, Fedora 9
Posts: 513

Original Poster
Rep: Reputation: 30
I'll check tonight and post back.
 
Old 08-02-2006, 05:28 AM   #9
apanloco
LQ Newbie
 
Registered: Jun 2006
Posts: 9

Rep: Reputation: 0
Found it, sorry and thanks

mythfrontend -> Utilities/Setup -> Setup -> General -> Page3

BR/D
 
Old 08-02-2006, 04:54 PM   #10
cdhgee
Member
 
Registered: Oct 2003
Location: St Paul, MN
Distribution: Fedora 8, Fedora 9
Posts: 513

Original Poster
Rep: Reputation: 30
No probs, was just about to post the answer but I won't bother now

I found the best solution was to untick the "use internal volume controls" and use the master ALSA mixer to control volume.
 
  


Reply

Tags
myth, resolved, sound, tv, volume


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
mythtv spidna Slackware 6 01-07-2006 11:14 AM
MythTV vswr31 Linux - Software 5 04-16-2005 02:16 AM
program volume rather than system volume Moebius Linux - Software 6 11-05-2004 09:57 PM
MythTV dexter4560 Linux - Software 11 01-22-2004 07:08 AM
Adjusting how much volume jumps with volume keys vrillusions Linux - Laptop and Netbook 2 10-17-2003 09:11 PM


All times are GMT -5. The time now is 12:35 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration