LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 01-22-2012, 01:58 AM   #1
elaterite
LQ Newbie
 
Registered: Nov 2007
Location: Reno, NV
Distribution: Linux Mint 9 LTE KDE
Posts: 7

Rep: Reputation: 0
Monitor goes blank (black) watching Flash video (screen savers are disabled)


Problem: Watching flash in web browser screen goes off after 15 minutes or so.

Yes, I have turned off all screensavers and power management (in both OS and Bios). (At least all that I could find.)

I've even tried uninstalling both xscreensaver and kscreensaver.

Equipment and distro:
Lenovo Thinkpad #0302-44U
Linux Mint 9 "Isadora" LTS (Package base Kubuntu, Lucid Lynx.)
Desktop KDE

System Settings > Screen saver > "Settings" start automatically (NOT checked).

System settings > Advanced > Power Management & Edit Profiles > I went through and unchecked everything, set everything to "Performance" and set all of the dialog boxes to "Do Nothing".

I also checked in my bios at start up for power-saving settings and assured they we off &c.

This problem (annoyance) seems to be quite prevalent with a lot of people complaining about it on a variety of Linux forums.

Thus far I have found two solutions:

1) A script at this link which I've not tried because it seems insanely complicated for solving such a simple problem, and it's written for Gnome. There was one written for KDE however. I'll go back and see if I can get it to work if no one can come up with a simpler solution in this thread.

2) And this site which suggests running the following at the command line: "while /bin/true; do qdbus org.freedesktop.ScreenSaver /ScreenSaver SimulateUserActivity > /dev/null; sleep 1m; done"

Number (2) worked great, however, when I was trying to send the Flash stream out to my TV in the front room via the HDMI port and a long cable--the TV screen blanked out while the monitor on the laptop remained on!

So clearly, the command in number (2) only works for the laptop monitor but not the HDMI port. Oy vei.

Thoughts anyone? And thanks in advance for reviewing this question! :)
 
Old 01-22-2012, 10:44 AM   #2
Thor_2.0
Senior Member
 
Registered: Nov 2007
Location: Somewhere on my hard drive...
Distribution: Manjaro
Posts: 2,228
Blog Entries: 23

Rep: Reputation: 279Reputation: 279Reputation: 279
Well, it is a (feather of a) thought, but here goes, youtube has a help page - okay, it's maybe not directly youtube related, but it helped me out with flash troubless...

If it works, repo is the one to thank got the link from him...

Good luck

Thor
 
Old 01-23-2012, 12:50 AM   #3
elaterite
LQ Newbie
 
Registered: Nov 2007
Location: Reno, NV
Distribution: Linux Mint 9 LTE KDE
Posts: 7

Original Poster
Rep: Reputation: 0
Thanks, I checked it but no help. Over on the Linux Mint forums, under KDE, I was given these instructions (UPDATE CORRECTION: this does work if you run the codes as the user, not root):
For a temporary solution (at least for the time you are logged in) you can run the following 2 commands in the terminal:

Code:
xset -dpms
Code:
xset s off
If you put them in a script saved as a hidden file in your /home directory, you can add it to your startup applications to do it automatically each time you boot.

Last edited by elaterite; 01-23-2012 at 08:01 PM.
 
Old 01-23-2012, 08:03 PM   #4
elaterite
LQ Newbie
 
Registered: Nov 2007
Location: Reno, NV
Distribution: Linux Mint 9 LTE KDE
Posts: 7

Original Poster
Rep: Reputation: 0
Solved

OK, I'm marking this thread as SOLVED.

Caffeine maybe another fix for this. I did not try it however.

For anyone else having this problem and reading this thread, Linux Mint forum user, tdockery's, solution works if you run the following commands in terminal (as yourself, not as root):

Code:
xset -dpms
Code:
xset s off
Additionally, for people having problems with the audio when trying to stream Flash out of their HDMI port to another monitor/TV a solution is posted at the follwoing link: https://wiki.archlinux.org/index.php..._Does_Not_Work

Thanks everyone!
 
Old 01-23-2012, 10:52 PM   #5
Thor_2.0
Senior Member
 
Registered: Nov 2007
Location: Somewhere on my hard drive...
Distribution: Manjaro
Posts: 2,228
Blog Entries: 23

Rep: Reputation: 279Reputation: 279Reputation: 279
Thanks for sharing the solution.
 
  


Reply

Tags
blank, disable, flash, monitor, screensaver


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Watching Flash video in OpenBSD just got a whole lot easier LXer Syndicated Linux News 0 04-27-2011 08:20 AM
More than one month watching a black screen r_active Linux - Laptop and Netbook 7 12-28-2009 03:02 PM
Black screen after upgrade to Fedora 9 - Intel video / Secptre monitor PTrenholme Fedora 2 05-16-2008 11:38 AM
suse 10 - black screen during installation or general monitor/video issues aluzero Linux - Hardware 0 12-23-2006 06:01 AM
kaffine only plays sounds, video screen is blank (black) all the time zeltak Linux - Software 2 04-22-2006 09:26 PM


All times are GMT -5. The time now is 08:25 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration