LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 07-15-2003, 01:56 PM   #1
sk545
Member
 
Registered: Aug 2002
Posts: 312

Rep: Reputation: 30
Lilo Gives Error when Booting up in Redhat 9.


I am getting this error upon booting up with lilo:

Quote:
mounting root filesystem
mount: error 6 mounting ext3
pivotroot: pivot_root(/sysroot, sysroot/initrd) failed 2
umount /initrd/proc failed: 2
kernel panic: no init found. Try passing init = option to kernel.
My lilo.conf looks like this:

Quote:
prompt
timeout=50
default=linux
boot=/dev/hda
map=/boot/map
install=/boot/boot.b
message=/boot/message
lba32

image=/boot/vmlinuz-2.4.20-8
label=linux
initrd=/boot/initrd-2.4.20-8.img
read-only
append="hdc=ide-scsi root=LABEL=/"
root=/dev/hda3

other=/dev/hda2
optional
label=DOS

And my drive structure is like this:

Quote:
Ignoring extra extended partition 4

Disk /dev/hda: 122.9 GB, 122942324736 bytes
255 heads, 63 sectors/track, 14946 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hda1 2 852 6835657+ 5 Extended
/dev/hda2 853 13524 101787840 c Win95 FAT32 (LBA)
/dev/hda3 13525 14162 5124735 83 Linux
/dev/hda4 * 14163 14946 6297480 85 Linux extended
/dev/hda5 2 852 6835626 7 HPFS/NTFS

What could be wrong? Its a dual boot machine with RH 9 and WinXp pro.
Also, i can boot into redhat just fine if i use the redhat bootdisk. So it looks like a lilo problem to me.

Thanks.

Last edited by sk545; 07-15-2003 at 01:59 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Dual Booting : ME, XP, Redhat (hal.dll error for XP) rinzei Linux - Newbie 1 03-03-2005 03:02 AM
Booting Problem after error in WineX RedHat 9 bubbahpw Linux - Newbie 1 09-04-2004 06:59 AM
error booting redhat with grub command line shams Linux - Software 0 03-02-2004 08:23 PM
error booting redhat for first time IvanT Linux - Software 6 09-24-2003 07:59 PM
LILO - dual booting win 95 / redhat 6.2 DiamondViper Linux - General 4 02-13-2002 09:45 PM


All times are GMT -5. The time now is 10:57 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration