LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 02-12-2003, 07:01 AM   #1
PcHammer
Member
 
Registered: Jan 2001
Location: Ljubljana Slovenija
Distribution: Slackware
Posts: 70

Rep: Reputation: 15
Ldap and SMB


Hi
I have installed Ldap and smb (with--ldapsam) on redhat 8.0.
Now when I try to add base.ldif file i get and error :

Enter LDAP Password:
adding new entry "dc=klinika,dc=net"
ldap_add: No such object

ldif_record() = 32


what could be the problem here ???

regards, pchammer
 
Old 02-12-2003, 07:52 AM   #2
ghight
Member
 
Registered: Jan 2003
Location: Indiana
Distribution: Centos, RedHat Enterprise, Slackware
Posts: 524

Rep: Reputation: 30
PC, I know more people get upset with posts like this, but I think they are helpful anyway. What are you using LDAP for? Is it just for keeping user data or is it for multiserver authentication or something else.

I ask because LDAP is the most misunderstood program out there. Its a lot of extra work if you don't use it to it's full potential. I have found quite a few people using it solely for authentication when PAM work just as well and is much simpler. Just a thought. Sorry in advance if any offense was taken.
 
Old 02-12-2003, 08:24 PM   #3
jamrock
Member
 
Registered: Jan 2003
Location: Kingston, Jamaica
Posts: 444

Rep: Reputation: 41
Check your slapd.conf. Have you included all the schemas that you need?

What info. are you trying to bring in?

What do you want to do with ldap? I think ghight has a good point. Ldap has some good uses but people are starting to make it seem like the cure for all ills.

Peace.
 
Old 02-13-2003, 05:26 AM   #4
PcHammer
Member
 
Registered: Jan 2001
Location: Ljubljana Slovenija
Distribution: Slackware
Posts: 70

Original Poster
Rep: Reputation: 15
OK u asked me why ldap, we are curently using Winnt 4.0 as PDC and WS on Win98 and WinXp.
We will migrate to a new server (dual cpu) and I don't wanna install windows 2000 so i'm looking for something else, so linux and ldap with samba comes to mind. I know that samba is much faster as win2000 (as files sharing server)

So there it is.


Regards, PcHammer

P.s. No offence was taken
 
Old 02-13-2003, 08:24 PM   #5
jamrock
Member
 
Registered: Jan 2003
Location: Kingston, Jamaica
Posts: 444

Rep: Reputation: 41
Make sure you have the samba.schema included in your slapd.conf file.

For more info. see

http://www-1.ibm.com/servers/esdd/tu...dap/index.html

There is a section on configuring openldap.
 
Old 02-19-2003, 04:37 AM   #6
PcHammer
Member
 
Registered: Jan 2001
Location: Ljubljana Slovenija
Distribution: Slackware
Posts: 70

Original Poster
Rep: Reputation: 15
Ok now I have installed and configured samba and ldap, all works without any problems.
OK now to another thing; I have installed smbldap-tools from idelax and it all works ok but one thing troubles me; how to and winXP to this samba PDC domain. I have smb.conf ready to add machines to the ldap directory:
add user script = /usr/local/sbin/smbldap-useradd.pl -w %u

and when i check ldap i get an entry with a $ at the end of the pc name.

OK i created root account (to add machines to smbpdc).
I have also done all in Winxp (WinXP_SignOrSeal.reg and local security policy).

So now i try to add pc to smbpdc and i get and error, so i go and check my samba log file and there is an entry:
ldap_connect_system: succesful connection to the LDAP server
[2003/02/18 18:46:56, 2] passdb/pdb_ldap.c:ldap_search_one_user(262)
ldap_search_one_user: searching for:[(&(uid=zupancic$)(objectclass=sambaAccount))]
[2003/02/18 18:46:56, 0] passdb/pdb_ldap.cdb_getsampwnam(858)
LDAP search "(&(uid=zupancic_)(objectclass=sambaAccount))" returned 0 entries.
[2003/02/18 18:46:56, 0] rpc_server/srv_netlog_nt.c:get_md4pw(176)
get_md4pw: Workstation zupancic$: no account in domain
[2003/02/18 18:46:56, 2] smbd/server.c:exit_server(461)
Closing connections

If anyone has any ideas about this pls help.

regards, PcHammer
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
SMB PDC + LDAP (all auth) FC2 chado Linux - Networking 1 11-02-2004 06:29 PM
ldap-abook unable to get street name in ldap-entry Jingle Linux - Software 1 06-06-2004 07:13 PM
making smb shares viewable from smb client via web browser scottpioso General 3 11-10-2003 04:25 PM
SMB and LDAP Installed Can't Login sm4ck Linux - Networking 2 06-23-2003 10:04 PM
Ldap + smb auth PcHammer Linux - Software 0 02-17-2003 03:19 AM


All times are GMT -5. The time now is 12:08 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration