LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 12-02-2003, 02:22 PM   #1
drand
LQ Newbie
 
Registered: Jun 2003
Location: Moscow, Russia
Posts: 4

Rep: Reputation: 0
ld: warning


when i make some application i get next error:
/usr/bin/ld: warning: libSM.so.6, needed by /usr/X11R6/lib/libXt.so, not found (try using -rpath or -rpath-link)
/usr/bin/ld: warning: libICE.so.6, needed by /usr/X11R6/lib/libXt.so, not found (try using -rpath or -rpath-link)
but
/usr/X11R6/lib/libICE.so.6.3
/usr/X11R6/lib/libICE.so.6
exists.

grep '/usr/X11R6/lib' /etc/ld.so.conf |wc -l
1
ldconfig -p|grep -E 'libSM.so.6|libICE.so.6'
libSM.so.6 (libc6) => /usr/X11R6/lib/libSM.so.6
libICE.so.6 (libc6) => /usr/X11R6/lib/libICE.so.6

in conclusion i try:
/usr/bin/ld /usr/X11R6/lib/libICE.so.6
/usr/bin/ld: warning: cannot find entry symbol _start; not setting start address
and
/usr/bin/ld /usr/X11R6/lib/libSM.so.6
/usr/bin/ld: warning: libICE.so.6, needed by /usr/X11R6/lib/libSM.so.6, not found (try using -rpath or -rpath-link)
/usr/bin/ld: warning: cannot find entry symbol _start; not setting start address
/usr/X11R6/lib/libSM.so.6: undefined reference to `IceSetShutdownNegotiation'
.....
undefined reference - looks like some kind of big problem here, no?.

10x for your answers
 
Old 12-02-2003, 02:31 PM   #2
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 22,988
Blog Entries: 11

Rep: Reputation: 880Reputation: 880Reputation: 880Reputation: 880Reputation: 880Reputation: 880Reputation: 880
I'd say it does look like some sort of a
problem, indeed. My first idea would be
to re-install those two libraries from the
original install-media since the current
ones seem to be broken (no idea how
that might have happened).



Cheers,
Tink
 
Old 05-25-2010, 04:03 AM   #3
hxcan
LQ Newbie
 
Registered: Mar 2010
Location: 北京
Distribution: Qomo
Posts: 4

Rep: Reputation: 0
I installed a new version of binutils and got a similar problem . Anyone who know the reason ?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Warning for Newbies !! raceware Linux - Distributions 24 03-01-2004 01:30 PM
perl warning lenlutz Red Hat 1 01-31-2004 09:18 AM
what is this warning in C? h/w Programming 7 10-26-2003 11:16 PM
why warning message is appear? eye Red Hat 3 10-22-2003 09:14 AM
fstab warning Gordon Slackware 5 04-15-2003 04:41 PM


All times are GMT -5. The time now is 12:52 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration