LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 07-08-2003, 12:57 PM   #1
mrtwice
Member
 
Registered: Feb 2002
Distribution: xubuntu 8.10
Posts: 225

Rep: Reputation: 31
kde system notifications don't work


This is actually a followup to my previous question:

http://www.linuxquestions.org/questi...threadid=70950

I have determined that somehow I managed to shut off system notifcations in KDE, both for root and my normal user. I can tell this because:

1) when I hit backspace multiple times on an emtpy command line I don't get a beep (yes, system notification is on in settings).

2) when I go to control center -> sound & multimedia -> system bell check the box and hit test I don't hear anything.

This happens only for the items described above. Otherwise, I have sound in various applications, I can play mp3s with mpg321, etc.

I have also determined it is a configuration setting because when I created a temp user and logged in to system notifications it worked fine. I have looked at all of the settings (I think) under the sounds and multimedia control section and tried to duplicate everything I had in the temp user's profile. I also tried setting everything back to default and that did not fix anything.

So, I am stumped. I hope someone has a good idea they would like to share.

<------------------------------------update-------------------------->

I have detemined how I "broke" it. From a fresh kde config:

1) control center -> sound & multimedia -> system bell
check box and hit OK.

2) logout

3) login

4) Follow above procedure (1) but this time uncheck box and hit OK

5) Logout

6) login

walla, no system notifications.

Or, for a faster "break":

Check box, uncheck box, hit Ok, logout, login

Would someone mind trying this on a test user on their system and telling me if this produced the results I am seeing.

Also, it would help if someone could tell me what configuration change is happening so I might be able to manually fix it.


Last edited by mrtwice; 07-08-2003 at 02:16 PM.
 
Old 07-08-2003, 05:25 PM   #2
mrtwice
Member
 
Registered: Feb 2002
Distribution: xubuntu 8.10
Posts: 225

Original Poster
Rep: Reputation: 31
Okay, I figured this out. As far as I can see, this is a bug in KDE.

When you uncheck the box after checking it, a file is created:

~/.kde/share/config/kaccessrc

This has settings that turn off all system notifications. In essence, the bell now works, but KDE isn't starting it.

I deleted the above file and my system works now.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
KDE system notifications won't play ! acanton MEPIS 4 03-23-2006 11:18 AM
KDE System Notifications GibsonDL Linux - Newbie 2 07-25-2005 01:38 PM
System Notifications No Longer Work AvatarofVirgo Suse/Novell 0 02-02-2005 06:52 PM
KDE System Notifications mykrob Linux - Software 0 08-31-2004 08:00 AM
System notifications sound isn't work. z-vet Mandriva 7 08-27-2004 09:08 PM


All times are GMT -5. The time now is 03:56 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration