LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 05-12-2003, 12:11 AM   #1
Robert0380
LQ Guru
 
Registered: Apr 2002
Location: Atlanta
Distribution: Gentoo
Posts: 1,280

Rep: Reputation: 47
iptables- new install


I just recently had to re-install linux (today), and I was trying to go ahead and set up my custom firewall rules using iptables but i run into a problem, here is what i get:

[root@decatur robert]# /sbin/iptables -P INPUT DROP
/lib/modules/2.4.18-27.7.x/kernel/net/ipv4/netfilter/ip_tables.o: init_module: Device or resource busy
Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters.
You may find more information in syslog or the output from dmesg
/lib/modules/2.4.18-27.7.x/kernel/net/ipv4/netfilter/ip_tables.o: insmod /lib/modules/2.4.18-27.7.x/kernel/net/ipv4/netfilter/ip_tables.o failed
/lib/modules/2.4.18-27.7.x/kernel/net/ipv4/netfilter/ip_tables.o: insmod ip_tables failed
iptables v1.2.5: can't initialize iptables table `filter': iptables who? (do you need to insmod?)
Perhaps iptables or your kernel needs to be upgraded.
[root@decatur robert]#


i have no clue what's wrong, this is off a fresh install of RedHat 7.3 plus any upgrades from RHN that i downloaded, iptables is installed and running because if i just type the iptables command i get this:


[root@decatur robert]# /sbin/iptables
iptables v1.2.5: no command specified
Try `iptables -h' or 'iptables --help' for more information.
[root@decatur robert]#



but it's when i try to add a rule or change a policy that i get the error message.
 
Old 05-12-2003, 12:14 AM   #2
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,066
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
Check whether any of the iptables modules
are loaded first ...

lsmod

Cheers,
Tink
 
Old 05-12-2003, 12:17 AM   #3
Robert0380
LQ Guru
 
Registered: Apr 2002
Location: Atlanta
Distribution: Gentoo
Posts: 1,280

Original Poster
Rep: Reputation: 47
how do i check to see if the modules are loaded, and if they arent loaded how do i load em and get em to load automatically

Last edited by Robert0380; 05-12-2003 at 12:26 AM.
 
Old 05-12-2003, 12:34 AM   #4
Robert0380
LQ Guru
 
Registered: Apr 2002
Location: Atlanta
Distribution: Gentoo
Posts: 1,280

Original Poster
Rep: Reputation: 47
anybody?
 
Old 05-12-2003, 12:36 AM   #5
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,066
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
sheeesh ...
Just READ what I posted mate...
The command to see loaded modules is

Code:
lsmod
:P

Cheers,
Tink
 
Old 05-12-2003, 12:42 AM   #6
Robert0380
LQ Guru
 
Registered: Apr 2002
Location: Atlanta
Distribution: Gentoo
Posts: 1,280

Original Poster
Rep: Reputation: 47
sorry man, it looked like a capital "i" and didnt work so i wasnt sure: this is what i got :


[root@decatur log]# /sbin/lsmod
Module Size Used by Not tainted
sr_mod 16056 0 (autoclean)
emu10k1 60832 1 (autoclean)
ac97_codec 12256 0 (autoclean) [emu10k1]
sound 69260 0 (autoclean) [emu10k1]
soundcore 6212 7 (autoclean) [emu10k1 sound]
radeon 96248 13
agpgart 40096 3
binfmt_misc 7236 1
autofs 11140 0 (autoclean) (unused)
tulip 41312 2
ipchains 40008 3
ide-scsi 9376 0
scsi_mod 104848 2 [sr_mod ide-scsi]
ide-cd 30144 0
cdrom 31968 0 [sr_mod ide-cd]
usb-uhci 24292 0 (unused)
usbcore 71104 1 [usb-uhci]
ext3 64768 2
jbd 47892 2 [ext3]


i see ipchains but not iptables, i tried loading iptables via insmod, this is what i did:

[root@decatur log]# /sbin/insmod /lib/modules/2.4.18-27.7.x/kernel/net/ipv4/netfilter/ip_tables.o
/lib/modules/2.4.18-27.7.x/kernel/net/ipv4/netfilter/ip_tables.o: init_module: Device or resource busy
Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters.
You may find more information in syslog or the output from dmesg

why would it give me "Device or resource busy", i turned off ipchains and ip6tables and restarted iptables but i still get the same errors.
 
Old 05-12-2003, 01:03 AM   #7
Robert0380
LQ Guru
 
Registered: Apr 2002
Location: Atlanta
Distribution: Gentoo
Posts: 1,280

Original Poster
Rep: Reputation: 47
is ipchains as good as iptables? if i cant get iptables to work, and ipchains is just as good, then i guess i'll go with ipchains, but i really want iptables.

Last edited by Robert0380; 05-12-2003 at 01:04 AM.
 
Old 05-12-2003, 01:25 AM   #8
ifconfig
LQ Newbie
 
Registered: May 2003
Posts: 23

Rep: Reputation: 15
try to do this first:
chkconfig --level 345 ipchains off
serviece ipchains stop

rpm -q iptables

Check that if you have installed iptables. Also tell us which version of Linux you are using
 
Old 05-12-2003, 01:28 AM   #9
markus1982
Senior Member
 
Registered: Aug 2002
Location: Stuttgart (Germany)
Distribution: Debian/GNU Linux
Posts: 1,467

Rep: Reputation: 46
ipchains does not have the powerful features offered by iptables. What does uname -a say? You're using a Kernel < 2.4, correct ?
 
Old 05-12-2003, 01:29 AM   #10
Robert0380
LQ Guru
 
Registered: Apr 2002
Location: Atlanta
Distribution: Gentoo
Posts: 1,280

Original Poster
Rep: Reputation: 47
[root@decatur robert]# /sbin/service ipchains stop
Flushing all chains: [ OK ]
Removing user defined chains: [ OK ]
Resetting built-in chains to the default ACCEPT policy: [ OK ]
[root@decatur robert]# rpm -q iptables
iptables-1.2.5-3

yea it's there, Red Hat 7.3

note: iptables was working fine before, but i had to reformat the drive and re-install everything, iptables was installed by default just like last time, but im getting these crazy errors this time around. im about to try using the older kernel just to see if that makes a difference, i'll let you know after i reboot and come back.
 
Old 05-12-2003, 01:35 AM   #11
Robert0380
LQ Guru
 
Registered: Apr 2002
Location: Atlanta
Distribution: Gentoo
Posts: 1,280

Original Poster
Rep: Reputation: 47
well what-do-you-know, iptables works fine with my older kernel (the one that comes with rh 7.3) but not with the latest kernel. Any ideas on what the problem could be? I'm not good with kernel issues by any means.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't install iptables-p2p Skunk_Face Fedora 5 01-12-2007 10:43 AM
problem in iptables when i install 2.6.10 on RH9 cranium2004 Red Hat 4 05-28-2005 02:04 AM
install iptables problem greklas Slackware 1 09-04-2004 01:59 PM
iptables install error...(for a firewall) b0uncer Linux - Security 1 01-06-2004 09:38 AM
IPtables Log Analyzer from http://www.gege.org/iptables/ brainlego Linux - Software 0 08-11-2003 07:08 AM


All times are GMT -5. The time now is 02:14 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration