LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 08-05-2003, 03:37 AM   #1
mobassir
Member
 
Registered: Jul 2003
Location: Pakistan
Distribution: Redhat , SME
Posts: 346

Rep: Reputation: 30
If Xpde is good under linux


hello

i found XP desktop Envoiement pakege at xpde.com
is is asf to load this pakege in redhat .

i have untar the pakege but if i tried to Install it wirh ./install.sh command as per its installing procdure, it gives me error can not creat Diretory for all Directories, then i open install.ch file and try to menualy make this directories but still same error,
what can be problem

thank you
 
Old 08-05-2003, 04:04 AM   #2
slakmagik
Senior Member
 
Registered: Feb 2003
Distribution: Slackware
Posts: 4,113

Rep: Reputation: Disabled
What are the install procedures and what exactly are you doing? For instance, I might think you needed to install as root but were trying to install as a regular user, but if those instructions are given and that is what you are doing, it must be something else.

Do you dislike KDE or Gnome or whatever other window managers/desktop environments RH provides?
 
Old 08-05-2003, 04:52 AM   #3
mobassir
Member
 
Registered: Jul 2003
Location: Pakistan
Distribution: Redhat , SME
Posts: 346

Original Poster
Rep: Reputation: 30
No i dont hat RedHat desktop
but i want to check xpde
i am lohon as root but it giving errot

[root@Omar-Pc xpde-0.4.0]# ./install.sh
Remember you must execute this program as root!!!
mkdir: cannot create directory `/opt': File exists
mkdir: cannot create directory `/opt/xpde': File exists
mkdir: cannot create directory `/opt/xpde/bin': File exists
mkdir: cannot create directory `/opt/xpde/bin/apps': File exists
mkdir: cannot create directory `/opt/xpde/bin/applets': File exists
mkdir: cannot create directory `/opt/xpde/share': File exists
mkdir: cannot create directory `/opt/xpde/share/apps': File exists
mkdir: cannot create directory `/opt/xpde/share/applets': File exists
mkdir: cannot create directory `/opt/xpde/share/doc': File exists
mkdir: cannot create directory `/opt/xpde/share/fonts': File exists
mkdir: cannot create directory `/opt/xpde/share/icons': File exists
mkdir: cannot create directory `/opt/xpde/themes': File exists
Installation completed
 
Old 08-05-2003, 05:07 AM   #4
slakmagik
Senior Member
 
Registered: Feb 2003
Distribution: Slackware
Posts: 4,113

Rep: Reputation: Disabled
File exists? Have you run this file more than once and did you get that error the first time? You should get a 'permission denied' if there was a permissions issue. File exists means, well, that it exists. Do 'ls /opt' and see if they aren't already there. You can't create the directory if it's already been created.
 
Old 08-05-2003, 05:17 AM   #5
mobassir
Member
 
Registered: Jul 2003
Location: Pakistan
Distribution: Redhat , SME
Posts: 346

Original Poster
Rep: Reputation: 30
yes

thank you Files are already Exists , its mean its already intstall but i am getting this error from very first time when i tried ti install
let me do next step
 
Old 08-05-2003, 05:27 AM   #6
slakmagik
Senior Member
 
Registered: Feb 2003
Distribution: Slackware
Posts: 4,113

Rep: Reputation: Disabled
Yeah - I think you might be okay - if the directories are there and the files are in them and the script's throwing errors but then saying its complete, it's probably good to go.
 
Old 08-05-2003, 07:17 AM   #7
mobassir
Member
 
Registered: Jul 2003
Location: Pakistan
Distribution: Redhat , SME
Posts: 346

Original Poster
Rep: Reputation: 30
hello
i have done all these following steps sucsessfuly and in the logon scree i found Xpde option when i try to logon with this session it give me error the error is
" your session only lasted less then 10 second if you have not logged out your self, this could meen that there is some installation problem or that you may be out of disk space. Try loggoing in with of the failsafe session to see if you can fix this problem
/home/mobassir/.xsession error could not be open"


To get XPde, go to:

http://www.xpde.com/releases.php

you download the tar.gz distribution:

$ cd /path/to/xpde.archive.tar.gz
$ tar xvzf xpde-X.X.X-XXXXXXXX.tar.gz
$ cd xpde-X.X.X

And now, you need to become root to perform the first installation part:

$ su
Password: ENTER_HERE_YOUR_ROOT_PASSWORD

And then, you need to execute the install script:

# ./install.sh

This script creates a directory called /opt/xpde, if you want to erase XPde from your system, you simply need to delete this directory.

Setting up the default environment
----------------------------------
[This step will be removed in a near future]

To setup the default environment for each user, you need to execute another script, but this time, as the user is going to use XPde. So you can use Ctrl+D or the exit command to return to the previous user, or issue a su command, for example:

# su korben

Where korben is the user you want to allow use XPde.

Now, change the directory again to xpde-X.X.X and perform this command:

$ ./setup.sh

This script creates an .xpde subdirectory on your home directory which holds your account information.

Setting up the display manager
------------------------------
[This part will be automated soon]
To allow you to choose XPde from your display manager, you need to perform some additional steps, which depend on your distro and the display manager you are using, in RedHat 9.0, by default, you use GDM.

Become root using the su command

$ su
Password: ENTER_HERE_YOUR_ROOT_PASSWORD

And change the current dir to the XPde bin directory:

# cd /opt/xpde/bin

Now copy the file xinitrcDEFAULT from the source directory:

# cp /home/korben/xpde-X.X.X/xinitrcDEFAULT .

And now, rename it and make it executable:

# mv xinitrcDEFAULT xpde
# chmod +x xpde

And make a soft link to this file on your /usr/local/bin

# ln -s /opt/xpde/bin/xpde /usr/local/bin/XPde

And to setup the session for the display manager, you need to create a file on the gdm sessions dir, you can use your favourite editor, or use vi, which is included on every distro:

# vi /etc/X11/gdm/Sessions/XPde

Press i to start typing and type this:

/usr/local/bin/XPde

And press :wq and Enter to write the file and exit the editor. Now you need to make this file executable using:

# chmod +x /etc/X11/gdm/Sessions/XPde

Running XPde
------------
Logout from your session and when the display manager is loaded, select Session from the bottom of the screen, you should see an XPde entry, select it and log in as the user you configured in the previous step.

You should see XPde running, if not, check all the previous steps.
 
Old 08-05-2003, 07:43 AM   #8
slakmagik
Senior Member
 
Registered: Feb 2003
Distribution: Slackware
Posts: 4,113

Rep: Reputation: Disabled
Damn. I've seen that website and to be trying to be XP-ish they don't sound exactly ready for prime time.

Well, I assume you're not out of space, so it must be a problem with the installation. Incidental thing - I think '.xsession error' wouldn't be opened because it doesn't exist. It should be .xsession-errors. Do you have the .xpde directory in your home?

If you did all those steps correctly and did get that glitch with the directories and now this I'd guess either there was something wrong with the tarball or there's just something wrong with the script. I'm also guessing you weren't having any trouble with whatever wm you were using before? You might just want to try again or wait for someone with more experience with wrestling with X to come along and post. I was caught more by the filesystem error.

You might want to copy out that xpde script that you renamed from DEFAULT, for the next person who comes along, too. I suspect there are just incorrect assumptions in the file you need to tweak.
 
Old 08-05-2003, 09:18 AM   #9
mobassir
Member
 
Registered: Jul 2003
Location: Pakistan
Distribution: Redhat , SME
Posts: 346

Original Poster
Rep: Reputation: 30
yes
i have tried again , its working now
i just add that user in root group, and set root as primary group for user wish to install xpde.
XP desk top enviemenet is working but there is no software to run any body how can i add software id this desktop

thank you for all
 
Old 08-05-2003, 09:39 AM   #10
Corin
Member
 
Registered: Jul 2003
Location: Jette, Brussels Hoofstedelijk Gewest
Distribution: Debian sid, RedHat 9, Suse 8.2
Posts: 446

Rep: Reputation: 31
Xpde is really not a suitable window manager for users comfortable with the freedom afforded them by Gnome, KDE, XFCE desktops and a whole plethora of window managers (FVWM, Blackbox, Icewm etc).

Please note the statement in the FAQ for the XPDE window manager -

Let's say it again. XPde doesn't want you to use it forever!! XPde doesn't try to create a new desktop interface!! It just exists to help *current* Windows XP users!! ;-))

Last edited by Corin; 08-05-2003 at 09:40 AM.
 
Old 08-11-2003, 08:35 AM   #11
mobassir
Member
 
Registered: Jul 2003
Location: Pakistan
Distribution: Redhat , SME
Posts: 346

Original Poster
Rep: Reputation: 30
i have install xpde sucsessfully , but its almost empty desktop , how i can import programe list from and gnome dektop to xpde
 
Old 08-11-2003, 04:00 PM   #12
Corin
Member
 
Registered: Jul 2003
Location: Jette, Brussels Hoofstedelijk Gewest
Distribution: Debian sid, RedHat 9, Suse 8.2
Posts: 446

Rep: Reputation: 31
Quote:
how i can import programe list from and gnome dektop to xpde
You read the documentation that came with the software and you visit the software home package site to learn how to configure it.

People who do not use XPde because it is not a properly developped window manager, and exists solely for the convenience of Windows XP users, are unable to assist you in this matter.

If you want Gnome features, then you use the Gnome desktop and not XPde.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
xpde drisay Slackware 3 03-21-2005 11:57 AM
How to install the xpde v5 vbbjq Mandriva 3 08-26-2004 03:02 AM
How to install the xpde! vbbjq VectorLinux 4 06-02-2004 04:57 PM
xpde masand Linux - Software 0 10-28-2003 05:13 AM
Installing XPDE kousik_s Mandriva 2 09-17-2003 01:20 AM


All times are GMT -5. The time now is 06:29 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration