LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 04-25-2006, 10:28 AM   #1
freekamail
LQ Newbie
 
Registered: Dec 2005
Distribution: Ubuntu 5.10
Posts: 16

Rep: Reputation: 0
How to disable save state across sessions in Gnome?


I am using Gnome 2.12.1 on Ubuntu 5.10 I want to know how one can disable the state save-across-session feature for some applications that seem to support it. Specifically the problem relates to Firestarter firewall, whose state is saved across the sessions. Whenever I login it complains about admin rights which my normal user doesn't have. However I already have enabled Firestarter at startup by having editing the sudoers file. In affect Fiestarter starts twice, once due to the saved state and once due to sudo firestarter --start-hidden command.

Any help will be appreciated
 
Old 04-25-2006, 11:10 AM   #2
brianthegreat
Member
 
Registered: Oct 2005
Posts: 518

Rep: Reputation: 32
Ahhh! I had this problem. You probably used the Automatix script which for some reason places a entry in the sessions.

System-->Preferences-->Sessions-->Startup Programs

Then delete the entry for firestarter. The firewall should start even though you delete this entry upon bootup. You might want to look at your configuration of firestarter to confirm this.
 
Old 04-26-2006, 08:40 AM   #3
freekamail
LQ Newbie
 
Registered: Dec 2005
Distribution: Ubuntu 5.10
Posts: 16

Original Poster
Rep: Reputation: 0
I didn't use Automatix and had installed Firestarter manually.

I have written the entry in the startup as

sudo firestarter --start-hidden

and there is an entry in my /etc/sudoers file for my user

<username> ALL=NOPASSWD: /usr/sbin/firestarter

So the startup entry doesn't give me any trouble while running firestarter

But due to session save (I think) there is another entry

/usr/sbin/firestarter --sm-config-prefix /firestarter-otDezh/ --sm-client-id 105e3fa07f000114605809900000098260000 --screen 0

which complains about insufficient rights, also I noticed that the command in startup (sudo firestarter --start-hidden) runs as root but the command when state of session is restored is run as the non previliged user

Last edited by freekamail; 04-26-2006 at 08:44 AM.
 
  


Reply

Tags
disable, firestarter, gnome, sessions


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How do -you- save STATE across web applications? lowpro2k3 Programming 2 05-23-2005 05:24 PM
Vidalinux 1.1 AthlonXP Build save sessions problem. JOKe Linux - Newbie 2 02-13-2005 04:29 AM
Session Save in Firefox--deleting saved sessions jonr Linux - Software 3 08-25-2004 01:22 PM
How to disable Power Save mode? Marina23 Linux - Hardware 3 05-15-2003 09:23 PM
Gnome Login sessions Ian Benjamin General 0 02-23-2001 09:04 AM


All times are GMT -5. The time now is 11:18 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration