LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   How to disable save state across sessions in Gnome? (http://www.linuxquestions.org/questions/linux-software-2/how-to-disable-save-state-across-sessions-in-gnome-438679/)

freekamail 04-25-2006 10:28 AM

How to disable save state across sessions in Gnome?
 
I am using Gnome 2.12.1 on Ubuntu 5.10 I want to know how one can disable the state save-across-session feature for some applications that seem to support it. Specifically the problem relates to Firestarter firewall, whose state is saved across the sessions. Whenever I login it complains about admin rights which my normal user doesn't have. However I already have enabled Firestarter at startup by having editing the sudoers file. In affect Fiestarter starts twice, once due to the saved state and once due to sudo firestarter --start-hidden command.

Any help will be appreciated

brianthegreat 04-25-2006 11:10 AM

Ahhh! I had this problem. You probably used the Automatix script which for some reason places a entry in the sessions.

System-->Preferences-->Sessions-->Startup Programs

Then delete the entry for firestarter. The firewall should start even though you delete this entry upon bootup. You might want to look at your configuration of firestarter to confirm this.

freekamail 04-26-2006 08:40 AM

I didn't use Automatix and had installed Firestarter manually.

I have written the entry in the startup as

sudo firestarter --start-hidden

and there is an entry in my /etc/sudoers file for my user

<username> ALL=NOPASSWD: /usr/sbin/firestarter

So the startup entry doesn't give me any trouble while running firestarter

But due to session save (I think) there is another entry

/usr/sbin/firestarter --sm-config-prefix /firestarter-otDezh/ --sm-client-id 105e3fa07f000114605809900000098260000 --screen 0

which complains about insufficient rights, also I noticed that the command in startup (sudo firestarter --start-hidden) runs as root but the command when state of session is restored is run as the non previliged user


All times are GMT -5. The time now is 12:59 AM.