LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 07-28-2004, 08:09 AM   #1
mwettach
Member
 
Registered: Oct 2003
Location: Germany
Distribution: SuSE 8.2, SuSE 9.1 on desktop (besides W2K). SuSE 9.1 on notebook (besides XP).
Posts: 44

Rep: Reputation: 15
Question How to disable auto session restore in KDE?


I have tried to start Gnome2 Nautilus from SUSE 8.2 which apparently was a bad idea. My desktop got cluttered with more than 200 error messages. They appear faster than I can close them.

What is worse, after I login again with the same user, KDE tries to restore all the applications and the same errors appear again. =:/

How can I disable the auto restore feature for this user (using a different login, e. g. root, or a non-KDE desktop)? I am almost sure there must be a config file for this.

Thanks.
 
Old 07-28-2004, 01:44 PM   #2
bulliver
Senior Member
 
Registered: Nov 2002
Location: Edmonton AB, Canada
Distribution: Gentoo x86_64; Gentoo PPC; FreeBSD; OS X 10.9.4
Posts: 3,760
Blog Entries: 4

Rep: Reputation: 77
Try:
Code:
rm -rf ~/.kde/Autostart/*
If this doesn't work all I can say is manually close all the apps, perhaps you will need to ps aux and kill the processes...then log out of kde.

Hmm, did a bit more research, and it would seem that the session data is actually in:
Code:
~/.kde/share/config/session/
So remove the contents of this directory before you startx...

Last edited by bulliver; 07-28-2004 at 01:53 PM.
 
Old 07-28-2004, 04:00 PM   #3
mwettach
Member
 
Registered: Oct 2003
Location: Germany
Distribution: SuSE 8.2, SuSE 9.1 on desktop (besides W2K). SuSE 9.1 on notebook (besides XP).
Posts: 44

Original Poster
Rep: Reputation: 15
Answering my own post...

I also did some research and looked into some of the KDE config files.
It seems that the windows to restore are remembered in
~/.kde/share/config/ksmserverrc

I deleted all the lines referring to open windows except window #1 (kwin).
That did the job.

Thanks for your help!

Last edited by mwettach; 07-28-2004 at 04:04 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
KDE Restore Session Fails Delphi123 Linux - Software 0 06-25-2005 04:39 PM
XDMCP Remote access session restore after disconnection soldonz Linux - Newbie 1 04-18-2005 04:20 PM
How do I restore the session?9.2 akihandyman Mandriva 3 09-17-2004 08:35 PM
How to disable KDE Auto-Restore? mwettach Linux - Newbie 1 07-29-2004 02:42 AM
disable auto login into KDE tonic Linux - General 3 02-16-2003 01:06 PM


All times are GMT -5. The time now is 06:53 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration