LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
LinkBack Search this Thread
Old 06-11-2008, 03:48 PM   #1
wyth
LQ Newbie
 
Registered: Jan 2005
Location: Charlottesville, VA
Distribution: Ubuntu
Posts: 16

Rep: Reputation: 0
Question How can I stop Amarok from automatically updating podcasts?


I posted this over at ubuntuforums, and 8 bumps and 4 days later, I've received not one response, so I'm trying over here.

Is there a way to keep Amarok from automatically updating podcasts? I know you can change the scan interval, but whenever I try to set it to zero, it just resets to a half hour. I've also unticked "Automatically scan for updates" on every podcast, but it still scans for updates.

I'd rather scan on my own because Amarok chokes whenever a feed hasn't updated; it spins its wheels, spawns a bunch of searches that never end, and when I try to use it, it crashes.

So I'd rather it just let me scan manually, but there doesn't seem to be a way to actually turn off the automatic scan or the scan interval.

Ideas?
 
Old 06-11-2008, 05:04 PM   #2
MS3FGX
Guru
 
Registered: Jan 2004
Location: NJ, USA
Distribution: Slackware, Debian
Posts: 5,850

Rep: Reputation: 350Reputation: 350Reputation: 350Reputation: 350
Have you tried turning off "Automatically Scan for Updates" from the top Podcasts "folder" rather than each individual podcast? Occasionally I have found that the individual settings don't always seem to apply for some reason.

Beyond that, perhaps you could just set the interval to 999999999 hours? Certainly not the most elegant solution...but it might work.
 
Old 06-11-2008, 06:04 PM   #3
wyth
LQ Newbie
 
Registered: Jan 2005
Location: Charlottesville, VA
Distribution: Ubuntu
Posts: 16

Original Poster
Rep: Reputation: 0
Hey, thanks for the reply -- that's the first one I've gotten.

I have my podcasts categorized into folders under the Podcasts folder in Amarok, which means you can't configure anything from the top Podcasts folder, only at the subfolder level. That's where I turned off automatic updates, but it doesn't seem to do anything.

But yeah, I have set it not to update for something like 2 days at a time (I'm at a different machine right now and can't check), but there's some point where it decides the time limit is too long, and it resets to something like every 30 minutes. I don't know where that point is, but I think 72 hours was too long.
 
Old 06-11-2008, 06:17 PM   #4
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
Perhaps you could use sqlite to change the podcastchannels.autoscan field to 0 on each of the entries.
 
Old 06-11-2008, 06:25 PM   #5
wyth
LQ Newbie
 
Registered: Jan 2005
Location: Charlottesville, VA
Distribution: Ubuntu
Posts: 16

Original Poster
Rep: Reputation: 0
jschiwal, I like that idea. I'll give that a try.
 
Old 06-11-2008, 07:54 PM   #6
wyth
LQ Newbie
 
Registered: Jan 2005
Location: Charlottesville, VA
Distribution: Ubuntu
Posts: 16

Original Poster
Rep: Reputation: 0
Just checked my laptop (where the issue is occurring), and the sqlite database has autoscan set to zero on all feeds.

There was a load of updates in the past couple days. This may have been ironed out, I have no idea. But I'll keep an eye on it to see if it still chokes.
 
Old 06-11-2008, 08:12 PM   #7
MS3FGX
Guru
 
Registered: Jan 2004
Location: NJ, USA
Distribution: Slackware, Debian
Posts: 5,850

Rep: Reputation: 350Reputation: 350Reputation: 350Reputation: 350
Yeah, I was just going to ask which version of Amarok are you seeing this in.
 
  


Reply

Tags
amarok, podcasts, update


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
amarok not retrieving podcasts abelloda Linux - Newbie 5 01-05-2008 04:12 AM
how to stop yum automatically updating the kernel ? hal_2001 Fedora 2 04-02-2007 08:12 AM
LXer: Download podcasts and sync music automatically with podget LXer Syndicated Linux News 0 04-02-2007 07:31 AM
problem getting amarok to play podcasts dasy2k1 Linux - Software 2 03-08-2007 03:41 AM
amarok podcasts - finding info via dcop? matthewg42 Linux - Software 1 09-20-2006 03:58 AM


All times are GMT -5. The time now is 05:15 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration