LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-24-2012, 06:26 AM   #1
Lumify
Member
 
Registered: Jan 2012
Distribution: Debian Stable
Posts: 52

Rep: Reputation: Disabled
Gtk-Message: Failed to load module "canberra-gtk-module"


I get this error whenever I open gedit.
Code:
Gtk-Message: Failed to load module "canberra-gtk-module"
I used strace gedit | grep can and I got this:
Code:
$ strace gedit 2>&1 | grep can
access("/home/user/.gtk-3.0/3.0.0/x86_64-pc-linux-gnu/modules/libcanberra-gtk-module.so", F_OK) = -1 ENOENT (No such file or directory)
access("/home/user/.gtk-3.0/3.0.0/x86_64-pc-linux-gnu/modules/libcanberra-gtk-module.la", F_OK) = -1 ENOENT (No such file or directory)
access("/home/user/.gtk-3.0/3.0.0/modules/libcanberra-gtk-module.so", F_OK) = -1 ENOENT (No such file or directory)
access("/home/user/.gtk-3.0/3.0.0/modules/libcanberra-gtk-module.la", F_OK) = -1 ENOENT (No such file or directory)
access("/home/user/.gtk-3.0/x86_64-pc-linux-gnu/modules/libcanberra-gtk-module.so", F_OK) = -1 ENOENT (No such file or directory)
access("/home/user/.gtk-3.0/x86_64-pc-linux-gnu/modules/libcanberra-gtk-module.la", F_OK) = -1 ENOENT (No such file or directory)
access("/home/user/.gtk-3.0/modules/libcanberra-gtk-module.so", F_OK) = -1 ENOENT (No such file or directory)
access("/home/user/.gtk-3.0/modules/libcanberra-gtk-module.la", F_OK) = -1 ENOENT (No such file or directory)
access("/usr/lib/x86_64-linux-gnu/gtk-3.0/3.0.0/x86_64-pc-linux-gnu/modules/libcanberra-gtk-module.so", F_OK) = -1 ENOENT (No such file or directory)
access("/usr/lib/x86_64-linux-gnu/gtk-3.0/3.0.0/x86_64-pc-linux-gnu/modules/libcanberra-gtk-module.la", F_OK) = -1 ENOENT (No such file or directory)
access("/usr/lib/x86_64-linux-gnu/gtk-3.0/3.0.0/modules/libcanberra-gtk-module.so", F_OK) = -1 ENOENT (No such file or directory)
access("/usr/lib/x86_64-linux-gnu/gtk-3.0/3.0.0/modules/libcanberra-gtk-module.la", F_OK) = -1 ENOENT (No such file or directory)
access("/usr/lib/x86_64-linux-gnu/gtk-3.0/x86_64-pc-linux-gnu/modules/libcanberra-gtk-module.so", F_OK) = -1 ENOENT (No such file or directory)
access("/usr/lib/x86_64-linux-gnu/gtk-3.0/x86_64-pc-linux-gnu/modules/libcanberra-gtk-module.la", F_OK) = -1 ENOENT (No such file or directory)
access("/usr/lib/x86_64-linux-gnu/gtk-3.0/modules/libcanberra-gtk-module.so", F_OK) = -1 ENOENT (No such file or directory)
access("/usr/lib/x86_64-linux-gnu/gtk-3.0/modules/libcanberra-gtk-module.la", F_OK) = -1 ENOENT (No such file or directory)
access("/usr/lib/gtk-3.0/3.0.0/x86_64-pc-linux-gnu/modules/libcanberra-gtk-module.so", F_OK) = -1 ENOENT (No such file or directory)
access("/usr/lib/gtk-3.0/3.0.0/x86_64-pc-linux-gnu/modules/libcanberra-gtk-module.la", F_OK) = -1 ENOENT (No such file or directory)
access("/usr/lib/gtk-3.0/3.0.0/modules/libcanberra-gtk-module.so", F_OK) = -1 ENOENT (No such file or directory)
access("/usr/lib/gtk-3.0/3.0.0/modules/libcanberra-gtk-module.la", F_OK) = -1 ENOENT (No such file or directory)
access("/usr/lib/gtk-3.0/x86_64-pc-linux-gnu/modules/libcanberra-gtk-module.so", F_OK) = -1 ENOENT (No such file or directory)
access("/usr/lib/gtk-3.0/x86_64-pc-linux-gnu/modules/libcanberra-gtk-module.la", F_OK) = -1 ENOENT (No such file or directory)
access("/usr/lib/gtk-3.0/modules/libcanberra-gtk-module.so", F_OK) = -1 ENOENT (No such file or directory)
access("/usr/lib/gtk-3.0/modules/libcanberra-gtk-module.la", F_OK) = -1 ENOENT (No such file or directory)
stat("libcanberra-gtk-module.so", 0x7fff73882db0) = -1 ENOENT (No such file or directory)
stat("libcanberra-gtk-module.so.so", 0x7fff73882db0) = -1 ENOENT (No such file or directory)
stat("libcanberra-gtk-module.so.la", 0x7fff73882db0) = -1 ENOENT (No such file or directory)
open("/lib/x86_64-linux-gnu/tls/x86_64/libcanberra-gtk-module.so", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/lib/x86_64-linux-gnu/tls/libcanberra-gtk-module.so", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/lib/x86_64-linux-gnu/x86_64/libcanberra-gtk-module.so", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/lib/x86_64-linux-gnu/libcanberra-gtk-module.so", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib/x86_64-linux-gnu/tls/x86_64/libcanberra-gtk-module.so", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib/x86_64-linux-gnu/tls/libcanberra-gtk-module.so", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib/x86_64-linux-gnu/x86_64/libcanberra-gtk-module.so", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib/x86_64-linux-gnu/libcanberra-gtk-module.so", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/lib/tls/x86_64/libcanberra-gtk-module.so", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/lib/tls/libcanberra-gtk-module.so", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/lib/x86_64/libcanberra-gtk-module.so", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/lib/libcanberra-gtk-module.so", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib/tls/x86_64/libcanberra-gtk-module.so", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib/tls/libcanberra-gtk-module.so", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib/x86_64/libcanberra-gtk-module.so", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib/libcanberra-gtk-module.so", O_RDONLY) = -1 ENOENT (No such file or directory)
write(2, "Gtk-Message: Failed to load modu"..., 57Gtk-Message: Failed to load module "canberra-gtk-module"
stat("/usr/share/fonts/opentype/cantarell", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
open("/usr/share/fonts/opentype/cantarell/Cantarell-Regular.otf", O_RDONLY) = 15
ioctl(0, SNDCTL_TMR_TIMEBASE or TCGETS, {B38400 opost isig icanon echo ...}) = 0
open("/usr/share/fonts/opentype/cantarell/Cantarell-Bold.otf", O_RDONLY) = 11
I have these packages installed: gnome-session-canberra, libcanberra-gtk-module, libcanberra-gtk0, libcanberra-gtk3-0, libcanberra-pulse, libcanberra0. I'm running Gnome 3.2.1, Debian Wheezy.
 
Old 03-25-2012, 03:55 PM   #2
John VV
LQ Muse
 
Registered: Aug 2005
Posts: 16,412

Rep: Reputation: 2319Reputation: 2319Reputation: 2319Reputation: 2319Reputation: 2319Reputation: 2319Reputation: 2319Reputation: 2319Reputation: 2319Reputation: 2319Reputation: 2319
Quote:
"/usr/lib/x86_64-linux-gnu/gtk-3.0/modules/libcanberra-gtk-module.so", F_OK) = -1 ENOENT (No such file or directory)
" (No such file or directory)"

that is fairly self explanatory
you do not have it installed , or
you installed it some place else

but the 64 bit version is not where it is expected
 
Old 03-29-2012, 01:53 PM   #3
Lumify
Member
 
Registered: Jan 2012
Distribution: Debian Stable
Posts: 52

Original Poster
Rep: Reputation: Disabled
I found that file elsewhere (it was in a GTK2 folder) and copied it to that location, but it complained that I couldn't use the GTK2 module for GTK3. I used apt-file to search for libcanberra-gtk-module.so, and I found that the package libcanberra-gtk3-module had that file. After installing that, everything works fine.
 
Old 12-05-2012, 06:24 AM   #4
roddersg
LQ Newbie
 
Registered: May 2011
Posts: 1

Rep: Reputation: 1
Thank you!! You hit the nail on the head!

sudo apt-get install libcanberra-gtk3-module

works like a charm!!
Thanks
 
1 members found this post helpful.
Old 06-15-2013, 12:12 PM   #5
Savalan
LQ Newbie
 
Registered: Oct 2010
Posts: 3

Rep: Reputation: 0
Cool

Quote:
Originally Posted by roddersg View Post
sudo apt-get install libcanberra-gtk3-module

works like a charm!!
Thanks
you're a bowss!
 
Old 04-18-2014, 12:09 PM   #6
estomagado
LQ Newbie
 
Registered: Jul 2012
Posts: 2

Rep: Reputation: Disabled
64 bit

This is an old thread, but I'm adding info that might be of use.

You may be getting this message in 64-bit systems even though you have the lib installed. That's because you might be using a 32-bit software and it expects the lib somewhere else.

My system is an Ubuntu 14.04, but I guess it would be the same thing on your Debian:

Code:
sudo apt-get install libcanberra-gtk-module:i386
Regards
--
estomagado
 
Old 09-02-2014, 12:38 PM   #7
aaguillon
LQ Newbie
 
Registered: Sep 2014
Location: Caracas
Distribution: Debian 7
Posts: 1

Rep: Reputation: Disabled
I have libcanberra-gtk-module:i386 and libcanberra-gtk-module. The message still happens. Any clue?
Debian 7 amd64 multiarch.
Thanks!
 
Old 10-02-2014, 05:12 PM   #8
samthewildone
LQ Newbie
 
Registered: Oct 2014
Distribution: Gnome Ubuntu 14.04LTS
Posts: 1

Rep: Reputation: Disabled
@aaguillion

Same here my friend, error still shows on mine.
Ubuntu 14.04.1LTS amd64

Code:
samthewildone@Olympian:~$ sudo apt-get install libcanberra-gtk3-module
[sudo] password for samthewildone: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libcanberra-gtk3-module is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
samthewildone@Olympian:~$ sudo apt-get install libcanberra-gtk-module:i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libcanberra-gtk-module:i386 is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
samthewildone@Olympian:~$ alarmclock 
Gtk-Message: Failed to load module "canberra-gtk-module"
^Z
[1]+  Stopped                 alarmclock
samthewildone@Olympian:~$ alarm
alarmclock          alarm-clock-applet  
samthewildone@Olympian:~$ alarm-clock-applet 
Gtk-Message: Failed to load module "canberra-gtk-module"
alarm-clock-applet is already running, exiting...
samthewildone@Olympian:~$


---------- Post added 10-02-14 at 06:13 PM ----------

@aaguillion

Last edited by samthewildone; 10-02-2014 at 05:16 PM. Reason: double post
 
Old 11-04-2014, 01:24 PM   #9
acousticks
LQ Newbie
 
Registered: Nov 2014
Posts: 1

Rep: Reputation: Disabled
gtk2, gtk3

Try the following

sudo yum install libcanberra-gtk2.i686
sudo yum install libcanberra-gtk3.i686
sudo yum install libcanberra-devel.i686

in order from top to bottom

use yum or apt-get as necessary.
 
1 members found this post helpful.
Old 03-03-2015, 06:08 PM   #10
x.gooch.x
LQ Newbie
 
Registered: Mar 2015
Posts: 1

Rep: Reputation: Disabled
On Ubuntu 12.04 server 64, I had to call:

sudo apt-get install libcanberra-gtk*

In order to remove the warning: Gtk-Message: Failed to load module "canberra-gtk-module"
 
1 members found this post helpful.
Old 07-14-2015, 11:19 AM   #11
mandolyn
LQ Newbie
 
Registered: Jul 2015
Posts: 1

Rep: Reputation: Disabled
Thanke too x.gooch.x . This seems to work fine here.

Linux samsung 3.16.0-4-amd64 #1 SMP Debian 3.16.7-ckt11-1 (2015-05-24) x86_64 GNU/Linux
 
Old 08-02-2015, 02:11 AM   #12
jobsworth
LQ Newbie
 
Registered: Jan 2010
Location: brighton england
Distribution: Debian not Ubuntu
Posts: 15

Rep: Reputation: 0
hello all,

i just did this on my amd debian jessie 64 bit system:-

sudo apt-get install libcanberra-gtk-module:i386
sudo apt-get install libcanberra-gtk*

it downloaded and installed a massive number of files
18.6MB and 197MB.

All of that just to remove a message about canberra-gtk-module!

What if anything have I gained?
 
Old 08-22-2015, 12:16 PM   #13
mmhmm
LQ Newbie
 
Registered: Aug 2015
Posts: 1

Rep: Reputation: Disabled
For me just the following command (with su permissions) helped:
Code:
apt-get install libcanberra-gtk-module
It's only 31,8 kB.
 
Old 10-17-2015, 08:36 AM   #14
rightec
LQ Newbie
 
Registered: Oct 2015
Posts: 1

Rep: Reputation: Disabled
Hello. It also occured to me when running a Qt application with Qt Creator 5.3.2 in Debian 8.2.
apt-get install libcanberra-gtk-module
worked fine to me

Thanks
 
Old 03-22-2016, 09:45 AM   #15
jlibraryist
LQ Newbie
 
Registered: Feb 2016
Distribution: debian
Posts: 18

Rep: Reputation: Disabled
Quote:
Originally Posted by x.gooch.x View Post
On Ubuntu 12.04 server 64, I had to call:

sudo apt-get install libcanberra-gtk*

In order to remove the warning: Gtk-Message: Failed to load module "canberra-gtk-module"
I followed a variation on this command - which solved my very similar problem.

Thank you to the various contributors in this thread.

J.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
(EE) Failed to load module "nvidia" (module does not exist, 0) sanitynotvanity Slackware 6 12-11-2011 12:04 PM
F15 gconf-editor Gtk-Message: Failed to load module "pk-gtk-module" syntax error Fedora 5 06-02-2011 02:10 PM
Xorg -- (EE) Failed to load module "glx" (loader failed, 7) windowsrefugeeX Linux - Software 10 09-23-2009 05:51 PM
Failed to load module "ati" (module does not exist, after upgrad from Redhat 3 to 5. perrym8 Red Hat 2 07-24-2007 10:14 AM
"Failed to load module "i915"" Kane635 Linux - Software 0 11-22-2004 08:17 PM


All times are GMT -5. The time now is 12:42 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration