LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 05-31-2011, 09:13 AM   #1
syntax error
LQ Newbie
 
Registered: Apr 2010
Posts: 3

Rep: Reputation: 0
F15 gconf-editor Gtk-Message: Failed to load module "pk-gtk-module"


When trying to launch gconf-editor or chemtool I encounter the following error message

Gtk-Message: Failed to load module "pk-gtk-module"
**
GLib-GIO:ERROR:gdbusconnection.c:2279:initable_init: assertion failed: (connection->initialization_error == NULL)
Aborted (core dumped)

I never met any problem in F14, so I assume the upgrading process lead to this problem. I am glad for any comments or suggestions. As I understand, pk-gtk-module errors seem to be a rather common problem in various contexts, however so far I could not find any helpful workaround.

regards

se
 
Old 05-31-2011, 09:47 AM   #2
SkyEye
Member
 
Registered: Sep 2005
Location: Sri Lanka
Distribution: Fedora (workstations), CentOS (servers), Arch, Mint, Ubuntu, and a few more.
Posts: 441

Rep: Reputation: 40
Try installing 'PackageKit-gtk-module' and see if it fixes this.

$ su -c "yum install PackageKit-gtk-module"
 
Old 05-31-2011, 11:16 AM   #3
syntax error
LQ Newbie
 
Registered: Apr 2010
Posts: 3

Original Poster
Rep: Reputation: 0
Thanks for your suggestion. I had it already installed and to its latest version.

Quote:
Originally Posted by SkyEye View Post
Try installing 'PackageKit-gtk-module' and see if it fixes this.

$ su -c "yum install PackageKit-gtk-module"
 
Old 06-01-2011, 02:57 PM   #4
ColinTempler
LQ Newbie
 
Registered: Oct 2008
Posts: 9

Rep: Reputation: Disabled
I also have this problem after updating to F15 but with unetbootin:
# whoami
root
# unetbootin
**
GLib-GIO:ERROR:gdbusconnection.c:2279:initable_init: assertion failed: (connection->initialization_error == NULL)
Aborted (core dumped)
#
I've tried installing the PackageKit-gtk-module too but I had it already at the latest version.
Any more ideas?
 
Old 06-01-2011, 07:54 PM   #5
NeilBryant
LQ Newbie
 
Registered: Jun 2011
Posts: 2

Rep: Reputation: Disabled
I get this error if I run gconf-editor as root. I don't get it under sudo.

HTH
 
Old 06-02-2011, 02:10 PM   #6
ColinTempler
LQ Newbie
 
Registered: Oct 2008
Posts: 9

Rep: Reputation: Disabled
I can confirm that with sudo, unetbootin works.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
(EE) Failed to load module "nvidia" (module does not exist, 0) sanitynotvanity Slackware 6 12-11-2011 12:04 PM
Xorg -- (EE) Failed to load module "glx" (loader failed, 7) windowsrefugeeX Linux - Software 10 09-23-2009 05:51 PM
Failed to load module "ati" (module does not exist, after upgrad from Redhat 3 to 5. perrym8 Red Hat 2 07-24-2007 10:14 AM
mkinitrd failed with message "no module raid0 found for kernel 2.6.9" ythevenot Red Hat 3 12-07-2004 09:15 PM
"Failed to load module "i915"" Kane635 Linux - Software 0 11-22-2004 08:17 PM


All times are GMT -5. The time now is 09:43 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration