LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 11-26-2004, 10:37 AM   #1
Snerkel
Member
 
Registered: Jul 2004
Location: England
Distribution: 1 Gentoo 2005.0 system(desktop), 1 hardened-gentoo SeLinux stage1 server ;)
Posts: 262

Rep: Reputation: 30
Gentoo. Problems with the loop device when mounting an iso file [Solved]


Hi, im trying to mount an iso file in gentoo, to do it im using the command mount -t iso9660 -o loop /iso/dir /mnt/iso but i get this error
Quote:
mount: could not find any device /dev/loop#
i dont know how to get round this problem as i dont even know what the loop device is! can anyone help me?

Thanks in advance, Ben

Last edited by Snerkel; 11-26-2004 at 04:35 PM.
 
Old 11-26-2004, 12:03 PM   #2
geniarse
Member
 
Registered: May 2003
Location: UK
Distribution: Gentoo
Posts: 141

Rep: Reputation: 15
try this as root:

Code:
cd /dev
MAKEDEV loop
(note capital letters) if this doesn't work you may have to recompile the kernel with loop device support (or something of the ilk) but I don't know exactly where to find this
 
Old 11-26-2004, 02:55 PM   #3
steve_d555
Member
 
Registered: Apr 2004
Location: Massachusetts
Distribution: Debian, Slack 10, Gentoo!
Posts: 87

Rep: Reputation: 15
Did you enable loop devices in the kernel?
Should be under filesystems.

--Steve
 
Old 11-26-2004, 04:26 PM   #4
Snerkel
Member
 
Registered: Jul 2004
Location: England
Distribution: 1 Gentoo 2005.0 system(desktop), 1 hardened-gentoo SeLinux stage1 server ;)
Posts: 262

Original Poster
Rep: Reputation: 30
ok, i tried MAKEDEV loop but i get this error:

Quote:
root@myroom dev # MAKEDEV loop
.devfsd presence implies active DevFS. Aborting MAKEDEV invocation.
and i configured my own kernel, it was not a first time thing i know how to configure it. i was looking through the kernel make menuconfig but i couldnt see anything to do with loop.

Can anyone help me ? im running the 2.6.9 kernel.

Thanks,
 
Old 11-26-2004, 04:34 PM   #5
Snerkel
Member
 
Registered: Jul 2004
Location: England
Distribution: 1 Gentoo 2005.0 system(desktop), 1 hardened-gentoo SeLinux stage1 server ;)
Posts: 262

Original Poster
Rep: Reputation: 30
Ok All sorted

For referance visit this Gentoo forum thread
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
can't mount iso 'could not find any loop device' dethree Slackware 1 06-23-2005 02:14 AM
can't mount cdrom (after mounting .iso once, using -o loop) cmbguy Linux - Newbie 4 03-21-2005 12:25 AM
Gentoo. Problems mounting an iso file Snerkel Linux - Distributions 2 11-26-2004 04:32 PM
Cannot mount more than 8 iso image files as loop device marsim Debian 4 11-09-2004 05:05 AM
Problem mounting CD image (no loop device)... Slayer Linux - General 1 10-05-2003 10:30 AM


All times are GMT -5. The time now is 08:50 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration