LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 02-19-2004, 05:09 PM   #1
randyriver10
Member
 
Registered: Sep 2003
Location: Nova Scotia
Distribution: Mandrake
Posts: 122

Rep: Reputation: 15
Angry ERROR running make when installing Nvidia drivers (syntax error)


5a2280" on integer constant
/lib/modules/2.4.22-10mdk/build/include/linux/ioport.h:118: error: syntax error
before numeric constant
/lib/modules/2.4.22-10mdk/build/include/linux/ioport.h:118: error: `autoirq_setu
p_R_ver_str' declared as function returning a function
/lib/modules/2.4.22-10mdk/build/include/linux/ioport.h:118: warning: function de
claration isn't a prototype
/lib/modules/2.4.22-10mdk/build/include/linux/ioport.h:119:12: invalid suffix "c 53" on integer constant
/lib/modules/2.4.22-10mdk/build/include/linux/ioport.h:119: error: syntax error before numeric constant
/lib/modules/2.4.22-10mdk/build/include/linux/ioport.h:119: error: `autoirq_repo rt_R_ver_str' declared as function returning a function
/lib/modules/2.4.22-10mdk/build/include/linux/ioport.h:119: warning: function de claration isn't a prototype
In file included from nvhw.h:15,
from nvrec.c:12:
/lib/modules/2.4.22-10mdk/build/include/linux/sched.h:6:22: invalid suffix "b16c 344" on integer constant
In file included from nvhw.h:15,
from nvrec.c:12:
/lib/modules/2.4.22-10mdk/build/include/linux/sched.h:6: error: syntax error bef ore numeric constant
/lib/modules/2.4.22-10mdk/build/include/linux/sched.h:6: warning: function decla ration isn't a prototype
make[2]: *** [nvrec.o] Error 1
make[2]: Leaving directory `/home/epro/Nforcesource/nforce/nvaudio'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/home/epro/Nforcesource/nforce/nvaudio'
make: *** [nvaudio_make] Error 2
[root@localhost nforce]#
 
Old 02-20-2004, 02:34 AM   #2
salparadise
Senior Member
 
Registered: Nov 2002
Location: Birmingham UK
Distribution: Freeslack
Posts: 1,713

Rep: Reputation: 104Reputation: 104
which version of the nvidia drivers are you using?

and, are you using src files or the .run script?
 
Old 02-20-2004, 04:57 PM   #3
randyriver10
Member
 
Registered: Sep 2003
Location: Nova Scotia
Distribution: Mandrake
Posts: 122

Original Poster
Rep: Reputation: 15
its the tar.gz one
 
Old 02-21-2004, 03:02 AM   #4
salparadise
Senior Member
 
Registered: Nov 2002
Location: Birmingham UK
Distribution: Freeslack
Posts: 1,713

Rep: Reputation: 104Reputation: 104
tar.gz?

hmmm

i always use the NVIDIA-Linux-x86-1.0-xxxx-pkgx.run

latest version is 5336-pkg1.run

this is a script, run it as root, the only failures I have had with this is when i try with a too old
version of the drivers with a too new distro,
the 5336-pkg1.run installs on mandrake 9.2 perfectly, so should install on mdk 9.0/9.1

download it, open a terminal, cd to driver location, su to root and type

sh NVIDIA-Linux-x86-1.0-xxxx-pkgx.run (replace x with right numbers)

when it's installed, you'll need to edit the /etc/X11/XF86Config-4 file, this can only be done as root,
so in a terminal, still as root, type
kedit /etc/X11/XF86Config-4
look for the line that says
driver "nv"
and change it to driver "nvidia"
save, exit and restart x (logout and back in again)

Last edited by salparadise; 02-21-2004 at 03:06 AM.
 
Old 02-21-2004, 03:23 PM   #5
randyriver10
Member
 
Registered: Sep 2003
Location: Nova Scotia
Distribution: Mandrake
Posts: 122

Original Poster
Rep: Reputation: 15
these arent the nvidia graphics drivers....its for sound
 
Old 02-21-2004, 05:51 PM   #6
salparadise
Senior Member
 
Registered: Nov 2002
Location: Birmingham UK
Distribution: Freeslack
Posts: 1,713

Rep: Reputation: 104Reputation: 104
humble apologies

appear to have wrong end of stick

doubley bad because my audio is i810 and I have no problems with it
and thus haven't come up against the problems you are having

might be worth adding the word sound to the subject line because nvidia graphic driver questions are very common on this site and often get ignored by older, more experienced members because they think (rightly) that people should search the site first


Last edited by salparadise; 02-21-2004 at 06:00 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Error running make Fusspils Linux - Newbie 4 09-14-2005 01:18 PM
Many errors when 'make'ing (example: error: syntax error before `::' token) darkblade Linux - Software 5 03-02-2005 04:00 PM
C++ syntax error before :: token HELP, i cant find the syntax error :( qwijibow Programming 2 12-14-2004 07:09 PM
Installing latest nVidia drivers in Mandrake 10. rivafb error? Pumaman Linux - Hardware 4 07-09-2004 08:04 PM
error when running make punt Linux - General 2 09-24-2001 08:38 PM


All times are GMT -5. The time now is 06:39 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration