LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 07-08-2004, 03:11 AM   #1
phlyersphan
Member
 
Registered: Jun 2004
Location: Chicago, IL USA
Distribution: Mandrake 10
Posts: 103

Rep: Reputation: 15
Error Evolution Unknown CORBA exception


Hi all -

Today's tragedy: Evolution has quit working on me.

KDE, Mandrake 10, Evolution version 1.4.6

I did nothing on the machine today that I can imagine is related - updated my Gaim install, configured new settings on my wlan0 interface....

Problem: Start evolution and receive these error messages:

Code:
Cannot activate component OAFIID:GNOME_Evolution_Mail_ShellComponent :
The error from the activation system is:
Unknown CORBA exception id: 'IDL:omg.org/CORBA/INV_OBJREF:1.0'

Cannot activate component OAFIID:GNOME_Evolution_Addressbook_ShellComponent :
The error from the activation system is:
Unknown CORBA exception id: 'IDL:omg.org/CORBA/INV_OBJREF:1.0'

Cannot activate component OAFIID:GNOME_Evolution_Calendar_ShellComponent :
The error from the activation system is:
Unknown CORBA exception id: 'IDL:omg.org/CORBA/INV_OBJREF:1.0'

Cannot activate component OAFIID:GNOME_Evolution_Summary_ShellComponent :
The error from the activation system is:
Unknown CORBA exception id: 'IDL:omg.org/CORBA/INV_OBJREF:1.0'


Then the program loads, and all folders are displayed on the left, but in the right pane, it shows "no folder displayed" and no folder contents. Contents of folders cannot be displayed by clicking the folders in the left column, either.

Help!! I've googled this error to death and found tons of people having the same problem, but no solution.
 
Old 07-08-2004, 03:28 AM   #2
Ice9
Member
 
Registered: Jun 2002
Location: Belgium
Distribution: Sidux
Posts: 313

Rep: Reputation: 30
Check your network settings.
I sometimes have that error too, and every time it's because the network is unavailable while the cable is plugged in.
A reboot is necessary to be able to use evolution again, a network restart isn't enough!

Try to unplug your network cable, reboot and see if it works.
If it still doesn't work and all your network settings/hardware are correct and up-and-running you could always try to re-install or revert to a prior version.

I've found evolution to have the same type of flaws that Windows software has, restarting the app/service doesn't work you have to reboot, buggy releases (like xml data that gets lost and suddenly the folders you created are gone, or attachments that refuse to show at the botom of the mail).
So now I use Kontact, it's less prone to crashes, has the same functionalities and looks better (as is the case most of the timewen you compare KDE apps to gnome apps) but looks are a totally subjective ting so ...
 
Old 07-08-2004, 01:48 PM   #3
phlyersphan
Member
 
Registered: Jun 2004
Location: Chicago, IL USA
Distribution: Mandrake 10
Posts: 103

Original Poster
Rep: Reputation: 15
I'll have to look into Kontact, as this isn't the first crash I've had in the week I've been using evolution. Indeed, a reboot fixed the problem (what?!?! Rebooting a linux box?!?!!)

Evolution was the first prog I looked at that had the email, contacts, and calendar all in one. Mozilla mail didn't, or else I'd have tried that.

Now will be the joy of figuring out how to transfer my mail to Kontact, if I like it Getting my mail from outlook was a mess of burning to a cd, going to another box with Windows installed, installing Outlook there, importing mail/contacts into the new Outlook, importing THAT into Mozilla mail, putting on a thumb drive, moving back to the linux box, and importing folders One.... by .... One into Evolution. Ugh!

Thanks for the help! At least evolution is working again
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Adding client to server's list failed, CORBA error: IDL:omg.org/CORBA/COMM_FAILURE:1. wlfdgcrkz Linux - Software 2 01-26-2008 01:28 PM
evolution stopped working - "CORBA" exception thegreatgatsby Linux - Software 3 03-16-2004 07:28 AM
CORBA error when running Gnome apps Dapper Dan Linux - General 1 01-12-2004 11:04 AM
startx error: vesa(0) unknown reason for exception pi314159 Slackware 1 12-04-2003 08:13 AM
CORBA Configuration error -- gotta be a better way jpbarto Linux - Software 0 09-27-2003 03:52 PM


All times are GMT -5. The time now is 11:12 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration