Visit Jeremy's Blog.
Go Back > Forums > Linux Forums > Linux - Software
User Name
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.


  Search this Thread
Old 09-03-2004, 10:45 AM   #1
LQ Newbie
Registered: Sep 2004
Posts: 2

Rep: Reputation: 0
Enemy Territory - No sound

Well after searching and searching I havn't been able to find a solution to my problem and i'm going to pull my hair out lol.

Sound works fine in linux, xmms works with ALSA, etc but whenever I run ET I get:

------- sound initialization -------
/dev/dsp: No such device
Could not toggle.

I changed permissions on /dev/dsp and /dev/dsp0 to 777 with no results, here's the output of ls -l /dev/dsp*

crwxrwxrwx 1 andrew root 14, 3 Feb 23 2004 /dev/dsp
lrwxrwxrwx 1 root root 3 Sep 1 23:10 /dev/dsp0 -> dsp
crw------- 1 andrew root 14, 19 Feb 23 2004 /dev/dsp1


Fedora Core 2, stock kernel
Sblive sound

Thanks for the help!
Old 09-04-2004, 08:53 PM   #2
Senior Member
Registered: Dec 2003
Location: Paris
Distribution: Slackware forever.
Posts: 2,252

Rep: Reputation: 87
Add your distro in your profile, plz.
In Slack (and other distros), there's a /etc/group file where you can put owners without thrash your system with chmoding like a punk. Artsd followed by artsdsp -m ennemyterritorycommand can be the answer.
Old 09-07-2004, 11:03 AM   #3
LQ Newbie
Registered: Sep 2004
Posts: 2

Original Poster
Rep: Reputation: 0
when trying to run artsd I get the following:

ALSA lib pcm_hw.c:494snd_pcm_hw_start) SNDRV_PCM_IOCTL_START failed: Broken pipe

Doesn't gnome use esd and not arts? If so what's the command to start enemy territory using esd.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
No sound in Enemy Territory wnaLinux Linux - Games 13 02-13-2005 05:00 PM
No sound only in Enemy Territory kjp_72 Linux - Newbie 0 05-22-2004 11:53 AM
Sound in Enemy Territory jeempc Linux - Hardware 5 03-02-2004 11:24 AM
Sound problem in Enemy Territory G-fahmah Linux - Games 2 02-26-2004 02:17 PM
Enemy Territory.. no sound?? trey85stang Linux - Games 3 12-20-2003 04:10 PM

All times are GMT -5. The time now is 05:54 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration