LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 03-02-2004, 12:07 AM   #1
jeempc
Member
 
Registered: Mar 2003
Location: Ann Arbor, MI
Distribution: Slackware 10.1
Posts: 119

Rep: Reputation: 15
Sound in Enemy Territory


Hello all. My sound works in X but not in the game Enemy Territory, I am confused. Here is the error and my dsp settings follow. I'm not sure what mmap is. I manned it but is was over my head.




------- sound initialization -------
/dev/dsp: Input/output error
Could not mmap /dev/dsp
------------------------------------


jeem@mystar:~$ ll /dev/dsp*
crw-rw-r-- 1 root sys 14, 51 Aug 29 2003 /dev/dsp3
crw-rw-r-- 1 root sys 14, 35 Aug 29 2003 /dev/dsp2
crw-rw-r-- 1 root sys 14, 19 Aug 29 2003 /dev/dsp1
crwxrwxrwx 1 root sys 14, 3 Aug 29 2003 /dev/dsp0
lrwxrwxrwx 1 root root 4 Mar 1 17:00 /dev/dsp -> dsp0
 
Old 03-02-2004, 09:01 AM   #2
320mb
Senior Member
 
Registered: Nov 2002
Location: pikes peak
Distribution: Slackware, LFS
Posts: 2,577

Rep: Reputation: 47
hhmm, I show the exact same ls -l output except for this.......
Code:
crwxrwxrwx 1 root sys 14, 3 Aug 29 2003 /dev/dsp0
on my box it says this..........
Code:
crw-rw-r-- 1 root sys 14, 3 Aug 29 2003 /dev/dsp0
you might change /dev/dsp0 and see if memory map will pick it up.......
I not real sure IF character devices should be executable like that......
the symlink is ok, it just points and takes the attributes of the other device.........((shrug shoulders))

Last edited by 320mb; 03-02-2004 at 09:04 AM.
 
Old 03-02-2004, 09:15 AM   #3
jeempc
Member
 
Registered: Mar 2003
Location: Ann Arbor, MI
Distribution: Slackware 10.1
Posts: 119

Original Poster
Rep: Reputation: 15
Thanks. I'll try when I get home. I am the one who changed it chmod a+w because it didn't work like this--crw rw r
Maybe it has something to do with ALSA or Artsd. I have to read up up on Linux sound I guess.
Thanks
Jeem
 
Old 03-02-2004, 09:18 AM   #4
jeempc
Member
 
Registered: Mar 2003
Location: Ann Arbor, MI
Distribution: Slackware 10.1
Posts: 119

Original Poster
Rep: Reputation: 15
I meant chmod a+rwx if that helps.
One more thing. On my other linux box the sound is loaded as a module (Sound Blaster). alsaconf could't find the card. On the box that the sound dosen't work I had to run alsaconf and then alsactrl restore to getr the sound to work.
Still confused,
Jeem
 
Old 03-02-2004, 10:31 AM   #5
320mb
Senior Member
 
Registered: Nov 2002
Location: pikes peak
Distribution: Slackware, LFS
Posts: 2,577

Rep: Reputation: 47
Ok, from what I've read here, Sound support in the kernel should be direct ( not as a module ) and the ALSA componants should all be compiled as modules............
 
Old 03-02-2004, 11:24 AM   #6
jeempc
Member
 
Registered: Mar 2003
Location: Ann Arbor, MI
Distribution: Slackware 10.1
Posts: 119

Original Poster
Rep: Reputation: 15
I am a little confused still about Linux sound. Do you know of any good links that can explain all of this. I use Slackware 9.1.
For my first box is uncommented the /sbin/modprobe/emu10k1 (or something like that) (Sound Blaster) to get my sound working. Is that that the correct procedure, or is it already in the kernel source?
For my second box it is an integrated sound card and I had to run alsactrl restore to get it to work in X. Except it still doesn't work in my game.
Thanks
Jeem
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
No sound in Enemy Territory wnaLinux Linux - Games 13 02-13-2005 05:00 PM
Enemy Territory - No sound lindude Linux - Software 2 09-07-2004 11:03 AM
No sound only in Enemy Territory kjp_72 Linux - Newbie 0 05-22-2004 11:53 AM
Sound problem in Enemy Territory G-fahmah Linux - Games 2 02-26-2004 02:17 PM
Enemy Territory.. no sound?? trey85stang Linux - Games 3 12-20-2003 04:10 PM


All times are GMT -5. The time now is 09:09 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration