LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 04-21-2006, 10:43 AM   #1
Coldmiser
Member
 
Registered: Sep 2003
Location: Chicago
Distribution: Ubuntu
Posts: 36

Rep: Reputation: 15
Dovecot pop3 authentication problem


I'm having problems authenticating against my Dovecot pop3 server.
When I look at the mail.log file here is my output.

dovecot: Apr 21 11:12:37 Info: Dovecot v1.0.beta7 starting up
dovecot: Apr 21 11:12:41 Error: auth(default): shadow(coldmiser,32.32.32.32): Multiple password values not supported
dovecot: Apr 21 11:12:41 Info: pop3-login: Login: user=<coldmiser>, method=PLAIN, rip=32.32.32.32, lip=192.192.192.192
dovecot: Apr 21 11:12:41 Error: POP3(coldmiser): pop3_uidl_format setting is missing from config file
dovecot: Apr 21 11:12:41 Error: child 710 (pop3) returned error 89

(IP addresses have been changed to protect the innocent).
Not much information there so when I try to Telnet to it and feed it raw POP3 commands I get the following:
+OK Dovecot ready.
USER coldmiser
+OK
PASS blahblah
-ERR Authentication failed..
OK, that tells me that I have a problem in my CONF file somewhere, but I can't find it for the life of me.

Here is a copy of my dovecot.conf file.
protocols = imap imaps pop3 pop3s
disable_plaintext_auth = no
log_path = /var/log/mail.log
protocol imap {
}
protocol pop3 {
}
auth default {
mechanisms = plain
passdb passwd {
}
passdb shadow {
}
userdb passwd {
}
user = root
}
plugin {
}
Can anyone see anything wrong in there?

Last edited by Coldmiser; 04-21-2006 at 11:15 AM.
 
Old 06-27-2006, 10:07 PM   #2
kitzune
LQ Newbie
 
Registered: Jun 2006
Posts: 1

Rep: Reputation: 0
I had the same problem and not sure what caused it to happen.
And the following entry from what I have read is suppose to
be the default. But when I added it, pop3 started working again.
There is a commented out entry in the conf file.

pop3_uidl_format = %08Xu%08Xv



Quote:
Originally Posted by Coldmiser
I'm having problems authenticating against my Dovecot pop3 server.
When I look at the mail.log file here is my output.

dovecot: Apr 21 11:12:37 Info: Dovecot v1.0.beta7 starting up
dovecot: Apr 21 11:12:41 Error: auth(default): shadow(coldmiser,32.32.32.32): Multiple password values not supported
dovecot: Apr 21 11:12:41 Info: pop3-login: Login: user=<coldmiser>, method=PLAIN, rip=32.32.32.32, lip=192.192.192.192
dovecot: Apr 21 11:12:41 Error: POP3(coldmiser): pop3_uidl_format setting is missing from config file
dovecot: Apr 21 11:12:41 Error: child 710 (pop3) returned error 89

(IP addresses have been changed to protect the innocent).
Not much information there so when I try to Telnet to it and feed it raw POP3 commands I get the following:
+OK Dovecot ready.
USER coldmiser
+OK
PASS blahblah
-ERR Authentication failed..
OK, that tells me that I have a problem in my CONF file somewhere, but I can't find it for the life of me.

Here is a copy of my dovecot.conf file.
protocols = imap imaps pop3 pop3s
disable_plaintext_auth = no
log_path = /var/log/mail.log
protocol imap {
}
protocol pop3 {
}
auth default {
mechanisms = plain
passdb passwd {
}
passdb shadow {
}
userdb passwd {
}
user = root
}
plugin {
}
Can anyone see anything wrong in there?
 
Old 11-21-2006, 09:38 PM   #3
buddha1256
LQ Newbie
 
Registered: Nov 2006
Posts: 1

Rep: Reputation: 0
thanks for the tip

I also has this problem.

Your advice worked perfectly.
 
Old 12-08-2006, 05:21 PM   #4
tbeehler
Member
 
Registered: Aug 2003
Location: Washington State, USA
Distribution: Mainly RH 9.0
Posts: 226

Rep: Reputation: 30
Yep, this worked perfectly for me too. I wonder why they commented it out by default? Oh well, thanks for the solution!

Travis
 
Old 09-09-2008, 11:16 PM   #5
sambajahjah
LQ Newbie
 
Registered: Jan 2005
Posts: 5

Rep: Reputation: 0
Smile Solved

Yes it worked like a charm.

Thank's a lot!
 
  


Reply

Tags
authentication, dovecot, pop3


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
i want to setup pop3 for dovecot in rh9 syedabdul Linux - Networking 0 04-09-2006 02:00 AM
LXer: Set up a secure IMAP/POP3 server with Dovecot LXer Syndicated Linux News 0 04-06-2006 07:33 PM
Problem setting up Dovecot for POP3 buzznick Fedora 5 11-04-2005 10:06 AM
how to start pop3 service in fedora core 3 and 2 using dovecot abhis_mail2002 Fedora 5 02-01-2005 04:35 AM
dovecot authentication error snurckle Linux - Newbie 4 08-13-2004 05:32 PM


All times are GMT -5. The time now is 11:18 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration