LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 03-03-2012, 10:10 PM   #1
flyinggeorge
Member
 
Registered: Feb 2012
Location: United States
Distribution: Slackware 14.0
Posts: 159

Rep: Reputation: 3
Conky + lua


Hello, all. I was recently trying to spice up my fluxbox a bit. I downloaded some themes and came across this web page about using widgets with conky.

http://blog.conky.be/category/hints-tips/

So I downloaded the .conkyrc file and replaced my old one, the .conkyrc works fine, but the widgets do not load. Conky returns:

Code:
Conky: llua_do_call: function conky_widgets execution failed: attempt to call a nil value
So I tried to google the error but I didn't get a clear solution. Some posts led me to believe that I might not have lua enabled in conky. But conky -v returns:

Code:
bash-4.1$ conky -v
Conky 1.8.1 compiled Wed Nov  9 12:34:01 EST 2011 for Linux 2.6.37.6-smp (i686)

Compiled in features:

System config file: /usr/local/etc/conky/conky.conf
Package library path: /usr/local/lib/conky

 X11:
  * Xdamage extension
  * XDBE (double buffer extension)
  * Xft
  * ARGB visual

 Music detection:
  * MPD
  * MOC

 General:
  * math
  * hddtemp
  * portmon
  * config-output
  * apcupsd
  * iostats
  * ncurses
  * Lua

  Lua bindings:
I assume that having "Lua" listed under general means that the bindings are enabled, but the Lua bindings section is blank. I currently have all the *.lua files copied into my home directory as well as /usr/local/lib/conky

Is there something I am missing? Thanks in advance for any help.
 
Old 03-04-2012, 12:01 AM   #2
flyinggeorge
Member
 
Registered: Feb 2012
Location: United States
Distribution: Slackware 14.0
Posts: 159

Original Poster
Rep: Reputation: 3
I tried to re-build conky with the variable LUA=yes enabled. I installed scons and tolua++ but when trying to build conky (From slackbuilds) it returns with errors

Code:
/usr/lib/libcurl.so: could not read symbols: File in wrong format
collect2: ld returned 1 exit status
make[2]: *** [conky] Error 1
make[2]: Leaving directory `/tmp/SBo/conky-1.8.1/src'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/tmp/SBo/conky-1.8.1/src'
make: *** [all-recursive] Error 1
Any ideas?

*edit* I downloaded and installed libcurl and conky built, but I am still getting the same error and no widgets.

Last edited by flyinggeorge; 03-04-2012 at 08:10 AM.
 
Old 03-04-2012, 02:00 PM   #3
Daedra
Senior Member
 
Registered: Dec 2005
Location: Springfield, MO
Distribution: Slackware64-14.1
Posts: 1,222

Rep: Reputation: 177Reputation: 177
Did you install all the required packages from slackbuilds.org. Install these packages in this order

lua
imlib2
tolua ++
conky


Also curl is installed already in the default slackware installation. did you do a full install when you installed slackware? Also you dont copy the lua files into you home directory use the lua slackbuild from slackbuilds.org
 
1 members found this post helpful.
Old 03-04-2012, 06:28 PM   #4
flyinggeorge
Member
 
Registered: Feb 2012
Location: United States
Distribution: Slackware 14.0
Posts: 159

Original Poster
Rep: Reputation: 3
Not sure if I have imlib2. I will build it and let you know. Thanks for you help.

Last edited by flyinggeorge; 03-04-2012 at 06:29 PM.
 
Old 03-04-2012, 07:17 PM   #5
flyinggeorge
Member
 
Registered: Feb 2012
Location: United States
Distribution: Slackware 14.0
Posts: 159

Original Poster
Rep: Reputation: 3
Okay. So I built all of the packages you mentioned above in that order. And I am still getting the same error. When I said I was putting the *.lua files in my home directory, I meant only the "conky_widgets.lua" script. Which contains the script for the clock and rings. Unfortunately even after all of this I am still getting the same error.

Last edited by flyinggeorge; 03-05-2012 at 12:52 AM.
 
Old 03-05-2012, 02:08 PM   #6
Daedra
Senior Member
 
Registered: Dec 2005
Location: Springfield, MO
Distribution: Slackware64-14.1
Posts: 1,222

Rep: Reputation: 177Reputation: 177
Your still getting the curl error when you try to compile conky?
 
Old 03-05-2012, 08:47 PM   #7
flyinggeorge
Member
 
Registered: Feb 2012
Location: United States
Distribution: Slackware 14.0
Posts: 159

Original Poster
Rep: Reputation: 3
No, I managed to build conky.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Installing Conky -- strange lua problem? benav Linux - Software 8 09-27-2011 12:06 PM
lua with cairo doesnt work in conky Bindestreck Slackware 15 08-19-2011 03:35 AM
Trying to get Lua to work with Conky AbsoluteZ3r0 Linux - Software 0 08-17-2011 10:01 AM
LXer: Conky Colors Makes Your Conky Beautiful In Seconds (Version 3.20 Released) LXer Syndicated Linux News 0 08-01-2010 11:21 AM
installing LUA 5.1 and conky on slackware 13 bret381 Linux - Software 2 11-17-2009 05:51 AM


All times are GMT -5. The time now is 09:39 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration