LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 04-02-2006, 05:27 PM   #1
nappy501
Member
 
Registered: Mar 2004
Location: UK
Distribution: Redhat 9, then Fedora Core 2, Suse 10.0, 10.2 now 11.3
Posts: 135

Rep: Reputation: 15
Changing default browser from Firefox to Mozilla


Hi

I have been using Fedora Core 2 and have just installed Suse 10.0. I started using Firefox, but for some reason it does not automatically read pdf's. Therefore I am now using Mozilla 1.7.12 which does. My question is how do I change my default browser from Firefox to Mozilla?

I have found instructions:
Mozilla 1.x:
Select "Edit | Preferences" from the main menu in Mozilla.

Change to the "Navigator" tab/section.

Click the "Set Default Browser" button.

Click "OK".

Close all Mozilla windows (for best results, restart the system). Finally, restart Mozilla.


The only problem is under the Navigoator tab there isn't a set default browser button??

Can anyone help?
Thank you.
 
Old 04-02-2006, 05:53 PM   #2
kencaz
Senior Member
 
Registered: Mar 2005
Location: Las Vegas, NV
Distribution: Mandriva Slackware FreeBSD
Posts: 1,468

Rep: Reputation: 47
If your using KDE then you need to change the application order pref for .html files. Look under:

Configure your Desktop >> Components >> File Associations

It should be under "Text" on the tree. then you can view the default application order. just set Mozilla on top and it will become the default for htm, html documents...

KC
 
Old 04-03-2006, 09:43 AM   #3
nappy501
Member
 
Registered: Mar 2004
Location: UK
Distribution: Redhat 9, then Fedora Core 2, Suse 10.0, 10.2 now 11.3
Posts: 135

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by kencaz
If your using KDE then you need to change the application order pref for .html files. Look under:

Configure your Desktop >> Components >> File Associations

It should be under "Text" on the tree. then you can view the default application order. just set Mozilla on top and it will become the default for htm, html documents...

KC
HiKC,
Thank you very much for that, but I don't think it worked. I am using KDE. I did:-
Control Centre>kde components>file associations>text.

Mozilla was right at the bottom, so I moved it to the top and pressed apply.

I then logged out and back in again. I opened Mozilla and thunderbird and clicked on the link from linux questions on this topic. It opened Firefox. I was hoping it would open another Mozilla window or tab. That's is why I find it so irratating, I'm working in Mozilla, but because firefox is the default still, I am sending you this message through Firefox. It maybe be fine when the machine has been turned off and on again?

Regards
Nappy501
 
Old 05-07-2006, 12:37 PM   #4
nappy501
Member
 
Registered: Mar 2004
Location: UK
Distribution: Redhat 9, then Fedora Core 2, Suse 10.0, 10.2 now 11.3
Posts: 135

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by nappy501
HiKC,
Thank you very much for that, but I don't think it worked. I am using KDE. I did:-
Control Centre>kde components>file associations>text.

Mozilla was right at the bottom, so I moved it to the top and pressed apply.

I then logged out and back in again. I opened Mozilla and thunderbird and clicked on the link from linux questions on this topic. It opened Firefox. I was hoping it would open another Mozilla window or tab. That's is why I find it so irratating, I'm working in Mozilla, but because firefox is the default still, I am sending you this message through Firefox. It maybe be fine when the machine has been turned off and on again?

Regards
Nappy501
Hi
I still have this problem. When I click on links in Thunderbird it opens Firefox, although I have Mozilla set as default.

Anyway today I uninstalled Firefox. When I click on links in Thunderbird now nothing happens. So now I am copying links into Mozilla.

Is Thunderbird able to use Mozilla? Who would know where can I find out?

Regards
nappy501
 
Old 05-07-2006, 12:58 PM   #5
nappy501
Member
 
Registered: Mar 2004
Location: UK
Distribution: Redhat 9, then Fedora Core 2, Suse 10.0, 10.2 now 11.3
Posts: 135

Original Poster
Rep: Reputation: 15
Also found this:
http://forums.mozillazine.org/viewto...t=mozex#146623
Is this what I need? Not sure what it means.

Mozilla tries to open Evolution when I click on email addresses. Would this help me to use the two programs together?
Regards

nappy501
 
Old 05-08-2006, 05:06 AM   #6
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,012

Rep: Reputation: 367Reputation: 367Reputation: 367Reputation: 367
Try:

Configure your Desktop >> Components >> Web Browser

And then enter the path to your preferred default browser
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Changing default browser floydking Linux - Software 11 03-07-2006 01:26 PM
Changing default Browser jgtg32a Mandriva 1 04-21-2005 04:14 PM
Getting Mozilla Firefox to run as default browser ClarkNG Linux - Software 1 08-30-2004 12:46 AM
How to make Mozilla Firefox my default file browser? jato Linux - Software 2 03-30-2004 11:33 AM
Changing default Browser Crashed_Again Linux - General 3 01-29-2003 09:31 PM


All times are GMT -5. The time now is 09:53 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration