LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 10-20-2004, 04:09 PM   #1
jlinkels
Senior Member
 
Registered: Oct 2003
Location: Bonaire
Distribution: Debian Lenny/Squeeze/Wheezy/Sid
Posts: 4,086

Rep: Reputation: 492Reputation: 492Reputation: 492Reputation: 492Reputation: 492
change video mode on console


Hi all,

THIS IS NOT ABOUT X RESOLUTIONS

I am trying to change my screen layout on the console to 132x50 characters (or whatever displays more text than 80x25)

I have compiled in in the kernel:

VGA Text console
Video Mode Select support
Frame buffer support
VESA VGA Graphic console
VGA 16-color graphics console
Select compiled-in fonts
VGA 8x8 fonts
VGA 8x16 fonts

Ok, when I boot, I enter at the command line: vga=ask

The system asks me to enter a VGA mode, I choose 'scan'

After scanning, I enter some mode, e.g. 'a' for 132x50

THE SYSTEM ACTUALLY CHANGES TO THIS MODE AND I SEE CHARACTERS IN 132x50 MODE!

Then the boot continues, that dreaded pinguin logo shows up, and the screen is switched back to 80x25, and it stays there.

When I try to set the resolution afterwards with fbset, I get this output:

root@siemens_pc:~# fbset -v 640x480-60
Linux Frame Buffer Device Configuration Version 2.1 (23/06/1999)
(C) Copyright 1995-1999 by Geert Uytterhoeven
Opening frame buffer device `/dev/fb0'
Reading mode database from file `/etc/fb.modes'
Using video mode `640x480-60'
Setting video mode to `/dev/fb0'
ioctl FBIOPUT_VSCREENINFO: Invalid argument

Which is not good

I am running Debian with 2.4.18 kernel without initrd
My video adapter is an Intel i810

The conclusions so far:

- I need frame buffer mode to get 132x50. Correct?

- FB, VESA etc works correctly because I see 132x50 before the penguin shows up, right?

Now:

- Can I disable the penguin and the fallback to 80x25 and leave fb intact?
- Why would fbset not work??

Yes, I googled around, but that yields only how to ENABLE the penguin. And yes I searched this forum, although the resolution problem is the same, the errors are different.

As usual, any help is appreciated.

jlinkels
 
Old 10-20-2004, 04:13 PM   #2
peok
Member
 
Registered: Aug 2003
Location: CA, USA
Distribution: (Almost) LFS 6.1.1
Posts: 91

Rep: Reputation: 15
are you using slackware? The only time I ever saw the penguin was when I used slackware. Anyway I don't know if it has to do with the penguin because I used a different video mode and it stayed even after the penguin showed up. But then again, I've been wrong many times before.
 
Old 10-20-2004, 04:20 PM   #3
goofyheadedpunk
Member
 
Registered: Aug 2003
Distribution: Arch Linux
Posts: 140

Rep: Reputation: 15
Assuming you're using LILO, I've forgotten if Debian uses it or GRUB, you can just edit /etc/lilo.conf. For example mine
Code:
# LILO configuration file
# generated by 'liloconfig'
#
# Start LILO global section
boot = /dev/hda
#compact        # faster, but won't work on all systems.
prompt
timeout = 30
# Normal VGA console
vga = normal
# VESA framebuffer console @ 1024x768x64k
# vga=791
# VESA framebuffer console @ 1024x768x32k
# vga=790
# VESA framebuffer console @ 1024x768x256
# vga=773
# VESA framebuffer console @ 800x600x64k
# vga=788
# VESA framebuffer console @ 800x600x32k
# vga=787
# VESA framebuffer console @ 800x600x256
# vga=771
# VESA framebuffer console @ 640x480x64k
# vga=785
# VESA framebuffer console @ 640x480x32k
# vga=784
# VESA framebuffer console @ 640x480x256
# vga=769
# ramdisk = 0     # paranoia setting
# End LILO global section
# Linux bootable partition config begins
image = /boot/vmlinuz
  root = /dev/hda2
  label = 2.6.8.1
  read-only
image = /boot/vmlinuz.old
  root = /dev/hda2
  label = 2.4.27
  read-only # Non-UMSDOS filesystems should be mounted read-only for checking
# Linux bootable partition config ends
The vga settings are what you'll want to change.

I think.

Last edited by goofyheadedpunk; 10-20-2004 at 04:29 PM.
 
Old 10-20-2004, 07:31 PM   #4
jlinkels
Senior Member
 
Registered: Oct 2003
Location: Bonaire
Distribution: Debian Lenny/Squeeze/Wheezy/Sid
Posts: 4,086

Original Poster
Rep: Reputation: 492Reputation: 492Reputation: 492Reputation: 492Reputation: 492
Peok:
I use Debian.

Goofyheadedpunk:
Debian uses LILO. But setting the video mode there is no solution. It is used in the same way as vga=ask. First the mode is set to whatever is set in lilo.conf. When the Penguin comes up, it resets again to 80x25. So this doesn't help.

Thanks anyway

jlinkels
 
Old 10-20-2004, 07:42 PM   #5
goofyheadedpunk
Member
 
Registered: Aug 2003
Distribution: Arch Linux
Posts: 140

Rep: Reputation: 15
I'm sorry for talking out of my bum, especially since it didn't help.

I found this and this, but I'm a bit afraid that you'll have already found and tried those suggestions.

Sorry I can't be of any help.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
In console mode can change tty's cannot from KDE or GRM rsol4747 Slackware 4 06-15-2005 02:56 AM
console video mode lupus9537 Linux - General 5 01-21-2005 06:12 AM
Console video mode rustynailz Linux - Newbie 3 06-05-2004 06:30 PM
Debian console video mode Radicalm16 Linux - Software 1 03-24-2003 09:57 PM
Help! I'm stuck in bad video mode and can't change it! sum1stolemynik Linux - Newbie 8 06-29-2002 03:14 AM


All times are GMT -5. The time now is 07:06 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration