LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 02-22-2004, 09:25 PM   #1
TheOneAndOnlySM
Member
 
Registered: Jul 2003
Location: Dallas, TX
Distribution: Ubuntu 10.04 LTS
Posts: 987

Rep: Reputation: 30
cdrdao 1.1.8 compile error


okay, i grabbed the latest release of cdrdao, mainly because it has direct support for atapi burning

i do the usual ./configure and i get no errors

then i issue make... it goes for a while then errors out at:
Making all in dao
make[2]: Entering directory `/home/sandeep/cdrdao-1.1.8/dao'
g++ -DDRIVER_TABLE_FILE=\"/usr/local/share/cdrdao/drivers\" -g -O2 -o cdrdao main.o -L. -ldao -L../paranoia -lcdda_paranoia -L../trackdb -ltrackdb -lpthread -L../scsilib/export -lscg -lschily -lnsl
/usr/lib/gcc-lib/i486-slackware-linux/3.2.3/../../../../i486-slackware-linux/bin/ld: cannot find -lscg
collect2: ld returned 1 exit status
make[2]: *** [cdrdao] Error 1
make[2]: Leaving directory `/home/sandeep/cdrdao-1.1.8/dao'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/sandeep/cdrdao-1.1.8'
make: *** [all] Error 2


it is apparently a gcc error (a problem with the way slackware has it built) since there is an option that is not recognized

i have also tried using make CC=gcc to use gcc instead of CC, but the same error occurs

has anyone been able to compile cdrdao 1.1.8?
 
Old 02-23-2004, 06:07 AM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
doesn't look like a gcc error at all. you just don't appear to have libscg installed from the bit that says "cannot find -lscg"
 
Old 02-24-2004, 07:22 PM   #3
TheOneAndOnlySM
Member
 
Registered: Jul 2003
Location: Dallas, TX
Distribution: Ubuntu 10.04 LTS
Posts: 987

Original Poster
Rep: Reputation: 30
eh, tried way too soon; slackware has already made a package for cdrdao 1.1.8

it seems that the libscg stuff was removed when i removed the old cdrdao 1.1.7, but now everything works

thx
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
compile error: #error unknown processor family kmack2001 Linux - Newbie 0 02-14-2004 12:52 PM
Alsa compile error, and a WINE error scheidel21 Linux - Software 1 12-08-2003 09:16 PM
cdrdao, cue file error? Andromea Linux - Software 0 09-20-2003 08:41 AM
cdrdao vexer Linux - Software 1 05-15-2003 12:49 AM
cdrdao twk Linux - Software 2 05-19-2002 06:37 PM


All times are GMT -5. The time now is 08:38 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration