LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 10-31-2003, 08:56 PM   #1
don_dimo
Member
 
Registered: Oct 2003
Location: Blacksburg, VA
Distribution: Fedora Core 2 (kde)
Posts: 144

Rep: Reputation: 15
CD-rom acts up


Hi,
I tried to mount my cdrom on my RH 8 machine and it gave me the following error:

mount: /dev/cdrom: can't read superblock

Anyone knows what that's for??
 
Old 10-31-2003, 09:55 PM   #2
jailbait
Guru
 
Registered: Feb 2003
Location: Blue Ridge Mountain
Distribution: Debian Wheezy, Debian Jessie
Posts: 7,574

Rep: Reputation: 184Reputation: 184
"mount: /dev/cdrom: can't read superblock"

Usually that message means that you specified the wrong file system type in the mount command. Try something similar to:
mount -t is09660 /dev/hdd /mnt/cdrom

___________________________________
Be prepared. Create a LifeBoat CD.
http://users.rcn.com/srstites/LifeBo...home.page.html

Steve Stites
 
Old 10-31-2003, 10:25 PM   #3
don_dimo
Member
 
Registered: Oct 2003
Location: Blacksburg, VA
Distribution: Fedora Core 2 (kde)
Posts: 144

Original Poster
Rep: Reputation: 15
Yes - you are right, I looked at my fstab file and for some reason it was modified for the cdrom only and it tries to mount it on /dev/cdrom which is nonexistent..my linux obviously has a mind of its own..Thx a lot for the help!!
 
Old 10-31-2003, 10:48 PM   #4
don_dimo
Member
 
Registered: Oct 2003
Location: Blacksburg, VA
Distribution: Fedora Core 2 (kde)
Posts: 144

Original Poster
Rep: Reputation: 15
Ok .. actually that did not quite fix the problem... it still gives the same error when I tried to mount it with:

mount -t iso9660 /dev/hdc /mnt/cdrom/
mount: /dev/hdc: can't read superblock

/dev/hdc is where /dev/cdrom used to point at, I tried to create a new link but that still did not work. I need to mention probably that I had problems with initscripts which I had to reinstall .. Could that have affected the cdrom??
 
Old 10-31-2003, 11:06 PM   #5
jailbait
Guru
 
Registered: Feb 2003
Location: Blue Ridge Mountain
Distribution: Debian Wheezy, Debian Jessie
Posts: 7,574

Rep: Reputation: 184Reputation: 184
Are you trying to mount the cdrom as user? If so then make sure that user has the proper permissions on /dev/hdd, /dev/cdrom, and /mnt/cdrom. Also if you are using ide-scsi then the kernel has switched the CD address to a scsi device, probably /dev/scd0


___________________________________
Be prepared. Create a LifeBoat CD.
http://users.rcn.com/srstites/LifeBo...home.page.html

Steve Stites
 
Old 10-31-2003, 11:13 PM   #6
don_dimo
Member
 
Registered: Oct 2003
Location: Blacksburg, VA
Distribution: Fedora Core 2 (kde)
Posts: 144

Original Poster
Rep: Reputation: 15
Of course not .. i am root, but something else is wrong - I just tried to start xcdroast and it could not even detect the cdrom and complained about scsi emulation being enabled in the kernel. Now my cdrom is a regular LG 24x10x40x CD-RW, and i've tried both mount cdrom , and mount -t iso9660 /dev/hdc /mnt/cdrom .. it gives the same error - i have no idea why???
 
Old 11-01-2003, 11:08 AM   #7
jailbait
Guru
 
Registered: Feb 2003
Location: Blue Ridge Mountain
Distribution: Debian Wheezy, Debian Jessie
Posts: 7,574

Rep: Reputation: 184Reputation: 184
" I just tried to start xcdroast and it could not even detect the cdrom and complained about scsi emulation being enabled in the kernel."

If you have a CD-ROM then Linx supports it as an IDE device on /dev/hdc. If you have a CD-RW then Linux supports it as a SCSI device on /dev/scd0.

If you are trying to burn a CD then you have a CD-RW. You must use the bootloader (either grub or lilo) to pass the kernel a boot parameter: append="hdc=ide-scsi" The append tells the kernel to use scsi suport for the CD-RW. Then your CD-RW will appear to be on /dev/scd0 (at least that is where SuSE puts it). Make /dev/cdrom a symbolic link to /dev/scd0 and you can do your mounts mounts on either /dev/cdrom or /dev/scd0.


___________________________________
Be prepared. Create a LifeBoat CD.
http://users.rcn.com/srstites/LifeBo...home.page.html

Steve Stites

Last edited by jailbait; 11-01-2003 at 11:10 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Terminal that acts more like an editor Z505 Linux - Software 7 04-09-2005 04:58 AM
ML 9.2 acts like windows oldator1940 Mandriva 4 11-21-2003 10:03 AM
chmod acts strange in Cygwin greg108 Linux - General 1 08-08-2003 10:34 AM
Any Linux browser acts like IE? chriscyl Linux - General 22 08-05-2002 10:49 AM
Any Linux browser acts like IE ? chriscyl Linux - Newbie 3 08-03-2002 07:05 PM


All times are GMT -5. The time now is 01:15 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration