LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 05-14-2003, 08:50 PM   #1
bobh080850
LQ Newbie
 
Registered: May 2003
Location: Parsons, KS
Distribution: Mandrake 9.2
Posts: 7

Rep: Reputation: 0
Can dialup start automatically with browser or mail?


I can access the internet through my external modem by using KPPP. However, then I have to start a browser or mail client program. How can I do like Windows does and just click on the browser or mail and start dialup?

Thank you.
Bob
 
Old 05-14-2003, 09:34 PM   #2
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,066
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
the pppd can be started in dial-on-demand mode

Cheers,
Tink
 
Old 05-15-2003, 09:53 AM   #3
bobh080850
LQ Newbie
 
Registered: May 2003
Location: Parsons, KS
Distribution: Mandrake 9.2
Posts: 7

Original Poster
Rep: Reputation: 0
Sorry, but am very very new at linux. What is pppd and how do you access?

Thanks again,
Bob
 
Old 05-15-2003, 09:55 AM   #4
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
http://www.tldp.org/HOWTO/Diald-HOWTO.html

looks a little out of date, but contains a lot of useful info
 
Old 05-15-2003, 10:07 AM   #5
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE 42.1_64+Tumbleweed-KDE, Mint 17.3
Posts: 3,952

Rep: Reputation: Disabled
Since you are writing that you use an external modem with KPPP I tentatively deduce that you use KDE (with SuSE?).

If so, in the tool bar at the lower margin of your screen at the right side is a symbol like a powerplug-connector. If you click on that one, your system connects you automatically (if you configured your modem permanently, that is).

You can test the symbol mentioned above by briefly moving the mouse-cursor over it, it will display a yellow text/information.
 
Old 05-15-2003, 11:32 AM   #6
bobh080850
LQ Newbie
 
Registered: May 2003
Location: Parsons, KS
Distribution: Mandrake 9.2
Posts: 7

Original Poster
Rep: Reputation: 0
I appreciate everyone's help but I am generally having problems with this issue. I just got my external modem yesterday so this is all new to me.
I am using Mandrake 9.1. When I go to the Mandrake Control Center and select "Setup internet and network", I am taken to drakconnect. Using the wizard my internet connection is configured and it finally asks me if I want to connect to the internet. I click yes and everything works fine. I start up my browser and mail and they function as they should. However, once I leave the wizard and click in Control Center on "Apply", then whenever I go to KPPP the modem will log onto to isp but none of my applications will find the connection. Also I wonder if I have 2 versions of KPPP. The KPPP that I access within Control Center will contain the information entered when I used the wizard. However, the KPPP that is accessed from the icon on my desktop, does not have that information. However, if I use setup I can enter the same info, but it still does the same thing - logs onto the isp but will not let my applications see the connection.

You help will be appreciated.

Thanks,
Bob
 
Old 05-15-2003, 02:40 PM   #7
Obi Perrin
Member
 
Registered: Nov 2002
Posts: 136

Rep: Reputation: 15
I'm going to take a wild guess. So if it doesn't work, you were duly warned beforehand

I believe that KPPP is like the MS dialer in that it temporarily stores your ISP nameservers in /etc/resolv.conf. If this file isn't writable with your user permissions, then when KPPP dials up to the net, it's unable to write the IP addresses to the file, and hence, it's unable to resolve URL's into IP numbers. A good way to test this is if when you go online through the KPPP link on your desktop, are you able to ping an IP address? If you are, but you're still not able to use URLs, then it's very likely a nameserver issue.

I also seem to remember that any Mandrake setup tool requires you to input the root password. Hence, when the dialup is done, it's done with root permissions and therefore able to temporarily store the nameserver IPs in /etc/resolv.conf.

If this is the problem, grab the IP numbers from your ISP's web site or take them from /etc/resolv.conf when you are able to access websites.
 
Old 05-15-2003, 06:10 PM   #8
tobyl
Member
 
Registered: Apr 2003
Location: uk
Distribution: slackware current
Posts: 750

Rep: Reputation: 53
Bob, what I do is this: put an icon on the taskbar for kppp. (right click, menu,add button,application,internet,kppp (or similar). Then click on your new icon, and edit the settings. In the execute tab you can put mozzilla or whatever. Then when you click on this icon, you connect and your browser fires up.
Actually I run a script from the execute tab, which does a few things when I connect, but you may wish to start with a simple setup first.
 
Old 05-16-2003, 11:01 AM   #9
bobh080850
LQ Newbie
 
Registered: May 2003
Location: Parsons, KS
Distribution: Mandrake 9.2
Posts: 7

Original Poster
Rep: Reputation: 0
Still problems. I believe that member: Obi Perrin in the post above may have the solution about this being a nameserver problem. I have tried to log in as root and change the write permissions on /etc/resolve.conf. The first time I did this I was able to start using KPPP on the desktop and several times I was able to log onto ISP and run browser. Then after I rebooted the computer it no longer worked again and now I cannot keep the permission changes on the /etc/resolve.conf file. Everytime I try to use KPPP and go back to the permissions on the file they have changed back to read only. What can I do?

Thank you,
Bob
 
Old 05-16-2003, 03:43 PM   #10
tobyl
Member
 
Registered: Apr 2003
Location: uk
Distribution: slackware current
Posts: 750

Rep: Reputation: 53
you could try the guys at

http://www.mandrakeusers.org/index.php

there are a few people there who know mandrake inside out
 
Old 05-16-2003, 05:28 PM   #11
Obi Perrin
Member
 
Registered: Nov 2002
Posts: 136

Rep: Reputation: 15
If you can get online at all, go to your ISPs site and look for their nameserver IP addresses. They should have them somewhere on the site. Alternatively, get their technical support number and call them up to ask them. Changing the permissions on /etc/resolv.conf is a sub-optimal solution, and I'm willing to bet that the change of permissions back again is part of Mandrake's "newbie-friendly" approach.

Open up a console, type 'su' and enter your root password. Now type 'kwrite /etc/resolv.conf'. Enter your ISP's nameservers to this file. Here's how mine looks to give you an example:

nameserver 195.92.195.94
nameserver 195.92.195.95

Save the file and exit the 'su' mode. Now try dialing up from your user account desktop link. What happens?
 
Old 05-17-2003, 06:12 PM   #12
bobh080850
LQ Newbie
 
Registered: May 2003
Location: Parsons, KS
Distribution: Mandrake 9.2
Posts: 7

Original Poster
Rep: Reputation: 0
I did exactly as suggested above. I tried logging in as root, opening kwrite, listing my ISP nameserver addresses and saving. However, when I tried to "save", it said that I did not have the necessary permission to make modifications to the file. So it would not save it.
Any thing else I can try?
Bob
 
Old 05-17-2003, 06:50 PM   #13
whansard
Senior Member
 
Registered: Dec 2002
Location: Mosquitoville
Distribution: RH 6.2, Gen2, Knoppix,arch, bodhi, studio, suse, mint
Posts: 3,185

Rep: Reputation: 52
try a different editor,
try opening a terminal,
typing
su
entering the root password,
then
pico /etc/resolv.conf
or
nano /etc/resolv.conf
do it before you open kppp

this is what a /etc/ppp/options
could look like for demand dialing.
demand dialing means for dialing the internet
access provider when an app needs it.

lock
defaultroute
noipdefault
modem
/dev/modem
115200
crtscts
debug
passive
name "yourname"
connect "chat -v -f /etc/ppp/pppscript"
ipcp-accept-local
ipcp-accept-remote
0.0.0.0:0.0.0.0
demand
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How do I automatically start a program at start up? victordh Linux - General 7 10-27-2013 07:02 AM
Browser automatically closes by itself........ emailssent Linux - General 10 10-13-2004 08:24 PM
start apps automatically on start up? chunlee Linux - Newbie 3 09-04-2004 01:58 PM
Mozilla mail and expiring old e-mail automatically dalek Linux - Software 8 07-14-2004 08:43 AM
Can I gett KPPP to start when I start a browser on a network machine? duffboygrim Linux - Networking 0 03-25-2004 05:49 PM


All times are GMT -5. The time now is 04:19 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration