LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 12-15-2003, 11:38 PM   #1
ralupien
LQ Newbie
 
Registered: Dec 2003
Location: Olympia, WA
Posts: 4

Rep: Reputation: 0
Can't access samba shares from xp


Hi folks,
I need a bit of help. I donít seem to be able to access samba shares from my XP box. I had this working fine running RedHat8.0 and Webmin. Then my server crashed and I decided to move up to 9.0 and the latest version of webmin. I realize now that I should have saved my smb.conf file. The issue is this; Iíve used webmin to set up a samba share on my server but when I try to map a drive to that share from my XP box I get a user name and password screen. It doesnít matter what I enter in this screen I fail to connect and the screen pops back up. Iím able to ping both machines from each other and I can see the server in my XP working group. I can access the server with webmin from the XP box for that matter. I just am not able to map a drive. As Iím sure you can tell Iím new to Linux and Iím sure Iíve missed something simple but I have no idea what it could be. Can some offer some direction on this?

Thanks so much.

Hereís my smb.conf:

# Samba config file created using SWAT
# from 0.0.0.0 (0.0.0.0)
# Date: 2003/12/14 21:55:20


# Global parameters
[global]
log file = /var/log/samba/%m.log
dns proxy = No
server string = Samba Server
passwd chat = *New*password* %n\n *Retype*new*password* %n\n
*passwd:*all*authentication*tokens*updated*successfully*
printing = cups
obey pam restrictions = Yes
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
unix password sync = Yes
workgroup = MSHOME
os level = 20
encrypt passwords = Yes
passwd program = /usr/bin/passwd %u
max log size = 0
pam password change = Yes
[homes]
comment = Home Directories
guest account =
valid users = %S
read only = No
create mask = 0664
directory mask = 0775
[printers]
comment = All Printers
path = /var/spool/samba
printable = Yes
browseable = No
[music]
comment = music
path = /home/music
valid users = ralupien gllupien
read only = No
 
Old 12-16-2003, 01:20 AM   #2
ugob
Member
 
Registered: Nov 2003
Distribution: RH, Fedora, Debian, Knoppix
Posts: 436

Rep: Reputation: 31
Have you configured your samba users?
 
Old 12-16-2003, 01:29 AM   #3
ambacrombie
LQ Newbie
 
Registered: May 2003
Posts: 1

Rep: Reputation: 0
Hate to ask obvious but are you using xp home. I spent the better part of two weeks trying to network home and knoppix. Finally decided on a virtual desktop setup as being easier. I believe I did get it "working" at one point with Samba and RH 9 but lost connectivity with a reinstall of knoppix on linux box which messed up everything/? Don't ask, my fault.
I had better luck with the network viewer in knoppix than webim. I'm not on that box right now so can't tell you name, was no problem to browse windows from linux.
As for password box, it will work when you get it configured properly. I think I had to put in new simple password file also though??
not much help but tried,
ambacrombie
 
Old 12-16-2003, 06:23 AM   #4
scheidel21
Senior Member
 
Registered: Feb 2003
Location: CT
Distribution: Debian 6-7, WIN 7-10, WIN SRV 03-12r2
Posts: 1,309

Rep: Reputation: 98
I posted something similar to this a while back, I recieved a post back stating that SP1 can cause this problem sometimes..I fon't knopw if thats any helpp

--Alex
 
Old 12-16-2003, 11:53 AM   #5
JoAnywhere
Member
 
Registered: Oct 2003
Location: denver
Distribution: Debian
Posts: 97

Rep: Reputation: 15
users

for the user you are trying to log in as (I'm assuming you have a valid user account on your RH9 box), have you created a corresponding SAMBA password?

from memory its something like
Code:
smbpasswd -a -U <user>%<passwd>
but you can just do a

Code:
man smbpasswd
and that will give you all the good info

Cheers
Jo
 
Old 12-16-2003, 12:26 PM   #6
ralupien
LQ Newbie
 
Registered: Dec 2003
Location: Olympia, WA
Posts: 4

Original Poster
Rep: Reputation: 0
Thanks for all the responses. Iíll do my best to answer some of the questions presented. For the rest, Iíll need to do some learning and hunting before I can respond.
Ugob: Been searching google for the better part of a week with some success but not finding what I need. Thatís actually how I found this BB.
Yes, all systems can access the internet. Iím assuming this is the question you were asking with ďNo internet connection?Ē
Iím looking into your other suggestions now.

Abercrombie: No, my XP box is running on XP pro. Being new to this Linux world I need to go off a find out what knoppix is and how I might benefit from it.
Thanks for the input though.

JoAnywhere: Yes, I do have a valid user account on the RH9 box. I also converted Linux users to samba users. It should be noted that the user accounts on the RH9 box are the same as the XP accounts.

Iíll be working with some of the suggestions that I received and Iíll post more information when I have it.

Thanks for all the input.
 
Old 12-16-2003, 12:28 PM   #7
ugob
Member
 
Registered: Nov 2003
Distribution: RH, Fedora, Debian, Knoppix
Posts: 436

Rep: Reputation: 31
This is only my signature... sorry it is not clear.
 
Old 12-16-2003, 12:41 PM   #8
FragInHell
Member
 
Registered: Sep 2003
Location: Sydney Australia
Distribution: Redhat, Centos, Solaris, Ubuntu, SUSE
Posts: 282

Rep: Reputation: 45
Just a thought, but you have already applied the XP sign and Seal Registry Fix for your XP client, otherwise, you'll never be able to log on to samba.
 
Old 12-16-2003, 01:19 PM   #9
ralupien
LQ Newbie
 
Registered: Dec 2003
Location: Olympia, WA
Posts: 4

Original Poster
Rep: Reputation: 0
Ugob: these are the results of the suggestions in your signature. Iíll need to spend some study time to fully understand the output.

/etc/resolv.conf
; generated by /sbin/dhclient-script
search @attbi
nameserver 204.127.198.4
nameserver 63.240.76.4

ifconfig Ėa (note: eth1 is not currently connected to anything)
eth0 Link encap:Ethernet HWaddr 000:B7:E8:2E:CA
inet addr:192.168.1.102 Bcast:192.168.1.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:3002 errors:0 dropped:0 overruns:0 frame:0
TX packets:2366 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:650456 (635.2 Kb) TX bytes:539191 (526.5 Kb)
Interrupt:9 Base address:0xd000 Memory:db800000-db800038

eth1 Link encap:Ethernet HWaddr 000:B7B:BE:C4
BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interrupt:11 Base address:0xb800 Memory:da800000-da800038

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:390509 errors:0 dropped:0 overruns:0 frame:0
TX packets:390509 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:26677311 (25.4 Mb) TX bytes:26677311 (25.4 Mb)

Route
Destination Gateway Genmask Flags Metric Ref Use
Iface
192.168.1.0 * 255.255.255.0 U 0 0 0
eth0
169.254.0.0 * 255.255.0.0 U 0 0 0
eth0
127.0.0.0 * 255.0.0.0 U 0 0 0
lo
default 192.168.1.1 0.0.0.0 UG 0 0 0
eth0
 
Old 12-16-2003, 01:23 PM   #10
ugob
Member
 
Registered: Nov 2003
Distribution: RH, Fedora, Debian, Knoppix
Posts: 436

Rep: Reputation: 31
you don't need to do what my signature says unless you have no internet connexion...

I don't think it is relevant in your case.
 
Old 12-16-2003, 02:06 PM   #11
ralupien
LQ Newbie
 
Registered: Dec 2003
Location: Olympia, WA
Posts: 4

Original Poster
Rep: Reputation: 0
Flash Flash:
All,
I was able to map a drive once I did the following:
I added the desired users to the smbusers file
(ralupien = ralupien)

Then I used the smbpasswd to set the password for each user.
Then restarted the samba servers and I was able to map with the current password.

Thanks for all your input. Iím sure Iíll have many more question to ask in the future (as Iím sure you can tell).

Regards,
 
Old 12-16-2003, 02:12 PM   #12
ugob
Member
 
Registered: Nov 2003
Distribution: RH, Fedora, Debian, Knoppix
Posts: 436

Rep: Reputation: 31
Good, you'd probably be better off using smbpasswd for that. Some distro even include the smbadduser command to help you out.

Anyways, the best way to get it, is, as JoAnywhere said.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
can't access samba shares [goldy] Linux - Software 14 08-21-2004 09:42 PM
Samba and MS Access Shares oneiltj Linux - Software 13 08-08-2004 09:11 PM
Access denied XP samba shares djtsa Linux - Software 0 10-02-2003 07:26 AM
can't access samba shares from xp hemp4fuel Slackware 20 07-09-2003 02:28 AM
Samba and MS Access Shares oneiltj Linux - Software 3 03-18-2003 12:32 PM


All times are GMT -5. The time now is 10:47 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration