LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 08-19-2004, 04:12 PM   #1
[goldy]
LQ Newbie
 
Registered: Aug 2004
Location: Nevada, US
Posts: 8

Rep: Reputation: 0
can't access samba shares


I recently switched routers from a Linksys wireless G to a netgear wireless B. While I was on the linksys, I had no problem accessing any of the shares from my fileserver, but now that I'm on the netgear router, I can't get onto the samba shares.

The two machines I'm trying on are both running WinXP pro and the fileserver is running freeBSD.
 
Old 08-19-2004, 04:43 PM   #2
arno
Member
 
Registered: Jul 2004
Location: Netherlands
Distribution: fedora core 8, suse 10.3, ubuntu 7.10, kamikaze 7.09
Posts: 515

Rep: Reputation: 30
Is it only samba that's not working?
can you ping the other machine's ?
 
Old 08-19-2004, 04:49 PM   #3
[goldy]
LQ Newbie
 
Registered: Aug 2004
Location: Nevada, US
Posts: 8

Original Poster
Rep: Reputation: 0
I haven't tried to ping the other machine, but I can see it from Network Neighborhood and when I click on it, it says that it cannot connect. I can connect to each of my Windows boxes, though. The weird thing is, nothing has changed except for the router, which is why I was thinking that maybe it's a router problem, but I'm not sure.
 
Old 08-19-2004, 05:00 PM   #4
arno
Member
 
Registered: Jul 2004
Location: Netherlands
Distribution: fedora core 8, suse 10.3, ubuntu 7.10, kamikaze 7.09
Posts: 515

Rep: Reputation: 30
There could be two problems
1) the wireless nics in your machines are of a different brand then your AP.
2) the router tables in your computers are confused
post the output of ( all your machines)
route -n
 
Old 08-19-2004, 05:10 PM   #5
[goldy]
LQ Newbie
 
Registered: Aug 2004
Location: Nevada, US
Posts: 8

Original Poster
Rep: Reputation: 0
I'm not sure if this is what you're looking for, but here it is:

route -n get -host 192.168.0.2 192.168.0.1
route to: 192.168.0.2
destination: 192.168.0.0
mask: 255.255.255.0
interface: sis0
flags: <UP,DONE,CLONING>
recvpipe sendpipe ssthresh rtt,msec rttvar hopcount mtu expire
0 0 0 0 0 0 1500 -99194


route -n get -host 192.168.0.4 192.168.0.1
route to: 192.168.0.4
destination: 192.168.0.0
mask: 255.255.255.0
interface: sis0
flags: <UP,DONE,CLONING>
recvpipe sendpipe ssthresh rtt,msec rttvar hopcount mtu expire
0 0 0 0 0 0 1500 -99206
 
Old 08-20-2004, 07:14 AM   #6
arno
Member
 
Registered: Jul 2004
Location: Netherlands
Distribution: fedora core 8, suse 10.3, ubuntu 7.10, kamikaze 7.09
Posts: 515

Rep: Reputation: 30
I asume that your linux distribution does not support a simple route -n, this is not what I wanted,

but

Did your new router use a different ip network address then have a look in the samba.conf and look for SUBNET and change it to 192.168.0.0
look for any other addresses in the file
 
Old 08-20-2004, 11:08 AM   #7
[goldy]
LQ Newbie
 
Registered: Aug 2004
Location: Nevada, US
Posts: 8

Original Poster
Rep: Reputation: 0
I had a part in [global] that said hosts = 192.168.1. and changed it to hosts=192.168.0. and it still didn't work.
 
Old 08-20-2004, 03:05 PM   #8
arno
Member
 
Registered: Jul 2004
Location: Netherlands
Distribution: fedora core 8, suse 10.3, ubuntu 7.10, kamikaze 7.09
Posts: 515

Rep: Reputation: 30
You better post the content of your samba.conf and the output of route -n ( with no extra's please) what linux distribution are you using
 
Old 08-20-2004, 03:32 PM   #9
Rob Roye
Member
 
Registered: Mar 2004
Location: Mishawaka, IN
Distribution: SuSE 9.0, 9.1, 9.2
Posts: 38

Rep: Reputation: 15
Quote:
The two machines I'm trying on are both running WinXP pro and the fileserver is running freeBSD.
On the Windows XP machines, hit Start, Run and then type cmd. When the DOS window pops up type ipconfig /all. This will give you the subnet that they are using.

Move to the FreeBSD box and bring up a konsole. Type ifconfig and see if they are all on the same subnet. If the BSD box was configured for a static IP it will not change with the router. The XP boxes are most likely DHCP and get addresses automatically.

All should be at the same numbers for the first 3 sets of numbers. Example - if the XP boxes are on 192.168.1.X then the BSD box needs to be on 192.168.1.X. The first three sets of numbers have to be the same, and the last number has to be different. The default addresses for Linksys are 192.168.1.X and D-Link normally uses 192.168.0.X.

See if this helps.

Last edited by Rob Roye; 08-20-2004 at 04:18 PM.
 
Old 08-20-2004, 04:29 PM   #10
[goldy]
LQ Newbie
 
Registered: Aug 2004
Location: Nevada, US
Posts: 8

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by arno
You better post the content of your samba.conf and the output of route -n ( with no extra's please) what linux distribution are you using
I'm running freeBSD, but my route command doesn't allow for only a -n option, I have to give it a command as well. Here's what I get when I try route -n:

$ route -n
usage: route [-dnqtv] command [[modifiers] args]
 
Old 08-20-2004, 04:40 PM   #11
[goldy]
LQ Newbie
 
Registered: Aug 2004
Location: Nevada, US
Posts: 8

Original Poster
Rep: Reputation: 0
Ok, from my laptop, here's the output of ipconfig /all:

Ethernet adapter Local Area Connection:

C:\Documents and Settings\Administrator>ipconfig /all

Windows IP Configuration

Host Name . . . . . . . . . . . . : goldy-laptop
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Unknown
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No


Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Intel 8255x-based PCI Ethernet Adapter (10/100)
Physical Address. . . . . . . . . : 00-00-39-DE-20-C9
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IP Address. . . . . . . . . . . . : 192.168.0.2
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.0.1
DHCP Server . . . . . . . . . . . : 192.168.0.1

and here's from ifconfig:

sis0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
inet6 fe80::240:f4ff:fe4c:f586%sis0 prefixlen 64 scopeid 0x1
inet 192.168.0.3 netmask 0xffffff00 broadcast 192.168.0.255
ether 00:40:f4:4c:f5:86
media: Ethernet autoselect (100baseTX <full-duplex>)
status: active
sis1: flags=8802<BROADCAST,SIMPLEX,MULTICAST> mtu 1500
ether 00:02:e3:23:52:ce
media: Ethernet autoselect (none)
status: no carrier
plip0: flags=8810<POINTOPOINT,SIMPLEX,MULTICAST> mtu 1500
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 16384
inet 127.0.0.1 netmask 0xff000000
inet6 ::1 prefixlen 128
inet6 fe80::1%lo0 prefixlen 64 scopeid 0x4
 
Old 08-20-2004, 05:14 PM   #12
arno
Member
 
Registered: Jul 2004
Location: Netherlands
Distribution: fedora core 8, suse 10.3, ubuntu 7.10, kamikaze 7.09
Posts: 515

Rep: Reputation: 30
What I can deduce is that:
sis0 is an active (100baseTX) nic with an address
sis1 has no address, but is this you wifi interface
your router seems to point to sis0

disable you sis0 nic and give sis1 a fixed address, set up a route table.

Sorry I cant tell you how to do that because in don't know how freeBSD works
 
Old 08-20-2004, 05:37 PM   #13
[goldy]
LQ Newbie
 
Registered: Aug 2004
Location: Nevada, US
Posts: 8

Original Poster
Rep: Reputation: 0
Yeah, this is what I've had even before I switched routers. I was originally planning to set up my server as a firewall as well, but figured that I'd just stick with the router. I don't have any wireless on my computers, I just have the wireless router for my roommates. I'll give what you said a try and see if that works. Thanks for all of the help.
 
Old 08-20-2004, 10:44 PM   #14
Rob Roye
Member
 
Registered: Mar 2004
Location: Mishawaka, IN
Distribution: SuSE 9.0, 9.1, 9.2
Posts: 38

Rep: Reputation: 15
You only set up a routing table on a router. Since the D-Link is the router and handles the traffic, setting up a route table is not the answer.

This may be a dumb question, but have you restarted the machine? My servers (static IP addresses) have been known to lose the connection when I replace a switch or something where the cable is disconnected for some reason.

Last edited by Rob Roye; 08-20-2004 at 10:47 PM.
 
Old 08-21-2004, 08:42 PM   #15
[goldy]
LQ Newbie
 
Registered: Aug 2004
Location: Nevada, US
Posts: 8

Original Poster
Rep: Reputation: 0
Well, I finally got it working. Something to do with routing tables being sent out from the router. Not too sure about it, but thanks for all of the help.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Samba and MS Access Shares oneiltj Linux - Software 13 08-08-2004 08:11 PM
Can't access samba shares from xp ralupien Linux - Software 11 12-16-2003 01:12 PM
Access denied XP samba shares djtsa Linux - Software 0 10-02-2003 06:26 AM
can't access samba shares from xp hemp4fuel Slackware 20 07-09-2003 01:28 AM
Samba and MS Access Shares oneiltj Linux - Software 3 03-18-2003 11:32 AM


All times are GMT -5. The time now is 03:53 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration