LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 12-15-2004, 02:55 AM   #1
ZaphyR
Member
 
Registered: Dec 2003
Distribution: Gentoo / Sabayon / Suse
Posts: 245

Rep: Reputation: 32
autostart kde


how do i autostart KDE? i am running Gentoo on this box, and it just gives me a console logon when booted, and i have to run startx to get KDE running.

this is my rc.conf:

Code:
# What display manager do you use ?  [ xdm | gdm | kdm | entrance ]
DISPLAYMANAGER="kdm"

# XSESSION is a new variable to control what window manager to start
# default with X if run with xdm, startx or xinit.  The default behavior
# is to look in /etc/X11/Sessions/ and run the script in matching the
# value that XSESSION is set to.  The support scripts is smart enouth to
# look in all bin directories if it cant find a match in /etc/X11/Sessions/,
# so setting it to "enligtenment" can also work.  This is basically used
# as a way for the system admin to configure a default system wide WM,
# allthough it will work if the user export XSESSION in his .bash_profile, etc.
#
# NOTE:  1) this behaviour is overridden when a ~/.xinitrc exists, and startx
#           is called.
#        2) even if a ~/.xsession exist, if XSESSION can be resolved, it will
#           be executed rather than ~/.xsession, else KDM breaks ...
#
# Defaults depending on what you install currently include:
#
# Gnome - will start gnome-session
# kde-<version> - will start startkde (ex: kde-3.0.2)
# Xsession - will start a terminal and a few other nice apps

XSESSION="kde-3.3.0"
 
Old 12-15-2004, 03:38 AM   #2
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,975

Rep: Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343
Edit your /etc/iniitab and change the initdefault value to the runlevel that starts X. Usually it's 5.
Regards
 
Old 12-15-2004, 04:06 AM   #3
ZaphyR
Member
 
Registered: Dec 2003
Distribution: Gentoo / Sabayon / Suse
Posts: 245

Original Poster
Rep: Reputation: 32
Thanks, i tried that but it still is the same.

this is what i set up in inittab

Code:
# Default runlevel.
id:5:initdefault
and I can see it when the computer is booting...INIT: Runlevel 5 it says...and then continues to console login...


 
Old 12-15-2004, 04:13 AM   #4
mayur
LQ Newbie
 
Registered: Jun 2003
Posts: 14

Rep: Reputation: 0
can you use switchdesk command
 
Old 12-15-2004, 04:18 AM   #5
ZaphyR
Member
 
Registered: Dec 2003
Distribution: Gentoo / Sabayon / Suse
Posts: 245

Original Poster
Rep: Reputation: 32
no, neither as user or root can it find the command "switchdesk"
 
Old 12-15-2004, 04:25 AM   #6
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,975

Rep: Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343
Are you sure that runlevel 5 is the graphical login in gentoo? There are comments in /etc/inittab describing the various runlevels.
Also you can run "init 5" from the command line to see if X starts.
 
Old 12-15-2004, 04:45 AM   #7
ZaphyR
Member
 
Registered: Dec 2003
Distribution: Gentoo / Sabayon / Suse
Posts: 245

Original Poster
Rep: Reputation: 32
so i reboot, and get the console again. log in as root and types "init 5".....nothing happens....

Code:
#init 5
#
as user i get

Code:
command not found
 
Old 12-15-2004, 05:21 AM   #8
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,975

Rep: Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343
Doing a liitle googling, here is what I've found:
Quote:
Graphical Login
If you want to use kdm as graphical login manager (which means you don't have to log on onto a terminal and type startx every time) you first need to look inside /etc/X11/Sessions to see how the KDE session is called:
Code listing 3.2: Checking the KDE session name
# ls /etc/X11/Sessions
Xsession fluxbox kde-3.2.1
In the above example, the KDE session is called kde-3.2.1. Let's enter this in /etc/rc.conf in the variable called XSESSION. While you are at it, also set the DISPLAYMANAGER to kdm.
Code listing 3.3: Setting XSESSION in /etc/rc.conf
# nano -w /etc/rc.conf
(Edit the following two variables)
XSESSION="kde-3.2.1"
DISPLAYMANAGER="kdm"
Finish up by adding xdm to the default runlevel:
Code listing 3.4: Adding xdm to the default runlevel
# rc-update add xdm default
When you reboot your system, it will use KDM as graphical login manager.
Cheers
 
Old 12-15-2004, 05:52 AM   #9
ZaphyR
Member
 
Registered: Dec 2003
Distribution: Gentoo / Sabayon / Suse
Posts: 245

Original Poster
Rep: Reputation: 32
yes! it was "rc-update add xdm default" that was missing all along!

still I wonder why it is "rc-update add xdm default" and not "rc-update add kdm default"?? strange....

Anyways...thanks!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
SUSE 9.3 KDE autostart ionmich Suse/Novell 1 10-17-2005 08:28 AM
KDE Autostart Shafted Linux - Software 2 12-01-2004 09:14 PM
autostart for aliases and kde derfaust Slackware 6 06-07-2004 12:48 AM
Trouble with autostart in kde... Toker Linux - Newbie 6 10-10-2003 03:49 PM
Kde 2 Autostart folder rfc1700 Linux - General 1 03-12-2001 09:04 PM


All times are GMT -5. The time now is 11:42 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration