LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 02-01-2007, 04:42 PM   #1
maybi7
LQ Newbie
 
Registered: Oct 2006
Posts: 4

Rep: Reputation: 0
apt-get install dependency problems with hplip software and kde install for Agnula


Hi,
I'm using Debian from an Agnula distribution (Linux demudi 2.6.12-3-multimedia-k7) and have been having some problems with apt-get install. I have been attempting to install hplip software for my new printer and it gives me dependency problems, a guy from hplip reckoned my sources.list might be wrong (below):

#deb file:///cdrom/ sarge main

deb cdrom:[Debian GNU/Linux A/DeMuDi 1.2.1 _Sarge_ - Unofficial i386 Binary-1 (20050627)]/ unstable main

# Security updates
#deb http://demudi.agnula.org/packages/demudi demudi main/updates

# Bleeding-edge packages
#deb http://demudi.agnula.org/packages/demudi demudi main

# Debian official archive
# deb http://ftp.debian.org/debian testing main

#See sources.list(5) for more information
deb http://http.us.debian.org/debian stable main contrib non-free
deb http://non-us.debian.org/debian-non-US stable/non-US main contrib non-free
deb http://security.debian.org stable/updates main contrib non-free


The install.log gives this problem:
The following packages have unmet dependencies:
libcupsys2-dev: Depends: libcupsys2-gnutls10 (= 1.1.23-10sarge1) but 1.1.23-10 is to be installed
Depends: libgnutls11-dev but it is not going to be installed
libsnmp5-dev: Depends: libssl-dev but it is not going to be installed
python-dev: Depends: python2.3-dev (>= 2.3.4-18) but it is not going to be installed
E: Broken packages

I have also tried running # apt-get install kde

and get the following which is also annoying (although I do like gnome I would like a choice.)
Reading Package Lists... Done
Building Dependency Tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
kde: Depends: kde-core but it is not going to be installed
Depends: kde-amusements but it is not going to be installed
Depends: kdeaddons but it is not going to be installed
Depends: kdeartwork but it is not going to be installed
Depends: kdegraphics but it is not going to be installed
Depends: kdemultimedia but it is not going to be installed
Depends: kdenetwork but it is not going to be installed
E: Broken packages
 
Old 02-03-2007, 05:16 PM   #2
karyoker
LQ Newbie
 
Registered: Feb 2007
Distribution: Etch 2.6.18-3-686
Posts: 26

Rep: Reputation: 15
Try This


After aptitude update

deb:/home/cab# aptitude search hplip
p hplip - HP Linux Printing and Imaging System (HPLIp hplip-data - HP Linux Printing and Imaging - data filesp hplip-dbg - HP Linux Printing and Imaging - debugging
p hplip-doc - HP Linux Printing and Imaging - documentatv hplip-ppds -
deb:/home/cab#
aptitude install hplip hplip-data .......
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't install via adept/apt-get, weird dependency error... Letherian Linux - Software 0 02-26-2006 04:12 PM
KDE Install problems with Synaptic/Apt-Get hauger Debian 4 08-05-2005 11:18 AM
agnula demudi install problems dianat100 Debian 2 06-22-2005 07:31 AM
dependency problems (libImlib.so.1 won't install) obli Linux - General 2 02-13-2003 03:02 PM
Dependency problems with StarOffice install VBJAEGER Linux - Software 4 06-06-2002 11:05 AM


All times are GMT -5. The time now is 03:39 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration