LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 03-11-2004, 10:37 AM   #1
qwijibow
Guru
 
Registered: Apr 2003
Location: nottingham england
Distribution: Gentoo
Posts: 2,672

Rep: Reputation: 47
ALSA-oss compatability works, but not programs intended for alsa ?


hi, i have a rather strange porblem...

Info....
fedora core 1 2.4.22-1.2115.nptl
sound related output from lsmod =

Quote:
snd-pcm-oss 44228 0 (autoclean)
snd-mixer-oss 16280 0 (autoclean) [snd-pcm-oss]
snd-seq-midi 5216 0 (unused)
snd-seq-midi-event 6016 0 [snd-seq-midi]
snd-seq 46512 0 [snd-seq-midi snd-seq-midi-event]
snd-ens1370 12000 0
snd-pcm 84740 0 [snd-pcm-oss snd-ens1370]
snd-timer 19684 0 [snd-seq snd-pcm]
gameport 3380 0 [snd-ens1370]
snd-rawmidi 18656 0 [snd-seq-midi snd-ens1370]
snd-seq-device 6252 0 [snd-seq-midi snd-seq snd-rawmidi]
snd-ak4531-codec 6232 0 [snd-ens1370]
snd 46372 0 [snd-pcm-oss snd-mixer-oss snd-seq-midi snd-seq-midi-event snd-seq snd-ens1370 snd-pcm snd-timer snd-rawmidi snd-seq-device snd-ak4531-codec]
soundcore 6500 6 [snd]
snd-page-alloc 10068 0 (autoclean) [snd-ens1370 snd-pcm]
i have downloaded and compiles the latest ALSA modules (with OSS compatability)

i have ran the snddevice script.
i have un-muted all audio chanels with aumix and alsa-mix
i have saved configureatino with alsactl store.

i have followed every manual exactly.

NOW... porgrams which use OSS output, for example XMMS and Mplayer work perfecty, the OSS modules are not loaded in the kernel, so they MUST be working though the ALSA compatability modules which ARE loaded.

however... when i attempt to run a program intended to use alsa, (quakeforge 2)
i get errors that /dev/dsp is not a valid pcm device, cannot open /dev/dsp.

any ideas ?
 
Old 03-12-2004, 05:03 AM   #2
guygriffiths
Member
 
Registered: Jun 2003
Location: Reading, UK
Distribution: Debian 3.0, LFS
Posts: 524

Rep: Reputation: 35
Yes, I have an idea, but only if you are using KDE 3.2. Are you?
 
Old 03-12-2004, 05:57 AM   #3
dushkinup
Member
 
Registered: Feb 2004
Location: Alpha Quadrant, sol system, earth, asia, Israel.
Distribution: Computer I : Slackware 9.1 ; Computer II : Windows XP
Posts: 144

Rep: Reputation: 15
I have the same problem!

Quake 3 and Vendetta just say that they can't load the sound driver. Dunno why.
 
Old 03-13-2004, 03:43 PM   #4
qwijibow
Guru
 
Registered: Apr 2003
Location: nottingham england
Distribution: Gentoo
Posts: 2,672

Original Poster
Rep: Reputation: 47
Im using KDE 3.1.4

but tell me your idea anyways ?
 
Old 03-14-2004, 05:24 AM   #5
guygriffiths
Member
 
Registered: Jun 2003
Location: Reading, UK
Distribution: Debian 3.0, LFS
Posts: 524

Rep: Reputation: 35
Well, KDE 3.2 takes exclusive control of the sound system, and won't let programs access it directly, but I never had the same problem with KDE 3.1.4. However, if this is the problem, then disabling the aRts sound server should fix the problem.
 
Old 03-14-2004, 07:28 AM   #6
qwijibow
Guru
 
Registered: Apr 2003
Location: nottingham england
Distribution: Gentoo
Posts: 2,672

Original Poster
Rep: Reputation: 47
yeah, i dont use the arts sound server.

Cummon.. some1 has to know ?
ive tried 2 different sound cards. ive done everything.

ALSA-oss works... so why not direct ALSA ?
surely oss emulation should be harder to get working that alsa !

this is madness !
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
AC97 works with ALSA - how can two programs use it at the same time? (XMMS + a game) SBing Linux - Software 2 07-18-2004 06:45 AM
ALSA ESD --> no sound, but OSS sound works intense Slackware 1 03-23-2004 02:34 PM
how do i know if its OSS or ALSA? sirpelidor Linux - Newbie 5 02-08-2004 02:27 AM
alsa or oss chii-chan Linux - Newbie 2 01-18-2004 09:23 PM
Problems in RH 9 with alsa and esd oss works fine (VIA VT8233) husfeldt Linux - Hardware 1 08-28-2003 06:59 AM


All times are GMT -5. The time now is 06:42 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration