LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 09-06-2007, 11:06 AM   #1
gambrinus777
LQ Newbie
 
Registered: Sep 2007
Posts: 4

Rep: Reputation: 0
Symbolic link not allowed


Hi all,
I 've made a Centos4 web server and configured a site under apache.
Now I've a windows 2000 server in my lan in which I have a directory containing images that must be visualized under my site. So I've mounted with samba my win2000 dir in /mnt/winimages and I can navigate it and see everythings.
After that I come under apache and in /var/www/html/mysite I've created a symbolic link named myimages that point to /mnt/winimages: all goes ok and ls -l myimages give me the list of my images...
I've also insert this line in my /etc/httpd/conf/httpd.conf

<Directory "/var/www/html/mysite/myimages">
Options Indexes Includes FollowSymLinks

AllowOverride None
Allow from all


Order allow,deny
</Directory>

and restart apache. When I put a direct url on my browser pointing to a pippo.jpg I receive this error on browser:

Forbidden
You don't have permission to access /mysite/myimages/pippo.jpg on this server.

Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request

I also get this making tail -f /etc/httpd/logs/error_log

Symbolic link not allowed: /var/www/html/mysite/myimages

I also do this:

vi /etc/selinux/config
and change to
SELINUX=permissive

and restart the server...

Anyone have an idea???

Thanks all,
Regards,
Gambrinus
 
Old 09-07-2007, 04:20 AM   #2
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,961

Rep: Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341
Quote:
AllowOverride None
You should at least change the above to
Code:
AllowOverride Options
in order for your "Options" directive to take effect.
 
Old 09-07-2007, 05:40 AM   #3
gambrinus777
LQ Newbie
 
Registered: Sep 2007
Posts: 4

Original Poster
Rep: Reputation: 0
I've tried your idea...

Nothing, I receive the same error Symbolic link not allowed

Thanks,
Any ideas???
 
Old 09-07-2007, 07:16 AM   #4
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,961

Rep: Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341
Some things:
1. You can change
Quote:
<Directory "/var/www/html/mysite/myimages">
to
Code:
<Directory "/var/www/html/mysite">
since you want to follow symlinks inside the directory mysite.
2. Since it's a windows share make sure you mount it with the correct permissions.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
error 403 Forbidden symbolic link not allowed vree13 Linux - Software 8 02-14-2008 09:58 PM
Not a symbolic link ?? attockonian Linux - Newbie 4 06-30-2006 09:09 PM
What is a Symbolic Link? little_penguin Linux - Software 2 05-14-2005 10:27 AM
Symbolic link? jasone Linux - Newbie 4 05-06-2005 08:55 AM
symbolic link ilnli Slackware 6 01-04-2005 06:05 PM


All times are GMT -5. The time now is 08:54 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration