LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 03-10-2004, 12:28 PM   #1
vree13
LQ Newbie
 
Registered: Feb 2004
Location: Kalamazoo
Distribution: Mandriva 2006
Posts: 14

Rep: Reputation: 0
error 403 Forbidden symbolic link not allowed


i'm running apache and big brother and after using webmin, i can't view anything in the bb directory. everything else running on apache on my box is fine, but when i go to my bb page it gives me a 403 Forbidden error.

"You don't have permission to access /bb/ on this server.

Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request."

when i check the httpd error log it says symbolic link not allowed. i do have the bb directory symbolically linked, but all my httpd files say to allow symlinks.

any suggestions? ideas??

thanks!
 
Old 04-14-2004, 10:49 AM   #2
leobg
LQ Newbie
 
Registered: Apr 2004
Posts: 2

Rep: Reputation: 0
check does apache has permissions to access this directory

regards
leobg
 
Old 04-16-2004, 09:58 AM   #3
oberonix
LQ Newbie
 
Registered: Jan 2004
Distribution: Ubuntu (Feisty Fawn)
Posts: 26

Rep: Reputation: 15
Im having the same problem, how do you check if apache has permissions?
 
Old 04-16-2004, 10:53 AM   #4
leobg
LQ Newbie
 
Registered: Apr 2004
Posts: 2

Rep: Reputation: 0
check what is the user that httpd runs as. In Redhat it is usually 'apache' (not sure how is in Mandrake - you can find this out in your httpd.conf - directive 'User')
then check permissions of the folder you're trying to access via http - user 'apache' must be able to read/execute it. And not only the current dir, but all it parent dirs too ('execute' is enough for parents - no need of 'read'). For example:

drwxr-xr-x 2 root root 4096 Feb 6 1996 example

you can see the dir is owned by root, but group and others has r-x permissions - so everyone can cd in to 'example' and can read it content.

But if you have it like this:

drwxr-x--- 2 root root 4096 Feb 6 1996 example
or
drwx------ 2 root root 4096 Feb 6 1996 example

apache will not be able to read contents of this dir.

if you change it to be like this:
drwxr-x--- 2 root apache 4096 Feb 6 1996 example
or make the dir owned by apache:
drwx------ 2 apache somegroup 4096 Feb 6 1996 example
apache will be able to access it.
You can also assign apache to the approrative group and make the dir accessible by group members.

regards,
leobg
 
Old 01-03-2005, 06:52 PM   #5
ncsuapex
Member
 
Registered: Dec 2004
Location: Raleigh, NC
Distribution: CentOS 2.6.18-53.1.4.el5
Posts: 770

Rep: Reputation: 42
I'm having a similar problem. I am running Fedora Core 3 and I get several error messages when I try to access a page on my website. The page I'm trying to access has content on my Windows XP box. I created a symbolic link to that DIR (this worked very well on RH9). When I boot up I get an error that says "Invalid line in /etc/fstab" I also get the "Symbolic link not allowed:" not allowed when I try to access the page. I can however access the files on my XP machine from my FC3 box so I know the connection between the two PCs are working. I have set the DIRS of /var/www/html/pics (symbolic link) to r-xr-xrwx and the /mnt/pics to r-x-r-x-rwx. The link in my fstab is as follows:

mount -t smbfs //"ip of windows machine"/pics /mnt/pics -o username="username of account on xp",password="usernames password"

I have changed the info in " " to protect the innocent.

Any Ideas on what to do next?
 
Old 02-27-2005, 10:48 PM   #6
morrie
LQ Newbie
 
Registered: Feb 2005
Posts: 1

Rep: Reputation: 0
I experienced the same issue.
It turned out to be selinux that is the cause.
Selinux be default locks down Apache in order to prevent
both malicious behaviour, and to prevent people from
shooting themselves in the foot security wise.

Have a read up on selinux policy settings as you will need
to either modify the way you have BB setup, modify the
standard selinux policies, or disable selinux

The files you want to peruse are under /etc/selinux.

Regards,
Morrie.
 
Old 06-16-2005, 12:04 PM   #7
paulengel
LQ Newbie
 
Registered: Jun 2005
Posts: 5

Rep: Reputation: 0
I'm seeing the same thing on SLES9.

I su'ed into wwwrun (using -s /bin/bash to get a shell) and I cannot traverse the link (Permission denied). What's more, if I cd into the link then su the pwd becomes the dereferenced directory.
 
Old 06-18-2005, 10:46 AM   #8
paulengel
LQ Newbie
 
Registered: Jun 2005
Posts: 5

Rep: Reputation: 0
Found a workaround.. and maybe an answer

I was doing some more searching and found an interesting workaround:

>My work around was I did a loopback device--
>
>mount --bind /var/www/html/htdocs /home/userid
>
>this worked like a charm.

This was related to an FTP issue. The problem was that when someone FTP'd into the server they were chroot'd into their directory and the symbolic link would of taken them out of their jail. I'm not sure why I cannot follow the link when I su into wwwrun, but the workaround works.
 
Old 02-14-2008, 08:58 PM   #9
dafunks
Member
 
Registered: Sep 2007
Location: UK
Distribution: Slackware 12
Posts: 62

Rep: Reputation: 15
This is the reason why I love this forum. I have been banging my head on the desk trying all sorts of things, 2 minutes to read this thread and the simple idea and the problem was solved.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
apache related problem (HTTP Error 403 - Forbidden ) spandau Linux - Networking 29 09-01-2005 06:06 PM
HTTP 403 (Forbidden) error lothario Fedora 6 02-08-2005 04:43 AM
Error 403 Forbidden access in Apache anoop_cn Linux - Software 1 09-21-2004 09:32 AM
apache error, 403 forbidden afrodocter Linux - Software 6 08-09-2004 08:35 PM
apache 403 error forbidden? bulliver Linux - General 4 01-31-2003 07:47 AM


All times are GMT -5. The time now is 10:52 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration