LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 08-04-2008, 11:54 AM   #1
rahilmaknojia
Member
 
Registered: Dec 2007
Distribution: RHEL6, CentOS6.3
Posts: 188

Rep: Reputation: 32
Squid problem


Hello,

I have problem with squid, I have made proxy server on my main PC, and I have install 1 more linux in VMware and I want to give proxy to VMware Linux.

On client PC I have done proxy setting "172.16.19.66:3128"


ON server side configuration

vi /etc/squid/squid.conf

visible_hostname rahil

acl rahil src 172.16.0.0/16
http_access allow rahil


I have restarted squid service and done squid -z its work find but on client it doesn't work it shows page cannot display
 
Old 08-04-2008, 04:38 PM   #2
dr.acul
LQ Newbie
 
Registered: Jun 2008
Location: Germany
Distribution: Gentoo/LFS
Posts: 27

Rep: Reputation: 15
As I understand, you have a linux with VMware running on it. Inside the VMware you run a second linux.
Do I have this right?

Please post your network ip's server/client and the squid.conf, because nobody can help you without your network configuration, right?

I don't know much about VMware, maybe you have to make VMware known about the proxy.

Before I forget, do you squid as a transparent proxy?

*dg*

Last edited by dr.acul; 08-04-2008 at 04:40 PM. Reason: typo...typo...typo :-)
 
Old 08-04-2008, 11:44 PM   #3
rahilmaknojia
Member
 
Registered: Dec 2007
Distribution: RHEL6, CentOS6.3
Posts: 188

Original Poster
Rep: Reputation: 32
Quote:
Originally Posted by dr.acul View Post
As I understand, you have a linux with VMware running on it. Inside the VMware you run a second linux.
Do I have this right?

Please post your network ip's server/client and the squid.conf, because nobody can help you without your network configuration, right?

I don't know much about VMware, maybe you have to make VMware known about the proxy.

Before I forget, do you squid as a transparent proxy?

*dg*

my server IP address is 172.16.19.66/16 and my client IP address is 172.16.19.85/16, and Vmware Linux is working perfect bcoz i have done dhcpd-client and done ssh everything is find with VMware, I think problem is with Server Configuration
 
Old 08-05-2008, 03:34 AM   #4
dr.acul
LQ Newbie
 
Registered: Jun 2008
Location: Germany
Distribution: Gentoo/LFS
Posts: 27

Rep: Reputation: 15
Yes, it looks like a server misconfiguration, but it is very difficult to help you without more datails.

Quote:
On client PC I have done proxy setting "172.16.19.66:3128"
Where do you have applied this setting, I assume in a browser.

Quote:
... done ssh everything is find with VMware...
Do you connect ssh directly or over squid?

Is squid working for other machines, e.g. localhost?
 
Old 08-05-2008, 04:25 AM   #5
rahilmaknojia
Member
 
Registered: Dec 2007
Distribution: RHEL6, CentOS6.3
Posts: 188

Original Poster
Rep: Reputation: 32
Quote:
Originally Posted by dr.acul View Post
Yes, it looks like a server misconfiguration, but it is very difficult to help you without more datails.


Where do you have applied this setting, I assume in a browser.


Do you connect ssh directly or over squid?

Is squid working for other machines, e.g. localhost?
how to send squid.conf file to you so u can understand better
 
Old 08-05-2008, 05:26 AM   #6
dr.acul
LQ Newbie
 
Registered: Jun 2008
Location: Germany
Distribution: Gentoo/LFS
Posts: 27

Rep: Reputation: 15
Just write me an e-mail over the bord email mechanism.

You can put the squid.conf in the email or, that would be nicer, wait for my response and reply to this email with the squid.conf as attachment.
 
Old 08-05-2008, 07:07 AM   #7
rahilmaknojia
Member
 
Registered: Dec 2007
Distribution: RHEL6, CentOS6.3
Posts: 188

Original Poster
Rep: Reputation: 32
Quote:
Originally Posted by dr.acul View Post
Just write me an e-mail over the bord email mechanism.

You can put the squid.conf in the email or, that would be nicer, wait for my response and reply to this email with the squid.conf as attachment.
I have emailed you squid.conf file, please check it if any problem let me know.

Thank you.
 
Old 08-05-2008, 08:45 AM   #8
dr.acul
LQ Newbie
 
Registered: Jun 2008
Location: Germany
Distribution: Gentoo/LFS
Posts: 27

Rep: Reputation: 15
At the first brief look I found this lines:
Code:
acl rahil src 172.16.1.0/16 
http_access allow rahil
Thats not your subnet, you should use 172.16.0.0/16 or 172.16.19.0/24

At the begin of this post you wrote:
Quote:
acl rahil src 172.16.0.0/16
http_access allow rahil
Can it be possible that only my config has this misconfiguration?

I will look more exact through your config later at home.
 
Old 08-05-2008, 11:31 AM   #9
rahilmaknojia
Member
 
Registered: Dec 2007
Distribution: RHEL6, CentOS6.3
Posts: 188

Original Poster
Rep: Reputation: 32
Quote:
Originally Posted by dr.acul View Post
At the first brief look I found this lines:
Code:
acl rahil src 172.16.1.0/16 
http_access allow rahil
Thats not your subnet, you should use 172.16.0.0/16 or 172.16.19.0/24

At the begin of this post you wrote:

Can it be possible that only my config has this misconfiguration?

I will look more exact through your config later at home.
Yes, 1st time I put 172.16.0.0/16 but it doesn't work so I changed then also it doesn't and again I put 172.16.0.0/16

I off my firewall also its seem to be nothing happen still same problem.
 
Old 08-05-2008, 12:22 PM   #10
dr.acul
LQ Newbie
 
Registered: Jun 2008
Location: Germany
Distribution: Gentoo/LFS
Posts: 27

Rep: Reputation: 15
Your config is ok, but the ip and netmask, however that should be cleared now.

Since your server configuration seems to be correct, you should check your network configuration.
I don't think that squid is the problem.
 
Old 08-05-2008, 02:08 PM   #11
rahilmaknojia
Member
 
Registered: Dec 2007
Distribution: RHEL6, CentOS6.3
Posts: 188

Original Poster
Rep: Reputation: 32
Quote:
Originally Posted by dr.acul View Post
Your config is ok, but the ip and netmask, however that should be cleared now.

Since your server configuration seems to be correct, you should check your network configuration.
I don't think that squid is the problem.
Yes, i was thinking same I will give u more information abt my server Network, My server IP address is 172.16.19.66 with netmask 255.255.0.0 and my default gateway is 172.16.1.1 this is configuration I got from my ISP to use NET but I want to give proxy to client PC, So on client side I have give proxy setting with 172.16.19.66:3128 and default gateway 172.16.19.66. I am stacked with this problem,
 
Old 08-06-2008, 11:03 AM   #12
rahilmaknojia
Member
 
Registered: Dec 2007
Distribution: RHEL6, CentOS6.3
Posts: 188

Original Poster
Rep: Reputation: 32
Do you know hoe to solve this problem, I have disable SElinux also but not working.
 
Old 08-07-2008, 12:33 AM   #13
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,627

Rep: Reputation: Disabled
Have you configured iptables to forward the requests? If its a transparent proxy then you need to configure iptables. Else start the squid. And put the ip address of squid in the web browser with the correct port number squid is running i.e 3128, the port on which your squid is running.
 
Old 08-07-2008, 08:20 AM   #14
rahilmaknojia
Member
 
Registered: Dec 2007
Distribution: RHEL6, CentOS6.3
Posts: 188

Original Poster
Rep: Reputation: 32
Quote:
Originally Posted by linuxlover.chaitanya View Post
Have you configured iptables to forward the requests? If its a transparent proxy then you need to configure iptables. Else start the squid. And put the ip address of squid in the web browser with the correct port number squid is running i.e 3128, the port on which your squid is running.

Yeah, My friend I have done all setting I will mail u my squid.conf conf to u and i have not done IPtable configuration it is default
 
Old 08-08-2008, 12:12 AM   #15
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,627

Rep: Reputation: Disabled
If its not the transparent proxy then, there is no need to configure anything. Just make sure the cache is initialized and squid is started. And do not mail the squid.conf file. Better post it here in the forum. If not me someone else will come and help you. Mailing is not a good option unless really necessary.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
a problem with squid alnmostafa Linux - Software 8 12-26-2006 11:35 PM
I Think its a SQUID problem SBN Linux - Software 1 09-18-2006 09:21 AM
Squid problem John Micheal Linux - Software 1 05-07-2005 05:26 PM
squid problem hariiyer Linux - Networking 7 01-31-2005 11:20 AM
Squid Problem !!!!! baye Linux - General 4 09-09-2004 01:09 PM


All times are GMT -5. The time now is 06:53 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration