LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
LinkBack Search this Thread
Old 11-18-2009, 05:26 AM   #1
andycol
Member
 
Registered: Jul 2009
Location: South Africa
Posts: 38

Rep: Reputation: 16
ppp0 and ppp1 keep switching around centos


Hi Guys

I hope someone can help me

my problem is i have setup 2x ppp used for adsl to split local and international bandwidth
ppp0 is using the international account
and ppp1 is using the local only account
this all works fine but every so often i notice when i do an ifconfig that ppp0 is dialed up on the local account and ppp1 is dialed up on the international one, and sometimes a reboot fixes it and sometimes it doesnt

does anyone have any ideas?

my config files are the following:

# Default ADSL network config file, as used by redhat
USERCTL=yes
PEERDNS=no
TYPE=xDSL
DEVICE=ppp0
BOOTPROTO=dialup
ONBOOT=yes
PIDFILE=/var/run/pppoe-adsl0.pid
FIREWALL=NONE
PING=.
PPPOE_TIMEOUT=80
LCP_FAILURE=3
LCP_INTERVAL=20
CLAMPMSS=1412
CONNECT_POLL=6
CONNECT_TIMEOUT=0
PERSIST=no
SYNCHRONOUS=no
DEFROUTE=yes
PROVIDER=provider
ETH=eth1
DEMAND=no
USER='myadslacc@no.co.za' (international account)

# Default ADSL network config file, as used by redhat
USERCTL=yes
PEERDNS=no
TYPE=xDSL
DEVICE=ppp1
BOOTPROTO=dialup
ONBOOT=yes
PIDFILE=/var/run/pppoe-adsl1.pid
FIREWALL=NONE
PING=.
PPPOE_TIMEOUT=80
LCP_FAILURE=3
LCP_INTERVAL=20
CLAMPMSS=1412
CONNECT_POLL=6
CONNECT_TIMEOUT=0
PERSIST=no
SYNCHRONOUS=no
DEFROUTE=no
PROVIDER=provider
ETH=eth1
DEMAND=no
USER='myadslaccount@no.local' (local account)

anyone have any ideas?

thanks
 
Old 11-18-2009, 06:38 AM   #2
GlennsPref
Senior Member
 
Registered: Apr 2004
Location: Brisbane, Australia
Distribution: Mageia Studio-13.37 Kubuntu.
Posts: 3,325
Blog Entries: 33

Rep: Reputation: 199Reputation: 199
Hi, set it the way you like and change persist=yes

Or look for the config files in /etc/sysconfig/network-scripts
and set the ip addresses for each of the ppp0 and ppp1 files

cheers Glenn
 
Old 11-23-2009, 02:12 AM   #3
andycol
Member
 
Registered: Jul 2009
Location: South Africa
Posts: 38

Original Poster
Rep: Reputation: 16
nope doesnt help

this is killing me ive looked everywhere and cant find anything
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ppp multilink doesn't combine ppp0 and ppp1 lgs Linux - Networking 0 07-08-2007 12:48 PM
Can't route traffic between ppp0 and ppp1 Jongi Debian 1 04-15-2007 05:35 AM
pppoe dialed twice - I got ppp0 and ppp1 carboncopy Linux - Networking 1 10-23-2005 01:15 AM
routing ppp0 & ppp1 hariiyer Linux - Networking 1 09-09-2005 05:48 AM
Endless Loop: ppp0 Unregister Netdevice: waiting for ppp0 to be free. oberon-ken-obi Linux - Networking 1 07-20-2004 11:04 PM


All times are GMT -5. The time now is 04:03 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration