LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 04-05-2012, 01:17 PM   #1
mwjones
LQ Newbie
 
Registered: Mar 2010
Posts: 20

Rep: Reputation: 0
Question Postfix: No AUTH?


I am trying to set up auth for postfix so I can send mail to addresses on the internet through my server. Here is the output from EHLO:

Code:
$ nc example.com 25
220 example.com ESMTP Postfix
ehlo example.com
250-example.com
250-PIPELINING
250-SIZE 10240000
250-VRFY
250-ETRN
250-STARTTLS
250-ENHANCEDSTATUSCODES
250-8BITMIME
250 DSN
So postfix is running fine and listening, but just missing the AUTH parts. Here are my postfix and dovecot infos, respectively.

Postfix config:
Code:
$ sudo postconf -n 
broken_sasl_auth_clients = yes
config_directory = /etc/postfix
home_mailbox = .system/
inet_interfaces = all
inet_protocols = ipv4
local_recipient_maps =
mailbox_command =
mailbox_size_limit = 0
mydestination = mail.example.com, localhost.localdomain, localhost
myhostname = example.com
mynetworks = 127.0.0.0/8 1.2.3.4
myorigin = /etc/mailname
recipient_delimiter = +
relayhost = mail.example.com
smtp_tls_note_starttls_offer = yes
smtpd_delay_reject = yes
smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination
smtpd_sasl_auth_enable = yes
smtpd_sasl_path = private/auth
smtpd_sasl_security_options = noanonymous
smtpd_sasl_type = dovecot
smtpd_tls_auth_only = yes
smtpd_tls_cert_file = /etc/apache2/ssl/cert-example.com.crt
smtpd_tls_key_file = /etc/apache2/ssl/example.key
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
smtpd_use_tls = yes
tls_random_source = dev:/dev/urandom
virtual_gid_maps = static:1030
virtual_mailbox_base = /home/vmail
virtual_mailbox_domains = /etc/postfix/vdomain
virtual_mailbox_maps = hash:/etc/postfix/vmailbox
virtual_minimum_uid = 1030
virtual_uid_maps = static:1030
/etc/postfix/vdomain:
Code:
$ cat /etc/postfix/vdomain
example.com
/etc/postfix/vmailbox:
Code:
$ cat /etc/postfix/vmailbox
mwjones@example.com example.com/mwjones/Maildir/
@example.com example.com/caught/Maildir/
Verifying auth socket:
Code:
$ sudo file /var/spool/postfix/private/auth
/var/spool/postfix/private/auth: socket
Dovecot config:
Code:
$ doveconf -n
# 2.0.18: /etc/dovecot/dovecot.conf
# OS: Linux 3.2.5-grsec x86_64 Debian wheezy/sid ext4
auth_debug = yes
auth_mechanisms = plain login
auth_verbose = yes
first_valid_gid = 1030
first_valid_uid = 1030
info_log_path = /var/log/dovecot-info.log
last_valid_gid = 1030
last_valid_uid = 1030
log_path = /var/log/dovecot.log
log_timestamp = "%Y-%m-%d %H:%M:%S "
mail_debug = yes
mail_location = maildir:/home/vmail/%d/%n/Maildir
passdb {
  args = /home/vmail/%d/etc/passwd
  driver = passwd-file
}
protocols = imap
service auth {
  unix_listener /var/spool/postfix/private/auth {
    group = postfix
    mode = 0660
    user = postfix
  }
}
service imap-login {
  inet_listener imap {
    port = 0
  }
  inet_listener imaps {
    address = *
    port = 993
  }
  service_count = 1
}
service ssl-params {
  type = startup
}
ssl_cert = </etc/apache2/ssl/cert-example.com.crt
ssl_key = </etc/apache2/ssl/example.key
userdb {
  args = /home/vmail/%d/etc/passwd
  driver = passwd-file
}
verbose_ssl = yes
Please let me know what other info I can provide that would be helpful.

I've been following the postfix documentation, but still get no AUTH from the daemon.
 
Old 04-06-2012, 02:48 AM   #2
Berhanie
Senior Member
 
Registered: Dec 2003
Location: phnom penh
Distribution: Fedora
Posts: 1,625

Rep: Reputation: 165Reputation: 165
Quote:
smtpd_tls_auth_only = yes
the setting above means that smtp auth is only available through tls. to verify, do the EHLO
after this:
Code:
openssl s_client -connect example.com:25 -starttls smtp
 
  


Reply

Tags
auth, postfix


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix - allow non-auth connections from local network, relay mail via SASL AUTH fantasygoat Linux - Server 1 10-14-2011 04:45 PM
Postfix AUTH pinoyskull Linux - Server 2 05-13-2009 04:21 AM
postfix smtp-auth csdhiman Linux - Server 1 05-31-2007 08:21 PM
postfix and smtp auth FragInHell Linux - Software 2 10-05-2005 06:23 AM
Postfix SMTP AUTH NetScripter Linux - Software 0 10-23-2002 01:53 AM


All times are GMT -5. The time now is 07:06 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration