LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Server (http://www.linuxquestions.org/questions/linux-server-73/)
-   -   Postfix: No AUTH? (http://www.linuxquestions.org/questions/linux-server-73/postfix-no-auth-938334/)

mwjones 04-05-2012 01:17 PM

Postfix: No AUTH?
 
I am trying to set up auth for postfix so I can send mail to addresses on the internet through my server. Here is the output from EHLO:

Code:

$ nc example.com 25
220 example.com ESMTP Postfix
ehlo example.com
250-example.com
250-PIPELINING
250-SIZE 10240000
250-VRFY
250-ETRN
250-STARTTLS
250-ENHANCEDSTATUSCODES
250-8BITMIME
250 DSN

So postfix is running fine and listening, but just missing the AUTH parts. Here are my postfix and dovecot infos, respectively.

Postfix config:
Code:

$ sudo postconf -n
broken_sasl_auth_clients = yes
config_directory = /etc/postfix
home_mailbox = .system/
inet_interfaces = all
inet_protocols = ipv4
local_recipient_maps =
mailbox_command =
mailbox_size_limit = 0
mydestination = mail.example.com, localhost.localdomain, localhost
myhostname = example.com
mynetworks = 127.0.0.0/8 1.2.3.4
myorigin = /etc/mailname
recipient_delimiter = +
relayhost = mail.example.com
smtp_tls_note_starttls_offer = yes
smtpd_delay_reject = yes
smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination
smtpd_sasl_auth_enable = yes
smtpd_sasl_path = private/auth
smtpd_sasl_security_options = noanonymous
smtpd_sasl_type = dovecot
smtpd_tls_auth_only = yes
smtpd_tls_cert_file = /etc/apache2/ssl/cert-example.com.crt
smtpd_tls_key_file = /etc/apache2/ssl/example.key
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
smtpd_use_tls = yes
tls_random_source = dev:/dev/urandom
virtual_gid_maps = static:1030
virtual_mailbox_base = /home/vmail
virtual_mailbox_domains = /etc/postfix/vdomain
virtual_mailbox_maps = hash:/etc/postfix/vmailbox
virtual_minimum_uid = 1030
virtual_uid_maps = static:1030

/etc/postfix/vdomain:
Code:

$ cat /etc/postfix/vdomain
example.com

/etc/postfix/vmailbox:
Code:

$ cat /etc/postfix/vmailbox
mwjones@example.com example.com/mwjones/Maildir/
@example.com example.com/caught/Maildir/

Verifying auth socket:
Code:

$ sudo file /var/spool/postfix/private/auth
/var/spool/postfix/private/auth: socket

Dovecot config:
Code:

$ doveconf -n
# 2.0.18: /etc/dovecot/dovecot.conf
# OS: Linux 3.2.5-grsec x86_64 Debian wheezy/sid ext4
auth_debug = yes
auth_mechanisms = plain login
auth_verbose = yes
first_valid_gid = 1030
first_valid_uid = 1030
info_log_path = /var/log/dovecot-info.log
last_valid_gid = 1030
last_valid_uid = 1030
log_path = /var/log/dovecot.log
log_timestamp = "%Y-%m-%d %H:%M:%S "
mail_debug = yes
mail_location = maildir:/home/vmail/%d/%n/Maildir
passdb {
  args = /home/vmail/%d/etc/passwd
  driver = passwd-file
}
protocols = imap
service auth {
  unix_listener /var/spool/postfix/private/auth {
    group = postfix
    mode = 0660
    user = postfix
  }
}
service imap-login {
  inet_listener imap {
    port = 0
  }
  inet_listener imaps {
    address = *
    port = 993
  }
  service_count = 1
}
service ssl-params {
  type = startup
}
ssl_cert = </etc/apache2/ssl/cert-example.com.crt
ssl_key = </etc/apache2/ssl/example.key
userdb {
  args = /home/vmail/%d/etc/passwd
  driver = passwd-file
}
verbose_ssl = yes

Please let me know what other info I can provide that would be helpful.

I've been following the postfix documentation, but still get no AUTH from the daemon.

Berhanie 04-06-2012 02:48 AM

Quote:

smtpd_tls_auth_only = yes
the setting above means that smtp auth is only available through tls. to verify, do the EHLO
after this:
Code:

openssl s_client -connect example.com:25 -starttls smtp


All times are GMT -5. The time now is 06:07 PM.