LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices



Reply
 
Search this Thread
Old 07-02-2012, 03:16 PM   #1
chrislex
LQ Newbie
 
Registered: Jul 2012
Posts: 6

Rep: Reputation: Disabled
NSLOOKUP fail..server can't find in-addr.arpa: SERVFAIL


Hey guys, I have been making configuration changes left and right, now I think I have made so many different changes that I am starting to get confused on why this isn't working. I have done several things and feel like it is in my zone files or perhaps my permissions on my keys (rndc.key) included in bind. Any suggestions would be appreciated. I can include zone files but do not want to take up a lot of space. If someone can direct me on how to insert my zones inside of a scrolling window like I see on here, that would be great..I'm as newbie to posting but check this site A LOT.
 
Old 07-02-2012, 03:25 PM   #2
Kustom42
Senior Member
 
Registered: Mar 2012
Distribution: Red Hat
Posts: 1,590

Rep: Reputation: 412Reputation: 412Reputation: 412Reputation: 412Reputation: 412
Well your nslookup is being run from a windows computer I imagine that is separate from the server. So is your issue here that your DNS entries inside of bind are not visible externally? I don't see a clear definition of your actual issue in the post can you clarify it a bit?
 
Old 07-02-2012, 04:00 PM   #3
chrislex
LQ Newbie
 
Registered: Jul 2012
Posts: 6

Original Poster
Rep: Reputation: Disabled
hope this answers the question

I am performing an nslookup on my server side as well as my windows side. The ubuntu server is giving me the error; SERVFAIL. I am trying to do an nslookup just using my server's IP and it will not find it. I am unable to find it pinging the domain as well. I hookup other machines and dhcp hands out their ip's and I am able to ping both the ip and hostname, but I cannot perform an nslookup on the ip or hostname.
 
Old 07-02-2012, 04:51 PM   #4
Noway2
Senior Member
 
Registered: Jul 2007
Distribution: Ubuntu 10.10, Slackware 64-current
Posts: 2,124

Rep: Reputation: 776Reputation: 776Reputation: 776Reputation: 776Reputation: 776Reputation: 776Reputation: 776
SERVFAIL generally indicates a problem, such as a syntax error in your zone file and Bind is rather picky about syntax. If you restart Bind do you get any warnings or errors? How about warnings or errors in your log file (on Ubuntu look in your syslog and daemon log). Then perform a query and look in the logs again. It should give you a hint towards the problem. If you are still having problems, please post your Zone file (feel free to substitute dummy addresses, but don't change the syntax your using).
 
1 members found this post helpful.
Old 07-02-2012, 05:26 PM   #5
chrislex
LQ Newbie
 
Registered: Jul 2012
Posts: 6

Original Poster
Rep: Reputation: Disabled
I do not get any errors when restarting bind. I did look at my syslog and have nothing in there. But when I look in my daemon.log file I have located a few strings of text regarding my reverse zone file: not loaded due to errors. I would have to capture the data and insert in here for you to look at if I am not supplying enough information. I am still a newbie to UNIX/Linux in general, switch from windows...should have done it a LONG time ago. Anyways, a few example lines:
ubuntuserv named[4448]: /etc/bind/zones/rev.1.168.192.in-addr.arpa:3: ignoring out-of-zone data (.)

ubuntuserv named[4448]: dns_rdata_fromtext: /etc/bind/zones/rev.1.168.192.in-addr.arpa:8: near 'Minimum': extra input text

ubuntuserv named[4448]: /etc/bind/zones/rev.1.168.192.in-addr.arpa/IN: loading from master file /etc/bind/zones/rev.1.168.192.in-addr.arpa failed: extra input text

ubuntuserv named[4448]: /etc/bind/zones/rev.1.168.192.in-addr.arpa/IN: not loaded due to errors.

BOTH my forawrd and Reverse zone files look as if they are failing. Any suggestions on what I should do? I will load my zone files in the morning when I get back to the computer, thank you so much for everyone's help!!!
 
Old 07-02-2012, 05:31 PM   #6
Kustom42
Senior Member
 
Registered: Mar 2012
Distribution: Red Hat
Posts: 1,590

Rep: Reputation: 412Reputation: 412Reputation: 412Reputation: 412Reputation: 412
Looks like syntax errors, post the contents of your zone records and we can review them to make sure they are correct.
 
1 members found this post helpful.
Old 07-02-2012, 08:38 PM   #7
chrism01
Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.6, Centos 5.10
Posts: 16,324

Rep: Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041Reputation: 2041
See if this cmd is available
Code:
service named configtest
should list all cfg syntax errors if it is
 
Old 07-03-2012, 10:43 AM   #8
chrislex
LQ Newbie
 
Registered: Jul 2012
Posts: 6

Original Poster
Rep: Reputation: Disabled
zone files

Here is my forward zone file:

file name is example.com.db

$TTL 3D
@ IN SOA ubuntuserv.example.com. root.example.com. (

2012061201; serial
28800; refresh
3600; retry
604800; expire
38400 minimum TTL
)

IN NS ubuntuserv.example.com
IN A 192.168.1.3
ubuntuserv IN A 192.168.1.3
router IN A 192.168.1.1
mail IN A 192.168.1.3
example.com. IN MX ubuntuserv.example.com.

This is my reverse zone: file name rev.1.168.192.in-addr.arpa

$TTL 3D
@ IN SOA ubuntuserv.example.com. root.example.com. (

2012061201; serial
28800; refresh
3600; retry
604800; expire
86400 minimum TTL
)

IN NS ubuntuserv.
3 IN PTR ubuntuserv.example.com.
 
Old 07-04-2012, 04:22 AM   #9
Eliransh
LQ Newbie
 
Registered: Jun 2012
Posts: 9

Rep: Reputation: Disabled
Quote:
Originally Posted by chrislex View Post
Here is my forward zone file:

file name is example.com.db

$TTL 3D
@ IN SOA ubuntuserv.example.com. root.example.com. (

2012061201; serial
28800; refresh
3600; retry
604800; expire
38400 minimum TTL
)

IN NS ubuntuserv.example.com
IN A 192.168.1.3
ubuntuserv IN A 192.168.1.3
router IN A 192.168.1.1
mail IN A 192.168.1.3
example.com. IN MX ubuntuserv.example.com.

This is my reverse zone: file name rev.1.168.192.in-addr.arpa

$TTL 3D
@ IN SOA ubuntuserv.example.com. root.example.com. (

2012061201; serial
28800; refresh
3600; retry
604800; expire
86400 minimum TTL
)

IN NS ubuntuserv.
3 IN PTR ubuntuserv.example.com.
Code:
$TTL 3D
@            IN SOA ubuntuserv.example.com. root.example.com. (

       2012061201; serial
       28800;      refresh
       3600;       retry
       604800;     expire
       86400;       minimum TTL
)
This is what you missed
 
Old 07-04-2012, 08:13 AM   #10
Noway2
Senior Member
 
Registered: Jul 2007
Distribution: Ubuntu 10.10, Slackware 64-current
Posts: 2,124

Rep: Reputation: 776Reputation: 776Reputation: 776Reputation: 776Reputation: 776Reputation: 776Reputation: 776
See this thread, in particular post #6: http://www.linuxquestions.org/questi...ements-875937/

It explains how when whitespace is used at the start of a line, that the name of the last resource record is used. Hence, with the whitespace added, it changes how the line is interpreted and additional information is automatically inserted, satisfying the formal syntax.
 
Old 07-09-2012, 03:16 PM   #11
chrislex
LQ Newbie
 
Registered: Jul 2012
Posts: 6

Original Poster
Rep: Reputation: Disabled
The configtest command was not available to determine syntax errors. I have ready noway2's response and even read up on the whitespace. However, I am not sure what is meant by the whitespace on my topic. Am I suppose to create a whitespace or take one out of my code? I what else can I put in this topic other than my zone files that will help? My dhcp works perfectly. As soon as anyone plugs into my network they are assigned an IP and my sever sees the computer name but it just doesn't log it correctly. Perhaps my keygen rndc.key isn't being used correctly? I have followed several different posts trying to correct my issue and it just doesn't seem to work as it should. At least all my commands are coming back to me from my Perl classes in college, that's a plus!!!
 
Old 07-10-2012, 04:47 AM   #12
Noway2
Senior Member
 
Registered: Jul 2007
Distribution: Ubuntu 10.10, Slackware 64-current
Posts: 2,124

Rep: Reputation: 776Reputation: 776Reputation: 776Reputation: 776Reputation: 776Reputation: 776Reputation: 776
You need to add whitespace (tabs) before certain fields in you zone file. Everything can't start in the leftmost column. Adding the tabs causes Bind to implicity define some missing syntax pieces. Here is a working example from one of my zone files. Also note which items do and do not end in a '.' (e.g. .lan versus .lan.). Feel free to copy it:
Code:
$ORIGIN .
$TTL 3600       ; 1 hour
dummy.lan              IN SOA  server.dummy.lan. admin.dummy.lan. (
                                2012031510 ; serial
                                4800       ; refresh (1 hour 20 minutes)
                                86400      ; retry (1 day)
                                86400      ; expire (1 day)
                                604800     ; minimum (1 week)
                                )
                        NS      server.dummy.lan.
                        A       192.167.0.49
$ORIGIN dummy.lan.
server2                 A       192.168.0.50
 
Old 07-11-2012, 04:29 PM   #13
chrislex
LQ Newbie
 
Registered: Jul 2012
Posts: 6

Original Poster
Rep: Reputation: Disabled
Thank you all for the replies. I went through my daemon.log and figured out what errors were occurring and where. I got my bind to load properly but now I am getting Server cannot find 1.168.192.in-addr.arpa. : NXDOMAIN. I will close this thread out and start a new one if I can't figure it out in the next few days. Once again, thank you guys!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
error: ** server can't find 79.20.168.192.in-addr.arpa: REFUSED mamtasahai1 Linux - General 17 05-07-2014 06:33 AM
[SOLVED] error "server can't find 254.0.168.192.in-addr.arpa: SERVFAIL" in dns server piyusharora420 Linux - Server 15 01-10-2011 02:06 AM
in-addr-arpa HELP!! james.farrow Linux - Networking 8 10-10-2008 03:47 AM
BIND 9 and in-addr.arpa subdomains carsten.engel Linux - Enterprise 6 07-18-2005 04:21 PM
nslookup ** server can't find homelan.home: SERVFAIL heals1ic Linux - Networking 7 05-19-2005 08:20 PM


All times are GMT -5. The time now is 11:33 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration