LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 02-16-2008, 01:40 AM   #1
mamtasahai1
Member
 
Registered: Jan 2007
Location: India
Distribution: RHEL 5, Fedora 9, Solaris, FreeBSD
Posts: 52

Rep: Reputation: 15
error: ** server can't find 79.20.168.192.in-addr.arpa: REFUSED


Dear All

I m using RHEL5 and configure DNS server on it. when I m running nslookup command from the client side it give the result:

[root@test ~]# nslookup 192.168.20.79
Server: 192.168.20.79
Address: 192.168.20.79#53

** server can't find 79.20.168.192.in-addr.arpa: REFUSED

What does it mean. it is an error or DNS?

How can i resolv it.

Please give answer.
thanks.
 
Old 02-16-2008, 01:44 AM   #2
0.o
Member
 
Registered: May 2004
Location: Raleigh, NC
Distribution: Debian, Solaris, HP-UX, AIX
Posts: 208

Rep: Reputation: 35
try this rather than nslookup:

dig -x 192.168.20.79

It should give you much more information.
 
Old 02-16-2008, 01:52 AM   #3
mamtasahai1
Member
 
Registered: Jan 2007
Location: India
Distribution: RHEL 5, Fedora 9, Solaris, FreeBSD
Posts: 52

Original Poster
Rep: Reputation: 15
I tried it, it shows:
;<<>> Dig 9.3.3rc2 <<>> -x 192.168.20.79
;; global options: printcmd
;; got answer:
;; ->>HEADER<<- opcode: QUERY, status: REFUSED, id: 45323

;; QUESTION SECTION:
;79.20.168.192.IN-ADDR.ARPA. in ptr


OUTPUT OMMITED..........


Quote:
Originally Posted by 0.o View Post
try this rather than nslookup:

dig -x 192.168.20.79

It should give you much more information.
 
Old 02-16-2008, 06:42 AM   #4
cconstantine
Member
 
Registered: Dec 2005
Distribution: RedHat, Ubuntu
Posts: 101

Rep: Reputation: 15
netfilter rules?

check your netfilter OUTPUT chain (iptables -L OUTPUT); are there any rules to permit outbound udp destined to port 53?

either a) your resolver libraries are communicating with the local dns server and it can't send the udp packets out; or b) your resolver libraries are trying to reach an across-the-network dns server and can't send out the udp packets.

probably need to
Code:
iptables -I OUTPUT (some_rule_number) -j ACCEPT -p udp --dport 53
(I'm afk until Monday, sorry)
-c

Last edited by cconstantine; 02-16-2008 at 06:43 AM.
 
Old 03-11-2011, 06:13 AM   #5
rahishkhan25
LQ Newbie
 
Registered: Feb 2011
Posts: 9

Rep: Reputation: 0
RHEL 5 Dns client side error

Dear all, please help i am faceing problem on dns client side
when i run nslookup command it says

**server can't find (name) REFUSED
please help me ,
thanks alot in advance
 
Old 03-11-2011, 06:16 AM   #6
rahishkhan25
LQ Newbie
 
Registered: Feb 2011
Posts: 9

Rep: Reputation: 0
i am on client then
[root@test ~]# nslookup pc1.example.com

Server: 192.168.0.100
Address: 192.168.0.100#53

** server can't find pc1.redhat.com: REFUSED

please help me out i am really in fix.

fyi: i can ping by ip but not with name.
if i run commands on server all works well
but this is only client side,
please let me know how to solv it
(please text in detail)
thanks a lot in advance
Rahi
 
Old 03-11-2011, 06:20 AM   #7
rahishkhan25
LQ Newbie
 
Registered: Feb 2011
Posts: 9

Rep: Reputation: 0
[root@client1 ~]# host client1.example.com
Host client1.example.com not found: 5(REFUSED)

---------- Post added 03-11-11 at 02:21 PM ----------

dear all, i will be highly oblised to you,
please tell me what should i do?
thanks a lot
 
Old 03-11-2011, 08:10 AM   #8
rahishkhan25
LQ Newbie
 
Registered: Feb 2011
Posts: 9

Rep: Reputation: 0
hi, Mr. cconstantine, i need your help please
 
Old 03-11-2011, 08:39 AM   #9
glennt11
LQ Newbie
 
Registered: Aug 2004
Location: NY
Distribution: Ubuntu,Red Hat,Centos 5
Posts: 29

Rep: Reputation: 0
Quote:
Originally Posted by rahishkhan25 View Post
[root@client1 ~]# host client1.example.com
Host client1.example.com not found: 5(REFUSED)

---------- Post added 03-11-11 at 02:21 PM ----------

dear all, i will be highly oblised to you,
please tell me what should i do?
thanks a lot
What do you have your server set up to do? By default, the server will only respond to itself on: localhost and 127.0.0.1.

In the /etc/named.conf file, have you changed these lines?
Code:
listen-on port 53 { 127.0.0.1; };
allow-query     { localhost; };
Depending on how you've set this config file up, you may have more in the zone sections that need to be changed as well...

Also, are you able to do nslookup from the server?
 
Old 03-12-2011, 04:37 AM   #10
rahishkhan25
LQ Newbie
 
Registered: Feb 2011
Posts: 9

Rep: Reputation: 0
Thanks alot dear, i really thankfull to you.

in
listen-on port 53 { 127.0.0.1; }; (inisted of 127.0.0.1 i did my dns server ip)
allow-query { localhost; }; (its same localhost, once i tried with any
but same problem.





ON CLIENT
[root@pc2 ~]# nslookup pc1.redhat.com
Server: 192.168.0.100
Address: 192.168.0.100#53

** server can't find pc1.redhat.com: REFUSED




[root@pc2 ~]# host pc1.redhat.com
Host pc1.redhat.com not found: 5(REFUSED)




[root@pc2 ~]# dig pc1.redhat.con

; <<>> DiG 9.3.3rc2 <<>> pc1.redhat.con
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: REFUSED, id: 44326
;; flags: qr rd; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;pc1.redhat.con. IN A

;; Query time: 24 msec
;; SERVER: 192.168.0.100#53(192.168.0.100)
;; WHEN: Sat Mar 12 14:06:06 2011
;; MSG SIZE rcvd: 32






[root@pc2 ~]# dig 192.168.0.100

; <<>> DiG 9.3.3rc2 <<>> 192.168.0.100
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: REFUSED, id: 10367
;; flags: qr rd; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;192.168.0.100. IN A

;; Query time: 0 msec
;; SERVER: 192.168.0.100#53(192.168.0.100)
;; WHEN: Sat Mar 12 14:06:21 2011
;; MSG SIZE rcvd: 31





ON SERVER ALL IS WELL i think so,

[root@pc1 ~]# nslookup pc1.redhat.com
Server: 192.168.0.100
Address: 192.168.0.100#53

Name: pc1.redhat.com
Address: 192.168.0.100




[root@pc1 ~]# host pc1.redhat.com
pc1.redhat.com has address 192.168.0.100





[root@pc1 ~]# dig pc1.redhat.com

; <<>> DiG 9.3.3rc2 <<>> pc1.redhat.com
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 21906
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 0

;; QUESTION SECTION:
;pc1.redhat.com. IN A

;; ANSWER SECTION:
pc1.redhat.com. 86400 IN A 192.168.0.100

;; AUTHORITY SECTION:
redhat.com. 86400 IN NS pc1.redhat.com.

;; Query time: 0 msec
;; SERVER: 192.168.0.100#53(192.168.0.100)
;; WHEN: Sat Mar 12 12:17:04 2011
;; MSG SIZE rcvd: 62



Please let me know friends where is the problem i am really in
fix. what should i do i am facing problem on clients only not on server.
i have created my private pc1.redhat.com dns server for practice.i have given nameserver 192.168.0.100 on client /etc/resolv.conf file also.
please assist me . thanks a lot in advance
 
Old 03-12-2011, 04:59 AM   #11
rahishkhan25
LQ Newbie
 
Registered: Feb 2011
Posts: 9

Rep: Reputation: 0
Dear all my configuration is follows


options {
listen-on port 53 { 192.168.0.100; };
listen-on-v6 port 53 { ::1; };
directory "/var/named";
dump-file "/var/named/data/cache_dump.db";
statistics-file "/var/named/data/named_stats.txt";
memstatistics-file "/var/named/data/named_mem_stats.txt";
query-source port 53;
query-source-v6 port 53;
allow-query { localhost; };
};
logging {
channel default_debug {
file "data/named.run";
severity dynamic;
};
};
view localhost_resolver {
match-clients { localhost; };
match-destinations { localhost; };
recursion yes;
include "/etc/named.rfc1912.zones";
};

---------- Post added 03-12-11 at 12:59 PM ----------

thanks a lot for your reply
like it
 
Old 03-12-2011, 06:58 AM   #12
rahishkhan25
LQ Newbie
 
Registered: Feb 2011
Posts: 9

Rep: Reputation: 0
allow-query { 192.168.0.100; }; (i also tried like this but same problem

please friends help me out.
thanks alot
 
Old 03-12-2011, 04:11 PM   #13
glennt11
LQ Newbie
 
Registered: Aug 2004
Location: NY
Distribution: Ubuntu,Red Hat,Centos 5
Posts: 29

Rep: Reputation: 0
Quote:
Originally Posted by rahishkhan25 View Post
allow-query { 192.168.0.100; }; (i also tried like this but same problem

please friends help me out.
thanks alot
Well here's one cause of the problem:

You want to change this line
Code:
allow-query { 192.168.0.100; };
to whatever networks are allowed to access the server for DNS. Here are some examples:

Code:
allow-query {192.168.2.1; 192.168.2.24;}; (by IP Addresses) 
allow-query { 192.168.0.0/24; }; (by networks)
allow-query { localnets; }; (I prefer this one myself, it'll allow any clients it recognizes as a network it's on to query it)
This is one reason the server can do "dig pc1.redhat.com", but the clients can't.
 
Old 03-13-2011, 06:54 AM   #14
rahishkhan25
LQ Newbie
 
Registered: Feb 2011
Posts: 9

Rep: Reputation: 0
Dear first thanks a lot for your help,
i tried with

allow-query { 192.168.0.0/24; };
allow-query { localnets; };

but still gettig same problem,
please i hope you will solv it completely.
thanks alot


what should i do netx please guide?
 
Old 03-15-2011, 06:45 AM   #15
rahishkhan25
LQ Newbie
 
Registered: Feb 2011
Posts: 9

Rep: Reputation: 0
This problem is resolved

Dear Friends,
i was having this probe but now its solved, thanks a lot Mr. Glennt for you valuable responses.
i change my "any" inisted of before one.
options {
listen-on port 53 { any; };
listen-on-v6 port 53 { ::1; };
directory "/var/named";
dump-file "/var/named/data/cache_dump.db";
statistics-file "/var/named/data/named_stats.txt";
memstatistics-file "/var/named/data/named_mem_stats.txt";
query-source port 53;
query-source-v6 port 53;
allow-query { any; };
};
logging {
channel default_debug {
file "data/named.run";
severity dynamic;
};
};
view localhost_resolver {
match-clients { any; };
match-destinations { any; };
recursion yes;
include "/etc/named.rfc1912.zones";
};
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[root@wlxxb ~]# telnet 192.168.192.12 25 Trying 192.168.192.12... telnet problem cnhawk386 Linux - Networking 1 10-10-2007 02:50 PM
pinging 192.168.0.10 from 192.168.2.101 cov Linux - Networking 12 05-03-2007 10:21 AM
What route to access daisy chained 2d router 192.168.1.1 after 192.168.0.1 (subnets?) Emmanuel_uk Linux - Networking 6 05-05-2006 01:47 AM
Is someone on my network?! ::ffff:192.168.0.10:ssh ::ffff:192.168.0.:38201 ESTABLISHE ming0 Linux - Security 4 04-12-2005 01:04 AM
[new bie] sshd: refused connect from 192.168.x.x jmcollin92 Linux - Security 2 12-14-2003 02:39 AM


All times are GMT -5. The time now is 07:22 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration