LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices



Reply
 
Search this Thread
Old 03-18-2009, 04:27 PM   #1
linuxguy08
Member
 
Registered: Apr 2008
Posts: 155
Blog Entries: 2

Rep: Reputation: 15
no valid rcpt address -smtp


When i telnet to the smtp mailserver , i get " no valid RCPT address specified " though recipient mail address is correct. AFter DATA anything i type it shows unknows command. My smtp works fine for other servers


telnet mailserver 25
...


554 no valid RCPT address specified
hello
501 Unknown command

Any help is highly appreicated!!!
Thanks
 
Old 03-18-2009, 06:47 PM   #2
archangel_617b
Member
 
Registered: Sep 2003
Location: GMT -08:00
Distribution: Ubuntu, RHEL/CentOS, Fedora
Posts: 234

Rep: Reputation: 42
Quote:
Originally Posted by linuxguy08 View Post
When i telnet to the smtp mailserver , i get " no valid RCPT address specified " though recipient mail address is correct. AFter DATA anything i type it shows unknows command. My smtp works fine for other servers


telnet mailserver 25
...


554 no valid RCPT address specified
hello
501 Unknown command

Any help is highly appreicated!!!
Thanks
Please show us a more complete session. This is an example of a good session:

http://exchange.mvps.org/smtp_frames.htm

- Arch
 
Old 03-19-2009, 05:04 PM   #3
linuxguy08
Member
 
Registered: Apr 2008
Posts: 155
Blog Entries: 2

Original Poster
Rep: Reputation: 15
I did the same steps given above but it shows the following messages and typing data command shows unknown command

571 xxxx@domainname prohibited. We do not relay
data
554 no valid RCPT address specified
hello
501 Unknown command

not sure why so

Thanks
 
Old 03-19-2009, 05:18 PM   #4
linuxguy08
Member
 
Registered: Apr 2008
Posts: 155
Blog Entries: 2

Original Poster
Rep: Reputation: 15
This is tried from one of my linux box.

[root@samepage ~]# telnet <smtp server> 25
Trying 10.10.10.2...
Connected to <smtp server > (Ip address of smtp server).
Escape character is '^]'.
220 mail server ESMTP CommuniGate Pro 4.0.6
helo mail server
250 smtp.etouch.net your name is not etouch.net
mail from: username@domainname
250 username@domainname sender accepted
rcpt to: username@domainname
571 username@domainanme prohibited. We do not relay
data
554 no valid RCPT address specified
testing
501 Unknown command

..


I have given valid email address which is being accepted from other linux server.
 
Old 03-19-2009, 05:30 PM   #5
archangel_617b
Member
 
Registered: Sep 2003
Location: GMT -08:00
Distribution: Ubuntu, RHEL/CentOS, Fedora
Posts: 234

Rep: Reputation: 42
Quote:
Originally Posted by linuxguy08 View Post
Code:
rcpt to: username@domainname
571 username@domainanme prohibited. We do not relay
Relay denied. Check what networks are permitted relay access in your mail server's config.

- Arch
 
Old 03-19-2009, 06:57 PM   #6
linuxguy08
Member
 
Registered: Apr 2008
Posts: 155
Blog Entries: 2

Original Poster
Rep: Reputation: 15
these are access configuration

[root@samepage ~]# cat /etc/mail/access

# Check the /usr/share/doc/sendmail/README.cf file for a description
# of the format of this file. (search for access_db in that file)
# The /usr/share/doc/sendmail/README.cf is part of the sendmail-doc
# package.
#
# by default we allow relaying from localhost...
localhost.localdomain RELAY
localhost RELAY
127.0.0.1 RELAY


where do i change and what changes to be done , pls clear out.

Thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
550 relay not permitted Valid RCPT command must precede DATA chiyamhad Linux - Newbie 1 03-05-2008 10:54 AM
Diablo II with cedega: no valid IP address detected JackSmith Linux - Games 2 05-21-2005 06:01 AM
!smtp and pop address for hotmail? ody1 Linux - Software 3 12-04-2002 06:02 PM
Gateway system not getting valid IP address richcoosa19 Linux - Networking 1 11-20-2002 11:15 AM
Enabling valid users to relay thru SMTP learning_slowly Linux - Networking 1 11-04-2002 05:07 PM


All times are GMT -5. The time now is 10:29 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration