LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 03-11-2010, 08:15 AM   #1
martinezpt
LQ Newbie
 
Registered: Mar 2010
Posts: 5

Rep: Reputation: 1
Cannot mount NFS share (wrong fs type, bad option, bad superblock)...


Hi!

I have a newly installed system (Debian) with an NFS share. The content of the /etc/exports file is:

Code:
/discs (insecure, rw, nohide)

I would like to mount this share on another debian machine on the same network. However, whenever I try to mount it the following happens:

Code:
server# mount -t nfs backups:/discs /mnt/temp/
mount: wrong fs type, bad option, bad superblock on backups:/discs,
       missing codepage or helper program, or other error
       (for several filesystems (e.g. nfs, cifs) you might
       need a /sbin/mount.<type> helper program)
       In some cases useful info is found in syslog - try
       dmesg | tail  or so
I've searched a lot about this and many people claim that this can be solved by installing nfs-common and portmap. However, these packages are already installed. I've even reinstalled them just to be sure.
I also don't have a "mount.nfs" command.

The strange part is that the "showmount" command correctly identifies the share:

Code:
server# showmount -e backups
Export list for backups:
/discs *

Any help would be appreciated

Last edited by martinezpt; 03-11-2010 at 08:16 AM.
 
Old 03-11-2010, 11:11 AM   #2
martinezpt
LQ Newbie
 
Registered: Mar 2010
Posts: 5

Original Poster
Rep: Reputation: 1
Question

Small Update:

I can connect to the NFS share using my Mac. This must mean that the problem is on the client side and not on the server side.

I still can't connect using my other debian machine.
 
Old 03-12-2010, 05:13 AM   #3
martinezpt
LQ Newbie
 
Registered: Mar 2010
Posts: 5

Original Poster
Rep: Reputation: 1
I've solved the issue I was having

Just to be sure that the absence of the mount.nfs command was the issue I used strace for the mount command and found the following:

Code:
stat64("/sbin/mount.nfs", 0xbff46fa0)   = -1 ENOENT (No such file or directory)
This confirmed that the mount command is indeed calling the mount.nfs which does not exist.

Then I checked and the version of "nfs-common" that apt-get was installing was not the latest one as announced on the debian web site.

So I manually downloaded the nfs-common ".deb" package, solved a dependency for the "libgssglue1" package, installed it and there it was... mount.nfs

Really can't understand why the package downloaded by "apt-get" did not install the command, but it is solved now and that is all that matters to me...

Thank you for trying...
 
Old 04-25-2010, 08:44 PM   #4
wallybsams
LQ Newbie
 
Registered: Sep 2005
Posts: 2

Rep: Reputation: 0
Martinezpt

Thank you for your post

I had to install ubuntu on one of my machines and it did not install nfs common much to my supprise

I was thinking the problem was on the sever end until I ran across your post

all is well now

wsams
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
mount: wrong fs type, bad option, bad superblock on /dev/hdc3 Lordandmaker Linux - Hardware 15 06-05-2011 08:55 AM
mount: wrong fs type, bad option, bad superblock on /dev/sda1 yekim Linux - Hardware 10 07-05-2007 11:28 AM
mount: wrong fs type, bad option, bad superblock on /dev/cdrom, Adil_uk Linux - Hardware 9 02-16-2005 05:50 PM
mount: wrong fs type, bad option, bad superblock...(cdrom,dvd and floppy) SpItoS Mandriva 14 11-12-2004 02:27 PM
mount: wrong fs type, bad option, bad superblock on /dev/sdb1 pmoreira Linux - Hardware 5 02-26-2004 10:31 AM


All times are GMT -5. The time now is 07:24 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration