LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Mandriva
User Name
Password
Mandriva This Forum is for the discussion of Mandriva (Mandrake) Linux.

Notices

Reply
 
Search this Thread
Old 05-26-2004, 05:23 PM   #1
SpItoS
Member
 
Registered: May 2004
Posts: 47

Rep: Reputation: 15
mount: wrong fs type, bad option, bad superblock...(cdrom,dvd and floppy)


Exact error : mount: wrong fs type, bad option, bad superblock on /dev/hdc, or too many mounted file systems

I tried everything, I removed supermount and tried a lot of stuff in my fstab file and there is always a new error coming up...

fstab :/dev/hdc /mnt/cdrom auto umask=0,user,iocharset=iso8859-1,codepage=850,ro,exec 0 0
/dev/hdd /mnt/cdrom2 auto umask=0,user,iocharset=iso8859-1,codepage=850ro 0 0
/dev/fd0 /mnt/floppy auto umask=0,user,iocharset=iso8859-1,sync,codepage=850 0 0

None of these worked and I googled for it and tried stuff but nothing works... If anyone can help me it would be greatly appreciated.
 
Old 05-26-2004, 06:41 PM   #2
nhs
Member
 
Registered: Aug 2003
Location: Edinburgh, Scotland
Distribution: Gentoo
Posts: 246

Rep: Reputation: 30
This most likely means that there is a syntax error in the fstab file. The most obvious error to me is a missing comma in between codepage=850 and ro. Apart from that try trimming the number of options (for example iocharset defaults to iso8859-1). Also try setting the filesystem type. For the floppy drive vfat is probably best and for the CD-ROM/DVD-ROM drives iso9660 is probably the best bet. This replaces the auto in the third column.
 
Old 05-26-2004, 10:10 PM   #3
SpItoS
Member
 
Registered: May 2004
Posts: 47

Original Poster
Rep: Reputation: 15
I still get : "mount: wrong fs type, bad option, bad superblock on /dev/hdc, or too many mounted file systems" for the cdroms and : "mount: /dev/fd0 is not a valid block device" for the floppy.
 
Old 05-27-2004, 12:29 AM   #4
kilgoretrout
Senior Member
 
Registered: Oct 2003
Posts: 2,330

Rep: Reputation: 141Reputation: 141
If your running mdk10, it now uses magicdev for automounting and won't let you mount your cd drives while it is running. Only way to stop it is:

# killall magicdev

then you can mount cd drives. If this applies and you don't like magicdev, you can uninstall it otherwise it will be back next time you boot.
 
Old 05-27-2004, 07:50 AM   #5
SpItoS
Member
 
Registered: May 2004
Posts: 47

Original Poster
Rep: Reputation: 15
Nope, I still get the same errors...
 
Old 05-27-2004, 01:56 PM   #6
nhs
Member
 
Registered: Aug 2003
Location: Edinburgh, Scotland
Distribution: Gentoo
Posts: 246

Rep: Reputation: 30
It is interesting that it says /dev/fd0 is invalid. Can you copy a disk image to the floppy (e.g. with "dd if=disk.img of=/dev/fd0"). If this fails then it would seem that there is a problem with your device files rather than the fstab file for the floppy drive and possibly for the cdrom/dvd-rom drives as well.

Last edited by nhs; 05-27-2004 at 02:00 PM.
 
Old 05-27-2004, 04:21 PM   #7
SpItoS
Member
 
Registered: May 2004
Posts: 47

Original Poster
Rep: Reputation: 15
I don't know I most likely think it's a fstab error cause before I compile a new 2.6.6 kernel it was working fine with all defaults options but I tried putting them back in and they don't work at all... I can't access the floppy at all even though when I try to mount it or mount cd-roms you see lights flashing...
 
Old 05-27-2004, 10:55 PM   #8
SpItoS
Member
 
Registered: May 2004
Posts: 47

Original Poster
Rep: Reputation: 15
We found out the problem, I had to remove umask and codepage.
 
Old 05-28-2004, 10:20 AM   #9
ocarina_of_time
LQ Newbie
 
Registered: May 2004
Location: Salina, KS, United States
Distribution: Mandrake 10.0 Official
Posts: 21

Rep: Reputation: 15
unmask and codepage

Please explain what you mean by removing "unmask and codepage" for all us n00bs. I have been getting the exact same problem. I thought it had to do with supermount. So I got a patch for it, and it still doesn't work. Please help me out here. Thanks.
 
Old 05-28-2004, 04:47 PM   #10
SpItoS
Member
 
Registered: May 2004
Posts: 47

Original Poster
Rep: Reputation: 15
Here is my old /etc/fstab file :
fstab :/dev/hdc /mnt/cdrom auto umask=0,user,iocharset=iso8859-1,codepage=850,ro,exec 0 0
/dev/hdd /mnt/cdrom2 auto umask=0,user,iocharset=iso8859-1,codepage=850ro 0 0
/dev/fd0 /mnt/floppy auto umask=0,user,iocharset=iso8859-1,sync,codepage=850 0 0

Here is my new one :
/dev/hdc /mnt/cdrom udf,iso9660 noauto,owner,kudzu,ro,exec 0 0
/dev/hdd /mnt/cdrom2 udf,iso9660 noauto,owner,kudzu,ro,exec 0 0
/dev/fd0 /mnt/floppy vfat noauto,owner,ro,exec 0 0

I removed some useless stuff and modified other but I think only removing codepage=850 and umask=0 should do the trick. Oh and don't forget to put the auto to udf,iso9660.
 
Old 05-28-2004, 04:56 PM   #11
Eagle_Y
LQ Newbie
 
Registered: May 2004
Posts: 4

Rep: Reputation: 0
i had the same problem with both the download edition and the Powerpack 10.0, but i think after editing the fstab as mentioned above you should be fine

ofcourse don't forget to run

mount -a

after editing the fstab

 
Old 07-14-2004, 10:14 AM   #12
bashrc2
Member
 
Registered: Feb 2004
Distribution: slackware 9.1
Posts: 106

Rep: Reputation: 15
/dev/cdrom /mnt/cdrom iso9660 noauto,owner,ro 0 0


here's my fstab.. and everytime i mount i get the error:

[root@slackware ~]# mount /mnt/cdrom
mount: wrong fs type, bad option, bad superblock on /dev/cdrom,
or too many mounted file systems

i also tried mount -t iso9660 but still doesnt work. im a noob..

im using slackware 9.1 with kernel2.6.7.. thanks in advance.. forgive my english.
 
Old 08-07-2004, 05:38 PM   #13
ttilt
Member
 
Registered: Dec 2003
Location: Campinas, Brasil
Distribution: slackware 10
Posts: 150

Rep: Reputation: 15
just for the record
I have the exact same problem here, with the same error msg, only removing codepage and umask doesn't work. I use mandrake9.2 and kernel 2.6.7. Here's my fstab:

/dev/hda5 / reiserfs notail 1 1
none /dev/pts devpts mode=0620 0 0
/dev/cdrom /mnt/cdrom iso9660 ro,user,noauto 0 0
/dev/floppy /mnt/floppy vfat user,noauto, 0 0
/dev/hda1 /mnt/windows vfat user,noexec,umask=0 0 0
none /proc proc defaults 0 0
/dev/hda6 swap swap defaults 0 0

ANy help would be greatly appreciated.
 
Old 11-12-2004, 12:57 PM   #14
jpcohen
LQ Newbie
 
Registered: Nov 2004
Posts: 1

Rep: Reputation: 0
user =>

Hi, just remove iocharset and codepage and change "user" to "owner". It worked for me. Hope it will do the trick for u.
 
Old 11-12-2004, 03:27 PM   #15
nafan
Member
 
Registered: May 2004
Location: /dev/bed
Distribution: Mandriva 2009.0 Powerpack
Posts: 172

Rep: Reputation: 30
It might also be beneficial to change the reference to the cdrom drive to point to the actual device.

eg, if your cdrom is actually at /dev/hdb use:
/dev/hdb /mnt/cdrom iso9660 ro,user,noauto 0 0

instead of:
/dev/cdrom /mnt/cdrom iso9660 ro,user,noauto 0 0
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem mounting CD-ROM: wrong fs type, bad option, bad superblock on /dev/cdrom Oooska Linux - Newbie 7 07-10-2013 12:37 PM
mount: wrong fs type, bad option, bad superblock on /dev/hdc3 Lordandmaker Linux - Hardware 15 06-05-2011 09:55 AM
mount: wrong fs type, bad option, bad superblock on /dev/cdrom, Adil_uk Linux - Hardware 9 02-16-2005 06:50 PM
mount: wrong fs type, bad option, bad superblock on /dev/sdb1 pmoreira Linux - Hardware 5 02-26-2004 11:31 AM
wrong fs type, bad option, bad superblock on /dev/cdrom, or too many mounted file sy TheCyberDude Linux - Software 1 02-11-2002 01:44 PM


All times are GMT -5. The time now is 07:46 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration