Review your favorite Linux distribution.
Go Back > Forums > Linux Forums > Linux - Security
User Name
Linux - Security This forum is for all security related questions.
Questions, tips, system compromises, firewalls, etc. are all included here.


  Search this Thread
Old 02-03-2008, 10:52 AM   #1
Registered: Jul 2006
Location: Belgium
Distribution: Debian, Fedora, CentOS, Windows
Posts: 361

Rep: Reputation: Disabled
pam authentication for keyring with thinkfinger

Hi all,

I need some help. I have been trying to figure out how to set up thinkfinger to log in and grant access to the keyring. I can get thinkfinger running, but after that I need to enter my password to access the keyring. I also was able to log in with a password (not using After that I can log in and get access to my keyring. When I try to combine both the closest I get is that at the log on prompt I have to enter my password, followed by entering my password again or swipe my finger over the scanner.
I read on several pages that this would be a bug in gnome_keyring_pam, but I am not using that (although tried it). I followed the guides I found about this subject, but none really talked about this issue. Does anyone know how I can get to log on with thinkfinger and after that pass the authentication to the keyring by just logging in once? I am using Fedora 8 on a Lenovo Thinkpad T61p. Below you can find my system-auth and gdm.

# This file is auto-generated.
# User changes will be destroyed the next time authconfig is run.
auth        required
auth	    sufficient
auth        sufficient nullok try_first_pass
auth        requisite uid >= 500 quiet
auth        required

account     required
account     sufficient
account     sufficient uid < 500 quiet
account     required

password    requisite try_first_pass retry=3
password    sufficient md5 shadow nullok try_first_pass use_authtok
password    required

session     optional revoke
session     required
session     [success=1 default=ignore] service in crond quiet use_uid
session     required
auth     [success=done ignore=ignore default=bad]
auth       required
auth	   optional try_first_pass
auth       include     system-auth
#auth       optional
account    required
account    include     system-auth
password   include     system-auth
session    required close
session    include     system-auth
session    required
session    optional
session    required open
session    optional force revoke
session    required
session    optional auto_start
#session    optional auto_start
Old 02-25-2010, 07:47 AM   #2
LQ Newbie
Registered: Feb 2010
Posts: 1

Rep: Reputation: 0
Anyone found a solution to this issue

Old 02-25-2010, 01:24 PM   #3
Registered: Jul 2006
Location: Belgium
Distribution: Debian, Fedora, CentOS, Windows
Posts: 361

Original Poster
Rep: Reputation: Disabled
Nope, I gave up on it. This was/is a bug in the software. I never tried this again. The only solution I found was very insecure. You needed to store the gnome-keyring password in some file.


keyring, pam

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
pam radius authentication danieldinu Linux - Security 2 07-17-2009 01:56 PM
PAM Authentication Issue SVI SUSE / openSUSE 2 09-27-2007 01:28 PM
VNC with PAM authentication? make Linux - Software 2 06-07-2005 02:45 AM
PAM Pop3 Authentication vijaykcm Linux - Security 3 12-27-2004 11:38 AM
python pam authentication shakeeb Programming 0 09-15-2004 03:57 AM

All times are GMT -5. The time now is 06:03 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration