LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-06-2003, 10:30 PM   #1
creeping.death
LQ Newbie
 
Registered: Jun 2003
Posts: 8

Rep: Reputation: 0
Angry XFConfig86 - Display Resolution


I've been pulling my hair out the last 3 hours tryng to get X to run at a larger resolution. (800x600 or larger). Here's my XFConfig86 file. Can someone point out to me what I'm doing wrong?

Section "ServerLayout"
Identifier "XFree86 Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
RgbPath "/usr/X11R6/lib/X11/rgb"
ModulePath "/usr/X11R6/lib/modules"
FontPath "/usr/X11R6/lib/X11/fonts/misc/"
FontPath "/usr/X11R6/lib/X11/fonts/Speedo/"
FontPath "/usr/X11R6/lib/X11/fonts/Type1/"
FontPath "/usr/X11R6/lib/X11/fonts/CID/"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/"
EndSection

Section "Module"
Load "dbe"
Load "dri"
Load "extmod"
Load "glx"
Load "record"
Load "xtrap"
Load "speedo"
Load "type1"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "keyboard"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/mouse"
EndSection

Section "Monitor"
DisplaySize 800 600 # mm
Identifier "Monitor0"
VendorName "OEC"
ModelName "706"
Option "DPMS"
EndSection

Section "Device"
### Available Driver options are:-
### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
### [arg]: arg optional
#Option "SWcursor" # [<bool>]
#Option "HWcursor" # [<bool>]
#Option "NoAccel" # [<bool>]
#Option "ShowCache" # [<bool>]
#Option "ShadowFB" # [<bool>]
#Option "UseFBDev" # [<bool>]
#Option "Rotate" # [<str>]
#Option "VideoKey" # <i>
#Option "FlatPanel" # [<bool>]
#Option "FPDither" # [<bool>]
#Option "CrtcNumber" # <i>
Identifier "Card0"
Driver "nv"
VendorName "nVidia Corporation"
BoardName "NV5 [RIVA TNT2/TNT2 Pro]"
BusID "PCI:1:0:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1280x1024" "800x600" "640x480"
ViewPort 0 0
EndSubSection
EndSection

Thanks,

CD
 
Old 06-06-2003, 11:09 PM   #2
totalcommand
LQ Newbie
 
Registered: Aug 2001
Posts: 23

Rep: Reputation: 15
change the line
Driver "nv"

to

Driver "nvidia"
 
Old 06-07-2003, 12:23 AM   #3
creeping.death
LQ Newbie
 
Registered: Jun 2003
Posts: 8

Original Poster
Rep: Reputation: 0
No go, It bails with the error message:

(EE) Failed to load module "nvidia" (module does not exist, 0)
(EE) No drivers available.

Do you know where I can find a list of available drivers to tryout?
CD
 
Old 06-07-2003, 12:45 AM   #4
Howloweener
LQ Newbie
 
Registered: Apr 2003
Distribution: Mandrake 9.1 and Arch Linux
Posts: 20

Rep: Reputation: 0
you need to get the nvidia driver installation tool from the nvidia web-site.

top left tab should be drivers, then select linux IA32 and download the driver package. When thats done hop inot you command-line and go to where you downloaded the package to an run:

sh NVIDIA-whatever.run

it'll run an installation program, installing the drivers. then make sure you have that line where the nv is listed and make sure it says nvidia. I think that would do it.

BTW I don't know what the View Port 0 0 is, if you know leave it, otherwise I would uncomment it #
 
Old 06-07-2003, 12:47 AM   #5
Howloweener
LQ Newbie
 
Registered: Apr 2003
Distribution: Mandrake 9.1 and Arch Linux
Posts: 20

Rep: Reputation: 0
BTW the wes site is www.nvidia.com and their support fourm is at

http://www.nvnews.net/vbulletin/foru...?s=&forumid=14

I think that'll do it. Good Luck
 
Old 06-07-2003, 09:33 AM   #6
creeping.death
LQ Newbie
 
Registered: Jun 2003
Posts: 8

Original Poster
Rep: Reputation: 0
Thanks, It's still not working right though.

I installed the drivers, and changed the Driver line to "nvidia". (And removed the ViewPort line). I read the README that came with the install and it told me to remove the Load "dri" in the Module section, so I did. X starts up fine, and displays a nice nVidia splash screen, but my resolution is still way below 800x600. What am I still missing?

CD
 
Old 06-07-2003, 10:45 AM   #7
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,085

Rep: Reputation: 398Reputation: 398Reputation: 398Reputation: 398
If you have the NVIDIA splash screen, the drivers are working. Well done.

You can change the resolution by <CTRL><ALT> and <+> or <-> on the numeric pad.

If your preferred resolution is then not centered properly, there is a handy little utility: xvidtune. Open a console in X, type xvidtune, a window opens for you to adjust the screen (carefully!). When it is OK, click SHOW. A line like this will be printed in the console window you started xvidtune from:

"1280x1024" 157.50 1280 1360 1520 1716 1024 1029 1032 1072 +hsync +vsync

Copy it (YOUR line, not the one above!) to the Section "Monitor" bit of /etc/X11/XF86Config-4, commenting out the previous lines like it.

Hope this helps
 
Old 06-07-2003, 10:56 AM   #8
chem1
Member
 
Registered: Jun 2002
Location: White House, Washignton DC
Distribution: Red Hat 9
Posts: 270

Rep: Reputation: 30
Very easy
Set your monitor to a frequency of 70Hz. The resolution will then stay at 800 x 600 or more. I had the same problem.

Hope that helps...
 
Old 06-07-2003, 12:47 PM   #9
Rick422
Member
 
Registered: Apr 2003
Location: Arizona
Distribution: Red Hat Linux 9
Posts: 158

Rep: Reputation: 30
I am not sure if what others posted above solved your problem or not but here are a few of my thoughts. In your XF86Config file but I am suspicious of one line in Section "Monitor". In that section one line says "DisplaySize 800 600 # mm" I do not know what version of Linux you are using but that is entirely different than what I have in that file with Red Hat 9. Just for comparison is a portion of my XF86Config file. I am not yet an expert at reading and editing hte XF86Config file. Notice that I also use the "nv"driver for my slighly older nVidia video card. If you decide to manually edit that file in some way be sure to save a backup copy of the file under a different name first. Some people manually edit that file themselves and others run one of several programs that that help them meke the changes. The program you would run to do that would in some cases depend on what version of Linux you are using. It looks to me like the description of your monitor may be somewhat vague and/or generic. That might or might not be the problem. I do not know what every entry in the monitor section means, although it looks way different than what is in my file.

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "PHILIPS 109B"
DisplaySize 360 270
HorizSync 30.0 - 97.0
VertRefresh 50.0 - 160.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nv"
VendorName "Videocard vendor"
BoardName "NVIDIA GeForce 2 MX (generic)"
VideoRam 65536
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
EndSection
 
Old 06-07-2003, 12:51 PM   #10
Rick422
Member
 
Registered: Apr 2003
Location: Arizona
Distribution: Red Hat Linux 9
Posts: 158

Rep: Reputation: 30
What I posted just above is a portion of my XF86Config file for comparison purposes. I was not sure if I had made that clear. It is just for comparison purposes and works fine. I wanted to show how different his "Monitor Section" was from my "Monitor Section."
 
Old 06-07-2003, 03:59 PM   #11
creeping.death
LQ Newbie
 
Registered: Jun 2003
Posts: 8

Original Poster
Rep: Reputation: 0
thanks for everyone's suggestions. I still got nothing though.

I tried the xvidtune, but i wasn't able to change the screen resolution anywhere. It's stuck at 640x480.

The CTRL-ALT ( + | - ) doesn't do anything.

Nor, was I able to figgure out how to set my monitor to 70Hz.

Any suggestions?

CD
 
Old 06-07-2003, 05:06 PM   #12
emetib
Member
 
Registered: Feb 2003
Posts: 482

Rep: Reputation: 33
what distro are you using?
 
Old 06-07-2003, 05:27 PM   #13
creeping.death
LQ Newbie
 
Registered: Jun 2003
Posts: 8

Original Poster
Rep: Reputation: 0
Red Hat 9
 
Old 06-07-2003, 06:08 PM   #14
Rick422
Member
 
Registered: Apr 2003
Location: Arizona
Distribution: Red Hat Linux 9
Posts: 158

Rep: Reputation: 30
I also use Red Hat 9, do you use Gnome or KDE? I have both installed but use Gnome by default. So anyway, I am using Gnome at the moment and I can click on the Red Hat Icon, then click on System Settings and then click on Display. It will then usually ask for the root users password and after giving it that two tabs appear that allow setting various features of the video card and monitor. Have you tried that? Do you have that installed and available to be used?
 
Old 06-07-2003, 06:45 PM   #15
emetib
Member
 
Registered: Feb 2003
Posts: 482

Rep: Reputation: 33
that's what i would be doing. try and use the gui tools for that one.

good luck
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
display resolution help saiz66 Slackware 10 10-20-2005 11:08 PM
display resolution dhlawrence Linux - General 2 09-16-2005 07:27 PM
X display resolution after logout amwink Slackware 14 04-07-2005 06:35 PM
Why does the only resolution I need, only display garbage? Wayne_Zombie Linux - Hardware 5 05-19-2004 10:58 AM
display resolution Jenifer Linux - Newbie 4 04-23-2001 10:24 PM


All times are GMT -5. The time now is 08:20 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration