LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 07-14-2005, 02:23 AM   #1
hanasi
Member
 
Registered: Jul 2005
Distribution: SUSE Linux v9.2
Posts: 85

Rep: Reputation: 15
XF86Config/xorg.conf ....?


I have been told that I can configure KDE on my new SUSE system by using XFConfig/xorg.config, so that I can use all four buttons on my trackball. Unfortunately, the source of this suggestion offered no hint of how to do this, or even where to find this file (for which I have searched unsuccessfully).

Can someone illuminate the darkness?
 
Old 07-14-2005, 02:53 AM   #2
Hosiah
Member
 
Registered: Sep 2004
Location: Des Moines, Iowa
Distribution: Slackware, Mandriva, Debian derivatives, +BSD/ Solaris/ Minix/ plan9/ GNU/HURD...
Posts: 185

Rep: Reputation: 30
ah...I had exactly the same issue with Slackware 10.1 not recognizing my scrollwheel. After a *lot* of searching the web, I found out I needed to add a couple lines to my /etc/X11/xorg.conf file:

Right after the line:
option "Device" "/dev/mouse"

I put:
option "Buttons" "5"
option "ZAxisMapping" "4 5"

and the tutorial I found also says (if my scribbled notes are correct):

For a 7-button mouse, you say,

option "Buttons" "7"
option "ZAxisMapping" "6 7"

and in addition for 7-button mice, you have to create a file called .Xmodmap in /etc/X11/xinit/
which just says:

pointer = 1 2 3 6 7 4 5

Note the order of these numbers!

Hope this helps, but I don't know if Xorg on Slackware works the same as on Suse. If not, try searching some more using some of the terms I've presented here - xorg is still young compared to XF86Config, it'll be some time before the kinks are worked out!

PS Geez, I've been using Emacs so much tonight, I just tried to post this by hitting Ctrl-X Ctrl-S !
 
Old 07-14-2005, 03:38 AM   #3
hanasi
Member
 
Registered: Jul 2005
Distribution: SUSE Linux v9.2
Posts: 85

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by Hosiah
ah...I had exactly the same issue with Slackware 10.1 not recognizing my scrollwheel. After a *lot* of searching the web, I found out I needed to add a couple lines to my /etc/X11/xorg.conf file:

Right after the line:
option "Device" "/dev/mouse"

I put:
option "Buttons" "5"
option "ZAxisMapping" "4 5"

and the tutorial I found also says (if my scribbled notes are correct):

For a 7-button mouse, you say,

option "Buttons" "7"
option "ZAxisMapping" "6 7"

and in addition for 7-button mice, you have to create a file called .Xmodmap in /etc/X11/xinit/
which just says:

pointer = 1 2 3 6 7 4 5

Note the order of these numbers!

Hope this helps, but I don't know if Xorg on Slackware works the same as on Suse. If not, try searching some more using some of the terms I've presented here - xorg is still young compared to XF86Config, it'll be some time before the kinks are worked out!

PS Geez, I've been using Emacs so much tonight, I just tried to post this by hitting Ctrl-X Ctrl-S !

Many thanks for your reply, much more explicit and therefore more helpful than the suggestion I asked about.
 
Old 07-14-2005, 10:27 AM   #4
Psibur
LQ Newbie
 
Registered: Jul 2004
Location: . <-- You Are Here
Distribution: Slackware 2.4.30
Posts: 20

Rep: Reputation: 0
Quote:
Originally posted by Hosiah

PS Geez, I've been using Emacs so much tonight, I just tried to post this by hitting Ctrl-X Ctrl-S !
You are not alone, my friend. I've had a hard time lately not using vi's [ESC]wq to save the messages.
 
Old 07-14-2005, 11:04 AM   #5
hanasi
Member
 
Registered: Jul 2005
Distribution: SUSE Linux v9.2
Posts: 85

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by Hosiah
ah...I had exactly the same issue with Slackware 10.1 not recognizing my scrollwheel. After a *lot* of searching the web, I found out I needed to add a couple lines to my /etc/X11/xorg.conf file:!
What I've learned since I read your reply is that I'm further in the dark than I had thought. Let us count the ways:

1) I had mentioned that I had been told to modify a file called XF86Config/xorg.conf. Your reply puts xorg.conf in a different directory, /etc/X11. What is the connection between these two directories, and how should a more experienced user know to connect the two? The sadly deficient book tht the DVD came in mentions XF86Config enthusiastically, but fails to say anything useful about finding it.

2) By any name at all, I have not been able to locate thies xorg.conf file, although I have devoted half a day to the search. Where is the bloody thing?

3) In the short time I have been using SUSE, I have had no difficulty in switching from my home directory to /root. Today, in the process of looking for the elusive xorg.conf file, I went through the same moves, but /root came up in the form of a Full Screen YaST, which is not what I had in mind. I cannot explain the change. And when I close YaST in the hope of being able to start a Terminal, that is the end of /root, and I am back to my own home directory. Why has this instability appeared, and what can I do to get a normal /root screeen back?
 
Old 07-14-2005, 11:22 AM   #6
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
Quote:
Originally posted by hanasi
2) By any name at all, I have not been able to locate thies xorg.conf file, although I have devoted half a day to the search. Where is the bloody thing?
I can't answer your other questions, but you could open a terminal and type "locate xorg.conf" (without the quotes). If it comes back with nothing, the file doesn't exist on your system. You could do a "locate XF86Config" too. Remember, filenames are case-sensitive.
 
Old 07-14-2005, 12:16 PM   #7
Hosiah
Member
 
Registered: Sep 2004
Location: Des Moines, Iowa
Distribution: Slackware, Mandriva, Debian derivatives, +BSD/ Solaris/ Minix/ plan9/ GNU/HURD...
Posts: 185

Rep: Reputation: 30
Quote:
do a "locate XF86Config"
Yeah, but be sure to do "updatedb" first. For which you must run as root. (or su)

Unfortunately, I couldn't tell you where Suse keeps it's files! That's one distro I've never tried, nor any dirivative thereof.

X11, X11R6, XF86.....these are all related to the "X" windows manager, the de facto standard throughout the Unix/Linux world, and I think even BSD. "X" is named after it's predecessor, "W" which stood for "window manager"! It was released (and/or it escaped) from MIT labs. Even Linux fanatics make fun of the system (fortune cookie files usually have a slew of jokes about X). X is actually just a system of graphics-device function calls, the next worst thing to doing it yourself in a C program using a VGA library. The idea is so we can build custom-designed window managers on top of it, hence the slew of desktop environments ranging from TWM to Blackbox/Fluxbox (my current fave!!!) to KDE. The part that backfires is that, since X gives you the freedom to come up with your own method to interact with it, every distro (and sometimes every release of every distro) cheerfully invents it's own unique, wacky method and leaves you to guess what it is!
 
Old 07-14-2005, 01:00 PM   #8
hanasi
Member
 
Registered: Jul 2005
Distribution: SUSE Linux v9.2
Posts: 85

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by Hosiah
Yeah, but be sure to do "updatedb" first. For which you must run as root. (or su)

Unfortunately, I couldn't tell you where Suse keeps it's files! That's one distro I've never tried, nor any derivative thereof.
I'll try to remember that when I am able to run as root. I have found no way to stop YaST without blowing the root user off. Also, the root user has forgotten the left-handed mouse configuration that I set.

Not knowing that I had to updatedb first, I tried to use "locate" to find this file. The reaction of SUSE was: "bash: locate: Cannot find command locate"

I interpret this as meaning that bash is indeed installed, which I remember doing, and that it is telling me that it doesn't know what "locate" is. How can this be, and what can I do about it?
 
Old 07-14-2005, 01:10 PM   #9
Hosiah
Member
 
Registered: Sep 2004
Location: Des Moines, Iowa
Distribution: Slackware, Mandriva, Debian derivatives, +BSD/ Solaris/ Minix/ plan9/ GNU/HURD...
Posts: 185

Rep: Reputation: 30
I think you'll probably want to go to a more distro-specific forum, try http://www.linuxquestions.org/questi...php?forumid=60

the Suse/Novell forum on this site. Disabled root and not having locate installed, you need some more knowledgeble bailing out! On some systems, you'd say "slocate", but I have no idea what on Earth's going on with your situation.

I'm starting to become glad I never tried Suse! It sounds uncooperative.
 
Old 07-14-2005, 01:11 PM   #10
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
I'm not sure how SuSe's package management works, but you need to have the GNU Findutils package installed to use locate. I would have thought it'd be installed automatically though, like Coreutils :/. Does the "updatedb" command work? If so, that should mean that Findutils is installed because updatedb is part of that package.
 
Old 07-15-2005, 01:14 AM   #11
J.W.
LQ Veteran
 
Registered: Mar 2003
Location: Milwaukee, WI
Distribution: Mint
Posts: 6,642

Rep: Reputation: 69
I'm pretty sure Suse v9.2 uses XF86Config, which should be found in the /etc/X11 directory. You will want to edit it to add the 'ZAxisMapping' line if it does not already exist. The comments Hosiah posted should work. Good luck with it; post back if you run into problems -- J.W.
 
Old 07-15-2005, 02:22 AM   #12
hanasi
Member
 
Registered: Jul 2005
Distribution: SUSE Linux v9.2
Posts: 85

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by J.W.
I'm pretty sure Suse v9.2 uses XF86Config, which should be found in the /etc/X11 directory. You will want to edit it to add the 'ZAxisMapping' line if it does not already exist. The comments Hosiah posted should work. Good luck with it; post back if you run into problems -- J.W.

You can bet on it.

But at the moment, the major problem is the matter of YaST coming up in the root session, hogging it with a Full Screen display, and forgetting/ignoring the root configuration that I had previously set.

I'm going to try the "sudo updatedb" suggestion later today.

Thanks...
 
Old 07-15-2005, 11:41 AM   #13
cuiq
Member
 
Registered: Aug 2004
Location: Philly
Distribution: Debian Lenny, FreeBSD
Posts: 577

Rep: Reputation: 30
Hosiah,

Thanks for that info. I have a four button trackball which I never used to it's full capacity. This is greatly appreciated.
 
Old 07-15-2005, 12:07 PM   #14
hanasi
Member
 
Registered: Jul 2005
Distribution: SUSE Linux v9.2
Posts: 85

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by Hosiah
ah...I had exactly the same issue with Slackware 10.1 not recognizing my scrollwheel. After a *lot* of searching the web, I found out I needed to add a couple lines to my /etc/X11/xorg.conf file:

Right after the line:
option "Device" "/dev/mouse"

I put:
option "Buttons" "5"
option "ZAxisMapping" "4 5"

and the tutorial I found also says (if my scribbled notes are correct):

For a 7-button mouse, you say,

option "Buttons" "7"
option "ZAxisMapping" "6 7"

and in addition for 7-button mice, you have to create a file called .Xmodmap in /etc/X11/xinit/
which just says:

pointer = 1 2 3 6 7 4 5

Note the order of these numbers!

Hope this helps, but I don't know if Xorg on Slackware works the same as on Suse. If not, try searching some more using some of the terms I've presented here - xorg is still young compared to XF86Config, it'll be some time before the kinks are worked out!

PS Geez, I've been using Emacs so much tonight, I just tried to post this by hitting Ctrl-X Ctrl-S !

I've succeeded in finding the configuration file, and (my face is red) have found that the lines you suggest adding are already present. This never occured to me. I have two questions:

1) As in your example above, the number of buttons is given as 5. Why, for a 4-button trackball?

2) Now that I see that the trackball has been identified properly, even to all its buttons, how do I go about assigning functions to the two "extra" buttons?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
XF86Config / xorg.conf legacyboy Linux - Software 1 06-29-2005 03:48 PM
why is there xorg.conf and XF86Config n175uj Linux - Newbie 2 06-21-2005 10:07 PM
XF86Config-4 and xorg.conf dx0r515t Slackware 3 02-04-2005 04:10 PM
Use XF86Config instead of xorg.conf zchoyt Linux - Newbie 10 09-07-2004 07:12 AM
edit xorg.conf rather than XF86Config? ICO Slackware 2 07-25-2004 11:17 AM


All times are GMT -5. The time now is 05:33 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration