LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 09-06-2004, 02:02 PM   #1
zchoyt
Member
 
Registered: Feb 2003
Location: Boise ID
Distribution: fedora
Posts: 156

Rep: Reputation: 30
Use XF86Config instead of xorg.conf


I have an XF86Config file that I was using on fedora core 1. I installed core 2 and it is using xorg.conf.

The xorg.conf file isn't setup for my laptop (dell 8600 widesreen). I would like it if I could just use the XFConfig file insead. Is there a way to tell linux to use XF86Config instead?



Also (I think this is related), I can't compile with glut. It keeps trying to use freeglut and that is causing me problems.) Anyways, if you could tell me how to use XF86Config instead of xorg.cong would be appreciated.
 
Old 09-06-2004, 02:11 PM   #2
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 65
You will need to install XFree86 instead of X.org
 
Old 09-06-2004, 02:25 PM   #3
zchoyt
Member
 
Registered: Feb 2003
Location: Boise ID
Distribution: fedora
Posts: 156

Original Poster
Rep: Reputation: 30
How would I go about doing that? Is this something on the disks?
 
Old 09-06-2004, 03:20 PM   #4
quatsch
LQ Addict
 
Registered: Aug 2003
Location: New York, NY
Distribution: gentoo, gentooPPC
Posts: 1,661

Rep: Reputation: 47
it's no problem. You just have to rename the XFree86 config file to xorg.conf and put it in the right place (i.e. in the /etc/X11 directory).
 
Old 09-06-2004, 11:04 PM   #5
zchoyt
Member
 
Registered: Feb 2003
Location: Boise ID
Distribution: fedora
Posts: 156

Original Poster
Rep: Reputation: 30
That's what I came up with. The documentation says that both files have the same syntax.

SO..... I renamed the file and rebooted. It couldn't start Xserver. It seems to be having problems with the mouse input device. Hmmm.... Any advice? Would you like me to post the file?
 
Old 09-06-2004, 11:14 PM   #6
zchoyt
Member
 
Registered: Feb 2003
Location: Boise ID
Distribution: fedora
Posts: 156

Original Poster
Rep: Reputation: 30
By the way... is there a way to restart X server without rebooting?
 
Old 09-06-2004, 11:18 PM   #7
quatsch
LQ Addict
 
Registered: Aug 2003
Location: New York, NY
Distribution: gentoo, gentooPPC
Posts: 1,661

Rep: Reputation: 47
I'm sure someone can help you if you post the file.

Also, I think X.org can run without xorg.conf in which case it will try to configure itself on the fly. It might be worth a shot. There also are xorgcfg and xrgconfig for configuring X.
 
Old 09-06-2004, 11:53 PM   #8
zchoyt
Member
 
Registered: Feb 2003
Location: Boise ID
Distribution: fedora
Posts: 156

Original Poster
Rep: Reputation: 30
OK: Here are the two files.
XF86Config
xorg.conf

Summary of the problem:
The XF86Config worked PERFECTLY on core1 (keyboard, mouse, and widescreen).
I renamed the XF86 file as xorg.conf and rebooted. It wouldn't even start Xserver (stating some error about the input devices).

I hacked on the file and finally got x server to start, but there are still problems.

1. It isn't supporting widescreen. When I try to changed the settings (expecting 1920X1200), all that is available is 1900x1440. This puts the toolbar with the redhad off of the bottom of the screen. I need it to support widescreen.

2. It is coming up with a popup error on startup. Something about the keyboard. The keyboard works fine, but if I could get rid of the popup that would be great.

Any help, please


thx
 
Old 09-07-2004, 12:08 AM   #9
zchoyt
Member
 
Registered: Feb 2003
Location: Boise ID
Distribution: fedora
Posts: 156

Original Poster
Rep: Reputation: 30
The popup messagebox says

to report the result of :
xprop -root | grep XKB
which is:

_XKB_RULES_NAMES_BACKUP(STRING) = "xfree86", "pc105", "us", "", ""
_XKB_RULES_NAMES(STRING) = "xfree86", "pc105", "us", "", ""



gconftool-2 -R /desktop/gnome/peripherals/keyboard/xkb
which is:

layouts = [us]
model = pc105
overrideSettings = false
options = []


Just in case this info helps.

Thx
 
Old 09-07-2004, 12:09 AM   #10
zchoyt
Member
 
Registered: Feb 2003
Location: Boise ID
Distribution: fedora
Posts: 156

Original Poster
Rep: Reputation: 30
I also tried to remove xorg.conf and allow the system to configure itself....no go. Came up with the mouse error (I am guessing cause it's not a PS2 mouse)
 
Old 09-07-2004, 08:12 AM   #11
quatsch
LQ Addict
 
Registered: Aug 2003
Location: New York, NY
Distribution: gentoo, gentooPPC
Posts: 1,661

Rep: Reputation: 47
it might not like the xfree86 in the XKB_RULES. Can you start x if you remove it in the conf file?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
XF86Config/xorg.conf ....? hanasi Linux - Newbie 13 07-15-2005 01:07 PM
XF86Config / xorg.conf legacyboy Linux - Software 1 06-29-2005 04:48 PM
why is there xorg.conf and XF86Config n175uj Linux - Newbie 2 06-21-2005 11:07 PM
XF86Config-4 and xorg.conf dx0r515t Slackware 3 02-04-2005 05:10 PM
edit xorg.conf rather than XF86Config? ICO Slackware 2 07-25-2004 12:17 PM


All times are GMT -5. The time now is 07:05 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration